Link to home
Create AccountLog in
Avatar of jcmurphy777
jcmurphy777Flag for Australia

asked on

USB storage not showing in my computer

We are in the middle of a windows 7 development in a network environment, 2008 R2 domain controllers.

the issue i am seeing is that when a standard user (domain user) is logged into the vm, a USB storage device, (thumb drive or larger) can be plugged in, and it appears under devices, however the drive is not accessable inside my computer.

the hardware wizard on drive insertion, says it installed correctly etc.

i am trying to track down what policy i may have enabled that would in effect cause the issue.

any ideas...
Avatar of jcmurphy777
jcmurphy777
Flag of Australia image

ASKER

forgot to add it happens under domain admins as well, so im pretty sure its a policy for all user or machine wide.

i have the below User policy "Default behavior for AutoRun" set to "Do not execute any autorun commands"

wasnt sure if that would stop the drive mapping or just showing the autorun menu. (which is what we want to do)
Right click on my computer and click manage.
Go to disk management
Check if the USB drive is showing there and has a drive letter assigned to.
under admin i checked and the drive (doesnt matter what type), is appearing, but no drive allocation.

when i try and change the drive, it says the operation failed to complete because the Disk management console view is not up-to-date refresh it by using the refresh task.

however that doesnt help

i dont think i mentioned a possible major environment setup.

we use vmware view 5.1 - no restrictions are set though at all.
Came across this problem myself in the past...  Why it wasn't showing up in the VM was because it was showing up on the host system, you need to disconnect it from the host system and it should show up as a usable device in the VM.  Hope this is the case for you, good luck....  Fred
our clients though are windows 7 embedded. the view client has to have the device on the local system, then it passes it to the remote.

so that is not quite possible, as the client needs it fully installed first.
have just re-installed the view agent software in case it was bad drivers on the view software side.
still no difference.
thankyou
anyone with something similar on vmware?
Avatar of LeeTutor
I've requested that this question be deleted for the following reason:

The question has either no comments or not enough useful information to be called an "answer".
ASKER CERTIFIED SOLUTION
Avatar of jcmurphy777
jcmurphy777
Flag of Australia image

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
I've requested that this question be deleted for the following reason:

Not enough information to confirm an answer.
this has been resolved now with the changes to the registry key.
Please mark this as solved due to the typo we made which caused the fault.

i believe this should not be deleted as others may have the same issues
after the bad typo was found, the issues resolved themselves.

now we dont have the same driver issues.