Link to home
Start Free TrialLog in
Avatar of skywalker7
skywalker7

asked on

cisco catalyst vlan

Hello,

I have cisco switch in between router and client and want my vlan to pass, at the moment the 2960 does not pass vlan, when i connect it in middle, how can i configure so that port 1 and 2 pass all vlan, i have vlan 110, and configured the ports as trunk but still vlan traffic does not pass.

internet ----------- router (vlan) --------------cisco -------------client (vlan110)

many thanks and have a great day.
Avatar of fgasimzade
fgasimzade
Flag of Azerbaijan image

first of all, what is connected to port 1 and 2 on the switch?

Which port the router is connected to?

Which port the client is connected to?
Avatar of skywalker7
skywalker7

ASKER

on cisco,
port 1 -- router
port 2 -- client
Can you post your routers port config ?
If you only have the one VLAN in total being VLAN 110 you can set both ports 1 and 2 to access ports allowing the VLAN to pass. Config below:

conf t
int range fa0/1 - 2
switchport mode access
switchport access vlan 110
exit

This will also create VLAN 110 on the switch if it is not already there.  If this does not work then if you could provide more information about what router you have with the configuration on it.
this is switch config :-



Current configuration : 1782 bytes
!
! Last configuration change at 15:36:26 MSK Wed Nov 14 2012
! NVRAM config last updated at 15:38:21 MSK Wed Nov 14 2012
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname cisco
!
no aaa new-model
clock timezone MSK 3
system mtu routing 1500
ip subnet-zero
!
!
!
!
no file verify auto
!
spanning-tree mode pvst
spanning-tree extend system-id
no spanning-tree vlan 1
!
vlan internal allocation policy ascending
!
interface FastEthernet0/1
switchport mode trunk
!
interface FastEthernet0/2
switchport mode trunk
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
 ip address 10.0.0.2 255.255.255.0
!
no cdp run
!
mac-address-table aging-time 3600
mac-address-table aging-time 3600 vlan 1

Coremagma#
On the switch:

conf t
int fa0/2
no switchport
switchport mode access
switchport access vlan 110


Configuration of interface fastethernet 0/1 depends on configuration of routers port, but I suggest it should be the same

int fa0/1
no switchport
switchport mode access
switchport access vlan 110
the router port has both vlan 110 and normal traffic on same port, would the cisco be able to handle that ?
or just pass vlan 110 ? and not pass normal traffic ?

thanks.
Yes, cisco switch is able to pass all vlans, but I can not give you a proper config if I dont see your router's port configuration

If you say that it has vlan 110 and normal traffic (by the way, what is normal traffic) I assume it has multiple vlans, in this case cisco switch port should be

interface FastEthernet0/1
switchport mode trunk

But I can not tell you exactly unless I see the config
its a mikrotik router, which has on the same port, vlan 110 and non vlan traffic.

below is one example, of one client we want to give him vlan 110, but rest of the clients are connected without vlan.

internet ----------- router (vlan) --------------cisco -------------client (vlan110)

the router servers normal users who do not have v lan and now we want for the vlan client too. keep it as hybrid port.
There is no such thing as non-vlan traffic. All traffic belong to a vlan. I suppose all other traffic goes through default vlan 1. In this case keep you switch port connected to router like this

interface FastEthernet0/2
switchport mode trunk

However, I dont know if mikrotik router supports trunked ports. Check your documentation
Traffic is either tagged or untagged.

Do you know if the router is tagging some traffic as VLAN110, and some traffic as passing as untagged?

In that case:

conf t
int fa0/2
no switchport
switchport mode access
switchport access vlan 110

int fa0/1
no switchport
switchport mode trunk native vlan 1
switchport trunk allow vlan all
router is tagging traffic as vlan 110 and it also passes untagged traffic, all i want is cisco to allow untagged and tagged traffic with all ports, as these switches are going to be in between our links, and we might have like 3 or 4, and all ports needs to be trunk. so untagging or tagging should happen, pass traffic as it is.

is this possible with this model ?

below commnad resulted in error.

no switchport
switchport mode trunk native vlan 1

thanks.
ASKER CERTIFIED SOLUTION
Avatar of fgasimzade
fgasimzade
Flag of Azerbaijan image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
All is working great. thanks for the help in sorting out the issue. we will be on our way deploying vlan.