Link to home
Create AccountLog in
Avatar of awilderbeast
awilderbeastFlag for United Kingdom of Great Britain and Northern Ireland

asked on

Exchange 2007 - OALGen could not generate full details, ive enabled expert logging, still get same message...

Hi all,

we are getting event 9320 on our exchange server
"OALGen could not generate full details for some entries in the offline address list for address list '\Global Address List'.  To see which entries are affected, event logging for the offline address list generator must be set to at least medium. "

i have set logging to expert but all i get is the same message, no additional warnings...

Identity    : MSExchangeSA\OAL Generator
IsValid     : True
ObjectState : Unchanged
Name        : OAL Generator
Number      : 13
EventLevel  : Expert

anyone know whats up with this? we dont need to restart any services to see the new logging level do we?

Thanks
Avatar of Manpreet SIngh Khatra
Manpreet SIngh Khatra
Flag of India image

Seems that OAB generation is skipping some entries

we dont need to restart any services to see the new logging level do we? - No need to restart any services.

- Rancy
as randy said, some entries are being skipped, can you do OAB logging to know which items are being skipped but as per my experience, this is not a series warning, it is safe to ignore unless you are really paranoid about what is going on.
Avatar of awilderbeast

ASKER

we've added a new user that inst getting sent out to users address books, but like i said weve enabled expert logging and it just says to enable logging beyond medium again, like expert isnt enabled, but it is...
we've added a new user that inst getting sent out to users address books - The OAB generation happens everyday at midnight ... so if you added a user today he would be viewable today in Outlook Online\Non-cache or OWA\Webmail

- Rancy
try to create a new OAB and rebuilt it if it doesn't gives any errors set it as default one and delete the old one
ive manually updated the OAB, also this user was added on monday, its thursday and still no one has him in GAL.

creating new OAB is the next step then? is there a reason why it seems to be igrnoring my expert level logging?
when did you enable the expert logging level ? It could take up to 2 hours for this to take effect unless you restart the system attendant service
It is but one of the latter steps if current things dont work as everytime you cant simply proceed with creating new stuff ..

Check if the "ExchangeOAB" folder has the GUID and all days LZX files and same should be on the CAS server in "OAB" folder if any issues on CAS you see restart FDS service.

- Rancy
well it depends on how you look at it, i wouldn't spend time working on an OAB if the solution is as easy as creating a new one then the OAB is corrupted and that's it.

If creating a new one doesn't solve the issue in that case the issue is not the OAB itself but rather something else (probably AD issue) in that case more troubleshooting is needed
ok we created a new on and updated that, same issues, where do you suggest we look in AD?

Thanks
well i am sorry to tell you it is not a good news, i have faced this issue once at a client

although the solution is very easy the tool to diagnose this is not available on the internet and can only be provided by PSS which is not exactly a cheap option.

In my case the tool identified some orphaned users that had to be purged.

anyway if you get more chance with the expert logging level you might not need that tool after all

keep us posted
who are PSS? what is the tool called?

the expert logging doesnt seem to be working, it just keeps saying the level needs to be medium or greater.

we have found that if we enabled web based distribution it works if that means anything?
what outlook version do you have?

web based distribution is for outlook 2007 and later

public folder is for earlier
we have outlook 2010, but use public folders.

i found this ftp site
ftp://ftp.microsoft.com/PSS/Tools/Exchange%20Support%20Tools/

theres OABinteg in there, is that the one? or others?
ASKER CERTIFIED SOLUTION
Avatar of Akhater
Akhater
Flag of Lebanon image

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
You getting any 9646 or 9582 if i remember correctly ?

- Rancy
no, none of those, however i have just found one of these
"Entry has invalid or expired e-mail certificates. These certificates will not be included in the offline address list for '\Global Address List'."

how can i remove this certificate or renew etc? see if that fixes it

Thanks
why cant we use public folder distribution for 2010? its been working fine for years now...
ok, using web based is a fix but doesnt assure that there isnt any other underlying issues with exchange or somewhere in the domain and with expert level diagnostics being ignored, how else can i troubleshoot this?

shall i enable medium logging globally give that a shot?
Webbased is more of a fix as it works with Autodiscover and can work via Internet as well :)

I would recommend save the current event logs before you enable expert logging as it will almost overwrite most of the data over there.

- Rancy
are you sure you have nothing in the event log ? these can be information not necessarily warning or errors
i have the below, none of which say anything other than each stage was succesful, then the last that says fail
info.PNG
then your logging level is definitely working can you paste again the content of the last warning please?
yeah here it is...

"OALGen could not generate full details for some entries in the offline address list for address list '\Global Address List'.  To see which entries are affected, event logging for the offline address list generator must be set to at least medium. "
really it is just a warning and if you have nothing relevant in the previous events I wouldn't worry much about it specially that it is not affecting anything

again, in my case, OAB was not being generated at all and I had to call PSS
ok, how then can i investigate why this user we added on monday (4 days ago) is still not in 90% of our users Addressbooks (unless we enabled web based and forced download)

thanks for your help
if it were an AD issue then web distribution wouldn't  have made a difference. so, the only thing i can think off, is a PF issue.
is there any tests or things i can diagnose on the public folder DB?
I'm sorry but i can't help anymore with this. it is just too tedious for me to do on the board.

if i can be of any help regarding the original question do let me know

good luck
changed to use web based OAB