Link to home
Create AccountLog in
Avatar of SonicVoom
SonicVoomFlag for United States of America

asked on

FOG project: "a disk read error occurred" XP

I've built a master image and am having trouble replicating it to other hardware. The machines are the same, though the hard drives are one of two sizes.

Whatever I'm doing wrong seems to be beyond system configuration, as the drive is rejected, erroring: "a disk read error occurred". I'm still at the experimental stage, having only built a reasonably complete image and not yet sysprepped (as recommended here http://www.fogproject.org/wiki/index.php/Client_Setup)

What could be going wrong? It's acting like the image is simply unbootable after it's written.
Avatar of JAN PAKULA
JAN PAKULA
Flag of United Kingdom of Great Britain and Northern Ireland image

1 bios hard drive settings are the same - both AHCI or both IDE?
2 have you try to run chkdsk from cmd (using windows PE)?
3 Which way are you doing it - small hard drive to bigger one or other way?
4 Same motherboard storage controllers? (missing drivers maybe? - sysprep will sort it)
 
JAN MA CCNA
Avatar of SonicVoom

ASKER

1. same on all
2. I'd already run it queued after reboot. Is it different through PE?
3. master is 160GB, I've imaged to both 80GB & 160GB (via multicast) with no luck.
4. ran sysprep; still wouldn't boot.

My current attempt is to change the IDE controller to standard
You may want to image from smaller to bigger.
Also, please let us know when the error happens. Has the imaging process begun?
Please detail the steps that were processed correctly and as many details as possible
If it has, it may be a problem of drive size or a real HDD HW issue.
Some other questions that may help:
Does the issue occurs on all similar targets or only on one of them?
Are all the HDDs connected to the same IDE/SATA socket?
I attempted the IDE driver change I linked above, still not working. I have not double-checked which SATA port the HD's are directly connected to, but in my memory, most are on 0 with optical drive on 1.

Here's everything I can think of that I've done:

Installed windows to master-image machine
install drivers & apps, configure windows, etc
chkdsk, disk cleanup, defrag
sysprep

create image in FOG, add hosts
upload master image (160GB HD)
push image to 3 workstations (80GB, 80GB, 160GB)
workstations reboot, PXE boot first, then follow boot order.

white words at top of black screen:

a disk read error occurred
press ctrl-alt-del

reboot, reboot, chkdsk, everything else I can think of to get those systems to boot. Try other misc tweaks & reimage. No love from the machines.

Thanks for your help
I tried again, making my image all disks/non-resizable and it works. Great, but I was counting on being able to resize as I'm imaging machines with two different HD sizes. The master image machine is 160GB, some are 80GB. If I change the master's partition to 80GB and then make a new image from it, will it fit onto the smaller machines?

I'd rather that resizable image simply worked!
Have u tried srinking the volume to minimum possible size before creating the image? Its in disk management.
That option is not visible. Is it not an option is XP?
ASKER CERTIFIED SOLUTION
Avatar of JAN PAKULA
JAN PAKULA
Flag of United Kingdom of Great Britain and Northern Ireland image

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account