Link to home
Create AccountLog in
Avatar of chadfran
chadfran

asked on

Can't connect when I hide my SSID

I cannot connect my Iphones to my wireless router when I hide my SSID. It works fine when it is unhidden. My PCs can connect with no issue hidden or not. Has anyone had this issue with their Iphones?
Avatar of SachinNamdeoSable
SachinNamdeoSable

My solution: iPhone Configuration Utility 2.2 for Mac OS X

(http://support.apple.com/kb/DL851)

Download:

http://support.apple.com/downloads/DL851/en_US/iPhoneConfigurationUtility.dmg

Had to set up a com.work.profile with that utility and store/send it to my iphone and install it.
(You only need to configure the wifi tab, nothing else!)

Now the connection to my hidden SSID at work also works fine.

Hope, that Apple will fix the FW 3.1.3 bug in the next FW.

Please let me know if this helps you
My SSID is hidden.  On IOS 5 or 6, go to Settings, WiFi and under choose a network, select Other and enter the SSID along with the Security Information. Entering the SSID works just fine (at least it did for me). .... Thinkpads_User
Avatar of chadfran

ASKER

I let it sit all day and just checked again, and it appears to have connected? I guess it just needed some time... I see if it drops.

If I go into the wifi settings it has a check mark beside my network but the Choose a Network still spins every few seconds. Is that normal for Iphones?
but the Choose a Network still spins every few seconds. Is that normal for Iphones?

No.  WiFi, Other, touch Other and it should instantly ask for name (SSID) which you can enter. This is true for IOS 5 and IOS 6. So something is strange.

IOS 6.0.1 is out. Can you connect to iTunes by USB and update it?

If you updated over the air and something went wrong, you may need to back up your iPhone and do a reset and reload the operating system.

...  Thinkpads_User
I'm already on 6.0.1 but I did it over the air, so maybe I'll have to reset as you stated.

I'm already connected to my network. It has a check mark beside it. I had to manually add it by selecting other > enter my SSID > set security WPA2 and it prompted me for my password.

Top left beside my phone provider's name shows the standard horizonatal arrows that it is connected, not the 3G anymore.

My only conern is why does it keep spinning beside choose a network when it is already connected. You are saying this isn't normal for iphones?
ASKER CERTIFIED SOLUTION
Avatar of John
John
Flag of Canada image

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
@chadfran - Thank you and good luck with your iPhone. Next time the IOS is updated, try updating via iTunes as that seems to work very well for me (two iPhones).

.... Thinkpads_User