Link to home
Start Free TrialLog in
Avatar of TimberJon
TimberJonFlag for United States of America

asked on

Issue editing htm file in Dreamweaver

Hi there,

I have an issue where I am trying to edit an htm file via dreamweaver, or else replace it via ftp but it throws permission errors. I was told by the original host to just remove the library and template tags to allow edits but I don't understand how tabs like that would lock down a file...

I have never really used either so I do not know what I should be doing to the file. It is the default page for an older html website. Main file is default.htm but I need access to it to make some changes.

Any help in understand how to remove or strip library and template tags from the file would be appreciated.
Avatar of Rob
Rob
Flag of Australia image

Can you post your htm page?  It sounds like it is a server side coldfusion script, which unless that is what is running on your how, will not work
but it throws permission errors

What is throwing permission errors?  The FTP operation or DW's editing function?

I was told by the original host to just remove the library and template tags to allow edits but I don't understand how tabs like that would lock down a file...

The HTML comments that make up DW library and template tags will lock those sections of the file as long as you attempt to use DW to edit.  The simple solution is to not use DW.  Download the file and open it in Notepad and make the edits there and you won't have any problems.  If you remove the HTML comments completely via Notepad then you will be able to edit the file in DW in an unrestricted manner.
Avatar of TimberJon

ASKER

Hum. I can edit in notepad, no problem. What do you mean remove the HTML comments?  I have seen alot of notes and things in html files that are meant to be disregarded by the browser but this sounds like something specific to the library tags?

Is there something specific I'm looking for? Sorry but I cannot make the html file public here. Editing purely in html for page layout and object sizing is going to be a pain if I cant use dreamweaver.
Dreamweaver uses HTML comments to define its Templates.  See here:

http://help.adobe.com/en_US/dreamweaver/cs/using/WScbb6b82af5544594822510a94ae8d65-7a79a.html

If you check your HTML page, you will see those comments littered throughout the document.  Just delete all of them in Notepad to remove the dependence on the Template and restore the ability to edit the file in DW.
are the tags you're talking about begin with <cf...> ?

eg

<cfajaximport params="#{googlemapkey='please use your own google map api key here'}#">  
  
<cfmap   
    centeraddress="Nebraska"  
    height="425"      
    width="650"  
    hideborder="no"  
    title="earth type google map (Nebraska)"  
    zoomlevel="6"  
    zoomcontrol="large3d"  
    typecontrol="none"  
    type="earth"  
    >  
</cfmap>  
  

Open in new window

Ok I took a look at that... and it comes back to editing the file. I cannot remove anything because it does not allow me to save or overwrite the file. I even get an error via FTP when I attempt to replace it with the one I have. Sooo.. how do I remove the offending text if I cannot even upload a revised copy?

Here is the bulk of my head.

<html><!-- #BeginTemplate "/Templates/Main Page.dwt" --><!-- DW6 -->

<head>
<!-- #BeginEditable "doctitle" -->
<title>ECA, Inc.</title>
<style type="text/css">
<!--
.style1 {
      font-size: 12px;
      font-weight: bold;
}
-->
</style>
<!-- #EndEditable -->
<link rel="stylesheet" href="Templates/eca.css">
</head>

I see the ! template line at the top. That is the only place in the whole thing that has that. Then there is also the !# editable strings. Are these what is locking out the rest of the document? I don't recall ever seeing this on sites Ive worked on before.
ASKER CERTIFIED SOLUTION
Avatar of Jason C. Levine
Jason C. Levine
Flag of United States of America image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Roger that. I found the command "Detach from Template" but yea it won't allow me to save the file. I'll see what I can do about the file access. Seems to be some kind of permission issue.
the files need to be at least 600 to allow owner to edit (assuming a nix box that is)
It was some kind of permission error on the FTP server. A 550 overwrite permission denied error was causing the problem. I have resolved it with the host. Thanks!
Problem Solved.