Link to home
Create AccountLog in
Avatar of DHPBilcare
DHPBilcareFlag for United Kingdom of Great Britain and Northern Ireland

asked on

RDP and DNS Failure Problem

From today when attempting to RDP into a Windows 2008 R2 server from a Win 7 Pro laptop I received the following message.

"Remote desktop cannot verify the identity of the remote computer because there is a time or date difference between your computer and the remote computer.  Make sure your computers clock is set to the correct time, and then try connecting again"
 
I can still RDP if I use IP address and not hostname and there is no difference of date or time or region between two.

On logging into the server I’m seeing lots of recent DNS errors as follows:

"The DNS server could not bind a Transmission Control Protocol (TCP) socket to address 0.0.0.0.  The event data is the error code.  An IP address of 0.0.0.0 can indicate a valid "any address" configuration in which all configured IP addresses on the computer are available for use.
Restart the DNS server or reboot the computer"

This server is a secondary DNS server and after restarting the DNS Server Service I cannot connect to the DNS Server Manager on the server.

Any ideas??
Avatar of Miguel Angel Perez Muñoz
Miguel Angel Perez Muñoz
Flag of Spain image

Pinging server from Win7 resolves correctly?
Avatar of DHPBilcare

ASKER

Yes.  
The Primary DNS Server is still working accross the network.
Have you checked dns server service is running on secondary dns server?
Yes, its running but I cant connect to the DNS Manager on that Server.
Is quite strange... is any event on event viewer? maybe one zone file is corrupt. From this dns server, you can ping to itself? IP address is correct?
Avatar of MarietMathew
MarietMathew

how many network card this particular DNS server have and did you verify all of them have a valid IP.
Only one active which has not changed and still shows the correct static IP os 10.213.11.23.
If I ping the server by IP from itself it works fine.
Seeing more DNS errors.

The DNS server could not open socket for address 0.0.0.0.
Verify that this is a valid IP address for the server computer.  If it is NOT valid use the Interfaces dialog under Server Properties in the DNS Manager to remove it from the list of IP interfaces.  Then stop and restart the DNS server. (If this was the only IP interface on this machine and the DNS server may not have started as a result of this error.  In that case remove the DNS\Parameters\ ListenAddress value in the services section of the registry and restart.)
 
If this is a valid IP address for this machine, make sure that no other application (e.g. another DNS server) is running that would attempt to use the DNS port.
 
Any ideas?
If your servers are more than 5 mins out of sync with your domain contraoller then you may have dns service errors.  

This will affect DNS running - particularly if dns services are authenticated via a domain account.
Date and times are identical on all the servers.
seems like server is seeing 0.0.0.0, but then the question is how come the server is pinging. But still you can try removing the IP address and reinstall network adapter driver. As per your details there should any hardware driver problem where the dns service seeing the IP as null.
One of my previous comments was not quite coreect.  We do have two Network cards on the server and the one not used is disabled with a null IP.  

Is DNS getting confused between the two?
Correction again.

The other Ethernet card is simply not bein used rather than disabled.
Assuming your server has static IP address, try running command prompt, "ipconfig /registerdns"

Does this run successfully?

Please can you confirm how your primary and secondary dns servers are configured - from point of view of updates (e.g. via named servers list).  

Is this server configured to point to your primary dns server as it's primary?  Does it stipulate your secondary too? (Genuine reason for this question as I've been round the mill numerous times with DNS).
Check if this Link helps to fix the problem
It did seem to run ok but still no resolution.

The secondary DNS server receives updates from our primary DNS Server for our local zones.  The Secondary server is showing and validated as a nameserver on our primary.  

The primary seems to be working with no issue.
One aspect to note is that this server is not running AD.
Andy by AD I mean it isnt a DC.
ASKER CERTIFIED SOLUTION
Avatar of DHPBilcare
DHPBilcare
Flag of United Kingdom of Great Britain and Northern Ireland image

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
Dont know what caused the issue but a restart solved the problem.