Link to home
Start Free TrialLog in
Avatar of StarfishTech
StarfishTech

asked on

Printed crystal report crunches characters together

We run crystal reports through our citrix server. All of our crystal reports ran fine on our old Windows 2003 citrix server. However, we just migrated to a new citrix server that is running on windows 2008 r2. Now, when certain reports print out, many of the characters on the page are crunched together. We've already tried changing the printer driver and also installing all of the fonts from the old server. That didn't seem to make a difference. I have attached the report to show you what it looks like. I've circled some of the words that aren't printing correctly.
scan--3-.pdf
ASKER CERTIFIED SOLUTION
Avatar of Mike McCracken
Mike McCracken

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Avatar of StarfishTech
StarfishTech

ASKER

How do i change the printer within the reports?
Open the report
Click FILE --> PRINT
Select a new printer
Save the report

mlmcc
Is that any different from just printing the report to a different printer?
Yes, since it saves the new printer in the report.

I had a similar issue with a project I was on.  I had to build 70-80 reports to be run from the application.  The printer we had was an old LajerJet but the users had newer LaserJets with features and capabilities mine didn't.
The main capability mine lacked was the ability to print duplex.  
To solve this I installed the printer driver for their printer on my machine, set it as the default printer then open each report set the printer, and saved the report.  The users then had the capability to print duplex in the reports.  I still couldn't since I didn't really have a printer on that machine but it solved the issue.

mlmcc
OK, so when I open the report in crystal reports and then go to file and printer setup, the drop down to choose the printer is greyed out and no printer appears to be selected. It also looks like a "no printer" tick box is checked and greyed out in the upper left hand corner of the printer selection window. Also I noticed that when I first open the report, it complains that "the report uses an invalid printer. The default printer will be used instead".
The NO PRINTER checked means the report is optimized for screen display and there generally are issues when printing.  Chief among the issues is usually you cant print at all.  You must have one of the newer versions where it allows the report to be printed.

Try unchecking the NO PRINTER box and selecting the correct printer.
Is there a default printe rdefined on the machine?
If not define one as the printer you want to use.

mlmcc
There is a default printer defined. However, the "no printer" checkbox is greyed out so I can't uncheck it. Please see the picture I uploaded.
printsetup.jpg
If you do a save as then open the new report does the no printer option become available?

mlmcc
Thanks. Changing the default printer of the report seems to have done the trick. We actually have another report this is having problems. Any chance you would like to look at this issue as well? I will be opening a new question in this same forum. Thanks for the help!.