Link to home
Start Free TrialLog in
Avatar of howmad2
howmad2Flag for United States of America

asked on

Blue Screen - ADVAPI32.DLL

I have a computer, XP Sp3.  Windows updates performed.  On reboot Blue screen on ADVAPI32.DLL.  Can't get to SafeMode, Safemode with networking and Last Known Good.  I get the same error,  Any Ideas?
Avatar of Levi Gwyn
Levi Gwyn
Flag of United States of America image

It sounds like this could be a hardware issue.  Run a disk diagnostic tool to be sure so you don't waste a lot time troubleshooting.  There are a lot out there that can be run from a CD.

Here is one I've used before (Drive Fitness Test):
http://pcsupport.about.com/gi/o.htm?zi=1/XJ&zTi=1&sdn=pcsupport&cdn=compute&tm=289&gps=148_9_1536_758&f=00&su=p504.6.342.ip_&tt=3&bt=0&bts=0&zu=http%3A//www.hitachigst.com/hdd/support/download.htm%23DFT 

You can burn this to a CD, boot from the CD and run the tests.  If you're hard drive is hosed, you're looking at a new drive and fresh reinstall.
Avatar of SVITC
SVITC

Have you tried to look at the dump with BlueScreenView: http://www.nirsoft.net/utils/blue_screen_view.html
Avatar of nobus
try a system restore to a date it was ok with this method :
http://support.microsoft.com/kb/307545
----------------------------------------------------------------------------------------------
An easier way is to boot from a Bart PE CD (or UBCD4Win CD) and use the file manager for manipulating files. Here  the procedure :
1. rename c:\windows\system32\config\SYSTEM to c:\windows\system32\config\SYSTEM.bak
2. Navigate to the System Volume Information folder.
it contains some restore {GUID} folders such as "_restore{87BD3667-3246-476B-923F-F86E30B3E7F8}".
The restore points are in  folders starting with "RPx under this folder.
3. In such a folder, locate a Snapshot subfolder. This is an example of a folder path to the Snapshot folder:  C:\System Volume Information\_restore{D86480E3-73EF-47BC-A0EB-A81BE6EE3ED8}\RP1\Snapshot
4. From the Snapshot folder, copy the following file to the c:\windows\system32\config folder
 _REGISTRY_MACHINE_SYSTEM
5. Rename _REGISTRY_MACHINE_SYSTEM to SYSTEM
6. Exit Bart PE, reboot and test

Use a fairly recent restore point from at least a day or two prior to problem occurring .

** you can add the other hives also with this procedure

http://www.nu2.nu/pebuilder/       BARTPE
http://www.ubcd4win.com/            UBCD4WIN
ASKER CERTIFIED SOLUTION
Avatar of howmad2
howmad2
Flag of United States of America image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
did you try the 'restore' method i posted?  and if so, what were the results?
Avatar of howmad2

ASKER

Thank you for the suggestion.  I tried.  I couldnt get the restore from run from F8 and getting to the desktop to run it was the root of my problem...  Thanks again.
you should boot from a CD - not from the disk...
not sure where you read that ?
Avatar of howmad2

ASKER

I appreciate all other responses but in this case it didnt help.  Thank You.