Link to home
Start Free TrialLog in
Avatar of LTMM
LTMM

asked on

W7-32: Windows Update not functioning ; no catdb

After installing a new OS (W7-32 Professional, SP1) on my Acer Aspire 6935G laptop in which I placed a new disk drive (Seagate Hybrid 750GB), everything seemed o.k. until I noticed that Windows Update didn't function => "Windows Update cannot currently check for updates, because the service is not running. You may need to restart your computer."

I tried the solution to repair the catdb with the 'esentutl' => Jet error 1811 => no catdb
I then used Fixit (KB971058) => no change
I read somewhere that installing the newest Intel ACHI driver solved the problem => not mine
As a last attempt I did a complete new install of Windows => no success

Who has the solution?
Avatar of John
John
Flag of Canada image

I am not exactly sure why updates should not function after a new install of Windows. Windows 7 updates normally work well..

Look at

http://support.microsoft.com/kb/947821  and then

http://www.microsoft.com/download/en/details.aspx?id=3132

These are the links to the System Readiness site and the 32-bit readiness tool.

Try the readiness tool and see if it helps.

.... Thinkpads_User
ASKER CERTIFIED SOLUTION
Avatar of LTMM
LTMM

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Avatar of LTMM
LTMM

ASKER

!