Link to home
Start Free TrialLog in
Avatar of ServTech
ServTech

asked on

Can't start SBS2008 DHCP Service...

Hi Guys,

Just went to join a new computer to our domain and it stated that it couldn't contact the active directory service on the server... I then trotted off to the server and found that the DHCP service was stopped, I tried to start it via the Server Manager and got the error:

Failed to Start DHCP server   The service changed to an unexpected state...

I then went to services and tried to start it there and got error:

Windows could not start the DHCP server service on the local computer
Error 2: The system cannot find the file specified.


I then went to the logs to see if there was any more info, it simply mentioned the same thing that system cannot find the file specified and also:

The DHCP service failed to initialize its registry parameters. The following error occurred:
The system cannot find the file specified.


Obviously, until I get DHCP working again I can't join the workstation to the domain

This server is running SBS2008 and the DHCP client starts no problem. The Workstation has prefered DNS set as the SBS server...

Any ideas..??

Cheers
Avatar of davorin
davorin
Flag of Slovenia image

Have you tried to restart the server?
Avatar of ServTech
ServTech

ASKER

Yes, unfortunately made no difference...
Alternatively, is there a different way I can connect a 'new computer' to the domain without having DHCP working at the time, gets the jobs done and gives me time to solve the DHCP problem next week..?? I have tried http://connect as well, no joy...

Basically I need to just get this joined then I can have what's remaining of the weekend..!

Any other ideas please...??
If you set on client PC fixed IP in the same subnet the SBS server is (please take care that this IP is not already used) and you set in DNS settings the IP address of the SBS server you should be able to connect computer to the domain.
The problem is that when IP leases on the client computers will expire, no computer using DHCP client will be able to access the network. I think that the default expiration time is 8 days, but this could have been changed.
I tried giving it a fixed IP (unused) to see if that would work, http://connect still does not work (cannot find server)

Then I tried to join through control panel/system & security/system/change settings/Network ID then change from workgroup to the domain...

Strangely, it does find the account and domain and says "would you like to use this account" so you say yes and it says "Error Message "Access Denied"...!

This is becoming tiresome.!

Any other ideas please...?
Can you ping the FQDN name of SBS server from the client?
yes it can...  

I have just realised what might be causing some or all off the problem, this new computer is a direct replacement for an old one, therefore I simply wanted to fire up the new one, give it the same name and join the domain, job done... I think it is because I am trying to add it to the domain, same name - different computer, plus I'm logging onto the domain as him (standard user) and not me (admin) that is where the access denied is coming from..??

I have just found this, whilst it applies to different windows the error remains the same.. Would this be a work around..?

http://support.microsoft.com/kb/330095

You are replacing a client computer with another computer that has the same computer name. ~ Correct

Use a different computer name ~ But I don't want to use a different name because it is a direct replacement..!!?

Thoughts..??
Direct replacement or not, you can not use the same computer name for new computer while the old computer name still exists in AD.
You need to delete old computer name from AD and just then try to join the new computer using the same name.
Using temporary different name for a new computer also is not such a big deal, as you can rename computer anytime.
Ok davorin thanks, If I delete the computer from AD will that solve the problem..? I will then be able to join with the new computer...?

I'm presuming that deleting 'the computer' in AD will have no affect on the persons domain account..??
SOLUTION
Avatar of davorin
davorin
Flag of Slovenia image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
In order to use http://connect
You must assign the SBS as the ONLY DNS server
add the domain suffix (mydomain.local) to the DNS tab under advanced TCP/IP config
have only one NIC enabled

If the PC has been a member of any domain, there is little advantage to using http://connect as it will not move the profile.  In that case see the following article regarding using Profwiz and SBS:
http://blog.lan-tech.ca/2011/05/19/sbs-and-profwiz/

Though your errors suggest otherwise, two common causes which keep DHCP from starting on an SBS are; if you enabled hyper-v on the SBS, or disabled IPv6.
@ davorin ~ thanks, I have tried to use connect wiz to join as I said before but the browser could not find the server... I will try to join using a different name and / or credentials tomorrow... Also I will try deleting the 'computer' from AD as well...

@ RobWill ~ the SBS is the only DNS server known to all the workstations...
The PC in question is a brand new dell so it has never been near a domain before...
The server does not have hyper-v enabled or IPv6 disabled...

Thanks
Hi Guys again,

Managed to get the computer joined to the domain by renaameing it and adding it using control panel/system & security/system/change settings/Network ID then change from workgroup to the domain... ... the connect wiz still does not work..!

Problem now is that although I can log onto the domain using 'his' credentials no problem, his desktop icons and redirected folders do not load as they should do... I can get to them manually but they should automatically load at logon..?? I'm pressuming that its because I haven't added the computer using the connect wiz..??

Any Ideas how I can get this solved..??
Unlike SBS 2003, with SBS 2008/2011 the connect wizard doesn't do much other than import a local profile, and never did control redirected folders.  All features, including redirected folders, are controlled or rather enforced by group policy.  Group policy relies completely on DNS as does joining a domain.  

I suspect DNS is still not properly configured.  Did you add the domain suffix as suggested in my earlier post.  Could you post the results of ipconfig /all from the problematic workstation and the server.  I'd also recommend running the fix my network wizard and the BPA.  The latter often will point out and configuration issues or other problem.
http://www.sbslinks.com/sbsbpa.htm
Desktop icons do part of user profile and if you have not configured roaming profile on the old computer, there is no way that you will see the same desktop items on new computer.
Also user profiles on windows xp (V1) and windows 7 (V2) are not compatible.

About connect wizard changes to client computer:
"When you join a client computer to the network, Windows SBS 2008 makes a number of changes to the client computer. These changes allow for seamless interoperability between the client computer and the server. Changes made to the client computer include:
 Create a Windows SBS group on the Start menu, and add the Internal Web site link to the group.
 Create a shortcut to the internal Web site on the desktop of computers running the Windows XP operating system.
 Set the Home page link in Internet Explorer to point to the internal Web site.
 Create links in the Internet Explorer Favorites folder for the Internal Web site, Outlook Web Access, and Remote Web Workplace.
 Configure Windows Firewall ports to allow the following features to work:
 Core Networking
 Remote Assistance
 Remote Desktop
 Windows Management Instrumentation (WMI)
 Configure Automatic Update on the client computer to install updates automatically.
 Install the Windows Small Business Server 2008 ClientAgent application on the client computer.
 Install the Windows Small Business Server 2008 WMI Provider component.
 Install the Windows SBS 2008 Desktop Links gadget on client computers running the Windows Vista operating system.
 Note
 Windows SBS 2008 installs the Desktop Links gadget in the gallery, but does not configure it to appear automatically in Windows Sidebar."
From http://www.petri.co.il/forums/showthread.php?t=54061
I believe the author is referring to redirected folders, not roaming profiles.  Redirected folders is enabled on most SBS servers and works with XP, Vista, and Win 7.  I agree roaming profiles work differently with XP/Win 7.

As for; "About connect wizard changes to client computer:"  The wizard does none of those things they are all pushed out by group policy.  SBS 203 however did have a list longer than that which the connectcomputer wizard did.

By the way redirected folders does not start to work until you have waited 90+ minutes or run gpupdate /force as well as logged off and on 3 times.
Cheers guys, I've got it joined now and manually set the desktop and my documents to be on  the server... (redirected folders) ~ I could have sworn that was done automatically by logging onto the domain the last time I did it... either way its done now.

The workstation is happy but I still have that problem with DHCP that I started out with, is DHCP essential to have running on SBS2008 as we have a router that will serve out addresses if required...?
>"I could have sworn that was done automatically by logging onto the domain"
It is if group policy is working, which relies on DNS.  Run gpresult and see if policies are being applied.

DHCP is not compulsory, but if using a router it must be configured to assign only the SBS for DNS and add the DNS suffix.

Have you run the Fix My Network Wizard?
Hi Rob,

Group policy does state redirected folder are to be used... maybe as you said an update hadn't happened at that point in time...

The SBS is assigned as the preferred DNS for the whole domain but not obviously for the modem/router...

Here is ipconfig/all from the workstation in question:

Windows IP Configuration

   Host Name . . . . . . . . . . . . : YPC-BB2
   Primary Dns Suffix  . . . . . . . : ypc.local
   Node Type . . . . . . . . . . . . : Hybrid
   IP Routing Enabled. . . . . . . . : No
   WINS Proxy Enabled. . . . . . . . : No
   DNS Suffix Search List. . . . . . : ypc.local

Ethernet adapter Local Area Connection:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Realtek PCIe GBE Family Controller
   Physical Address. . . . . . . . . : 78-45-C4-28-B0-28
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : fe80::ceb:6d67:f34:1939%11(Preferred)
   IPv4 Address. . . . . . . . . . . : 192.168.1.23(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . : 192.168.1.1
   DHCPv6 IAID . . . . . . . . . . . : 242763204
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-18-2D-89-36-78-45-C4-28-B0-28

   DNS Servers . . . . . . . . . . . : 192.168.1.2
   NetBIOS over Tcpip. . . . . . . . : Enabled

Tunnel adapter Local Area Connection* 12:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes

Tunnel adapter isatap.{C3063E07-77FC-4334-BABB-5A4098506D6C}:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Microsoft ISATAP Adapter #2
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes


Cheers
ASKER CERTIFIED SOLUTION
Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
yep great,will do ~ thanks rob and also davorin... I will do some more investigation on the DHCP issue...

At least the workstation is up and running on the network, ready for tomorrow..! That was the important thing..!

Thanks to both of you.

Cheers :-)
Superb Assistance..!