?
Solved

'Action failed on AutoExec' error msg on app start-up

Posted on 2012-12-20
10
Medium Priority
?
663 Views
Last Modified: 2012-12-20
when you open this access app, you get the below screen. how can this warning be avoided? (Action failed on AutoExec)

when you click close, then you get the second screen. (vba macro)

this started happening only 2 months or so ago, i am told.

thanks.
0
Comment
Question by:25112
  • 4
  • 3
  • 2
  • +1
10 Comments
 
LVL 66

Assisted Solution

by:Jim Horn
Jim Horn earned 1000 total points
ID: 38709990
Define 'the below screen' and 'the second screen', as I don't see any screen shots.
0
 
LVL 85

Assisted Solution

by:Scott McDaniel (Microsoft Access MVP - EE MVE )
Scott McDaniel (Microsoft Access MVP - EE MVE ) earned 332 total points
ID: 38710023
Action failed on AutoExec
You would have to determine which action is failing in the AutoExec macro. If you can list those actions, we might be able to point you to some likely suspects.
0
 
LVL 5

Author Comment

by:25112
ID: 38710056
sorry i had not put comment for attachment, and it was not loaded.. here is the screenshot
2nd-screen.png
macro.png
0
The new generation of project management tools

With monday.com’s project management tool, you can see what everyone on your team is working in a single glance. Its intuitive dashboards are customizable, so you can create systems that work for you.

 
LVL 5

Author Comment

by:25112
ID: 38710065
LSMConsulting, do you mean the error code? (2950).. or the code of the macro?
0
 
LVL 66

Assisted Solution

by:Jim Horn
Jim Horn earned 1000 total points
ID: 38710070
If I'm interpreting this correctly, it's not an error, but the user's Office settings for Trust Center is not allowing any Access apps that have code or macros to execute those code or macros, and when the AutoExec macro fires on startup it blocks execution.

Below is the manual answer for Access 2010.   Also, afaik there is no way to programmatically pull this off, as this was intended to be a safeguard against viruses.

Give this a whirl on the pc that is generating the message (Access 2010)

(1)  Go to File menu, Options.  The Options window will appear.
(2)  Click on the Trust Center on the left, and hit the 'Trust Center Settings...' button.  The Trust Center window will appear.
(3)  Click on Trusted Locations, then click on the 'Add new location...' button.
(4)  Enter the path that the Access app lis in, and hit Ok.
(5)  Hit Ok a couple of times to close.

Close out of Access, then open the database, and it should go straight to the Main Menu.
0
 
LVL 5

Author Comment

by:25112
ID: 38710083
when I open the app with Shift key, I get this screen only
2.png
0
 
LVL 49

Assisted Solution

by:Dale Fye
Dale Fye earned 668 total points
ID: 38710099
This is caused by Office security settings.  Since this appears to have begun several months ago, I assume that the version of Office in use on that computer was upgraded from 2003 or lower to 2007 or higher about two months ago.

The only way to circumvent this message is to designate the folder that the application resides in as a "trusted location".  Creating a "trusted location" will allow VBA code (and macros) embedded in any Office application that resides in that folder to run without first having to "enable" macros.

1.  Click the Office button in the upper left corner when Access is opened,.
2.  Click the "Access Options" button (bottom center of popup window)
3.  Click the "Trust Center" option in the panel on the left of the Access Options dialog
4.  Click the "Trust Center Settings" command button
5.  Click the "Trusted Locations" option in the panel on the left
6.  Click the "Add a new Location" button, then migrate to the folder where your application resides.

HTH
Dale
0
 
LVL 66

Assisted Solution

by:Jim Horn
Jim Horn earned 1000 total points
ID: 38710100
>when I open the app with Shift key, I get this screen only
That's because opening it with the Shift key down bypasses the AutoExec macro.
Since no code is executing, it allows the file open, which then goes to a blank screen with all your objects listed.
0
 
LVL 49

Accepted Solution

by:
Dale Fye earned 668 total points
ID: 38710118
Sorry, Jim.  Did not mean to repeat your post.

The other thing about the Shift bypass, if you look at your screen (not the image you posted), you should see a bar across the top of the Access window (probably right below the menu bar) that says something like:

Security Warning Certain content in the database has been disabled

This will be followed by a command button (Options) which pops up the Security Options dialog, which is the first image you provided.
0
 
LVL 5

Author Comment

by:25112
ID: 38710705
thanks a lot for your explanation!
0

Featured Post

Never miss a deadline with monday.com

The revolutionary project management tool is here!   Plan visually with a single glance and make sure your projects get done.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

We live in a world of interfaces like the one in the title picture. VBA also allows to use interfaces which offers a lot of possibilities. This article describes how to use interfaces in VBA and how to work around their bugs.
If you’re using QODBC to update QuickBooks data from Microsoft® Access but Access is not showing the updated data, you could have set up QODBC incorrectly.
In Microsoft Access, when working with VBA, learn some techniques for writing readable and easily maintained code.
Polish reports in Access so they look terrific. Take yourself to another level. Equations, Back Color, Alternate Back Color. Write easy VBA Code. Tighten space to use less pages. Launch report from a menu, considering criteria only when it is filled…
Suggested Courses
Course of the Month4 days, 17 hours left to enroll

601 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question