Network configuration in ESXi 4.1

I had the below question and have made the configs but the server attached to that NIC is not comunicating to the network. attached is what my config looks like, im sure Im missing something






Network adapter configuration in ESXi 4.1

Asked by: atorex


 I have an ESX server with 4 NICs I would like to use one of the NICs on a virtual machine  on that ESX.
I have 2 ISP connections one is for hosting and other is for local network, I want 1 of the servers to have access to the Hosting ISP link, this is my reason for this configuration.
So my question is how do I add a physical NIC to a VM?


:2012-12-19 at 08:25:32ID: 27972871Topic:
VMware
Participating Experts:3Points:500Comments:3

Request Attention



Answers





 
Assisted Solution


by: busbarPosted on 2012-12-19 at 08:28:51ID: 38705523






 create a vswitch that is conected to that NIC as upling, connect that VM to that vswitch via a port group, easy.!


167

EXCELLENT

Add to Knowledgebase


 
Assisted Solution


by: gcoltharpPosted on 2012-12-19 at 08:42:03ID: 38705565






 I don't have ESX 4 servers left but if I recall correctly, the procedure has not changed.
In vSphere, go to configuration, networking. You should get a visual display of how your networking is configured.

Click add networking, select virtual machine. On the next page, use Create a vSphere standard switch and check the network interface that you want to use. Give it a name and a VLAN if you need one. Click through to finish.

Click on your virtual machine and Edit Settings. Click on the network adapter. On the lower right, there will be a network connection setting with a drop down. Pull it down and select the vSwitch you created above. This can be done while the vm is booted. The effect is immediate.

HTH.
network.png
network2.png
atorexAsked:
Who is Participating?
 
Andrew Hancock (VMware vExpert / EE MVE^2)Connect With a Mentor VMware and Virtualization ConsultantCommented:
The hardware nic that is vmnic3 gets no ip?

this is correct, and normal. You will never be able to assign an IP Address to vmnic3, you do not need to for this to function, so your VMs can send traffic to the internet.

The physical nics, 3 are on the 172 network (vmnic0 to vmnic2)

Correct, I would expect that.

So assign IP Addresses to your VMs connected to the Virtual Machine Portgroup, which is connected to the vSwitch, connected to VMNIC3, which is connected to your ASA with the ISP NAT.

Do you want to connect to the ESXi server on 192 as well as 172?
0
 
mcsweenSr. Network AdministratorCommented:
Make sure you assign a valid IP to that NIC in the virtual machine for that network.  If it is connected directly to the internet then it will be a public IP provided by your ISP unless you put a firewall in front of it.
0
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
can you upload screenshots of your:-

1. vSwitch
2. VM configuration
0
Improve Your Query Performance Tuning

In this FREE six-day email course, you'll learn from Janis Griffin, Database Performance Evangelist. She'll teach 12 steps that you can use to optimize your queries as much as possible and see measurable results in your work. Get started today!

 
atorexAuthor Commented:
0
 
coolsport00Commented:
2 things - first, you just provided a screenshot of your vSwitch properties....if you could instead, provide a screenshot of what is seen on the Configuration tab > Networking section (i.e show us what vSwitches you have configured).

Since I assisted you on your prev question, your 2nd screenshot of your VM isn't configured correctly. You have the 1 vNIC and that's fine. Connect that to the VM Netwk port group of your internal LAN. You should've created a 2nd vSwitch and assigned the pNIC of the Host that is connected to the ISP/Hosting site you want to connect to. To create the vSwitch, on the Networking area, click Add Networking and select VM Network. Choose the pNIC to the Host site and give this VM Network pg a name. Then, go back into your VM settings, select Add button, add an Ethernet Adapter, then choose the network you want to assign this new vNIC to, which will be the new VM Netwk pg you just created on your 2nd vSwitch.

Regards.
~coolsport00
0
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
what is Grove_VN?

could you also screenshot the vSwitch?

is Grove_VN connected to this vSwitch?

is this vSwitch connected to a physical NIC connected to your ISP?

how have you configured your VM - DHCP?
0
 
atorexAuthor Commented:
here is what I think you wanted
vswitch2.png
0
 
atorexAuthor Commented:
what is Grove_VN?
could you also screenshot the vSwitch?
is Grove_VN connected to this vSwitch?
is this vSwitch connected to a physical NIC connected to your ISP?
how have you configured your VM - DHCP?

this is the new switch I created and is attached to nic3, ESX will not allow me to set a atatic IP for each NIC this may be my issue, the VM is set to DHCP but no data is geting to it, it sends DHCP request nothing comes back.
0
 
atorexAuthor Commented:
Since I assisted you on your prev question, your 2nd screenshot of your VM isn't configured correctly. You have the 1 vNIC and that's fine. Connect that to the VM Netwk port group of your internal LAN. You should've created a 2nd vSwitch and assigned the pNIC of the Host that is connected to the ISP/Hosting site you want to connect to. To create the vSwitch, on the Networking area, click Add Networking and select VM Network. Choose the pNIC to the Host site and give this VM Network pg a name. Then, go back into your VM settings, select Add button, add an Ethernet Adapter, then choose the network you want to assign this new vNIC to, which will be the new VM Netwk pg you just created on your 2nd vSwitch.

Regards.
~coolsport00

grove_VN is the new vSwitch i created and the VM is attached to it
0
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
you do not set an IP Address on the switch, it's an "unmanaged switch" which passes the traffic to the VM. So don't get hung up on this, does not matter, and cannot be done!

Okay, does your ISP send DHCP info?

how is your Public IP Address delivered? to a router?

what router do you have?
0
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
your VM is not connected to the correct vSwitch and NIC! (ISP)
0
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
nic3 should be connected to a seperate vSwitch.
0
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
grove_VN is a Virtual Machine Portgroup. (not a vswitch)

should be like this

VM ---> grove_VN (Virtual Machine Portgroup.) ----> vSwitch2 (vSwitch) ----> vmnic3 ----> ISP
0
 
coolsport00Commented:
Ok, so what I recommend is this, for clarity & simplicity sake - click on the Properties of that vSwitch0 and remove that GROVE_VM Network PG. On the Add Networking link, click on that then choose VM Network, select new vSwitch and choose the vmnic, which seems like it's vmnic1, that you want assigned to the new VM Netwk PG (and that I assume is connected to the ISP Host site). Ok, so once that's done, your networking is configured. So now, go into the VM's Edit Settings and follow my prev comment on how to add another Ethernet Adapter.

~coolsport00
0
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
could you expand on how you connect to your ISP, and public IP addresses that have been allocated?
0
 
atorexAuthor Commented:
the Network is, a Cisco 3560 for the internal office network, I have another ASA connected to the internet for hosting purpouses, a hardware server is already on this network with a static IP. we use 172 Ip range for internal and I have 192 IP for the internal address of the hosted servers.

I have done the steps of deleting and recreating the VSwitch and I think its done correctly this time, I think I did it from the properties of the vSwitch0 last time (my bad not the direction I received)

let me do some testing and will see, here is the new setup.
newVswitch.png
0
 
coolsport00Commented:
That looks much better. Again, if you want that VM to also connect to internal network, just add another Ethernet Adapter in its settings area and select an 'internal' VM Netwk port group.

~coolsport00
0
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
looks good if that is the VM which needs to connection.

e.g. iks this the VM which needs access - Live_drs_app
0
 
atorexAuthor Commented:
Now, ESX will only allow me to set IP for one NIC is there a way for me to assign a static IP to that NIC?

Thanks for the help and patience, migrating a new Domain at the same time so Im loosing it.
0
 
coolsport00Commented:
You assign an IP on the virtual NIC (vNIC) within the VM's guest OS. You don't assign the IP within ESXi's Network vSwitch properties or anything.
0
 
atorexAuthor Commented:
No I was talking about the hardware NIC, I have one IP of 172.0.0.15 for the internal network, doesnt the NIC on the 192.168.50.0 network need an IP?
0
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
think of the vSwitch (in ESXi) as an unmanaged switch, it does not need an IP Address, just like a physical switch (unmanaged) does not need an IP address to connect computers!

So I would assume, that the VM is still not getting an IP Address, which if this is the case, we need to understand your network, and external facing arrangement.

it might be that you are required to give your VM an internal IP Address and use a NAT translation to the external public facing IP Address.

could you expand on what this VM does, and why it needs a public facing IP Address?

OR, has your ISP given you a Public IP Address on this LAN?

and is it the Guest or Host which needs to be on the LAN?
0
 
atorexAuthor Commented:
The ISP facing VMs are connected to a Cisco ASA with NAT, the internal IP on that network is the 192.168.50 subnet, our internal network uses 172 address and after the changes I can no longer access the ESX server from within 172 network. once I unplug that NIC on the 192 network I can now get in to the ESX from 172 network.
0
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
okay, so all the ISP facing VMs need to have an IP Address of 192.168.0.50, with NAT translations from Public IP Address to their respective 192.168.0.50 IP Address.

Internally Host is 172.

so it should be conmnected

VM (192.168.0.50) ---> NewVSwitch (Virtual Machine Portgroup.) ----> vSwitch1 (vSwitch) ----> vmnic3 ----> 192.168.0.50

ESX and Other VMs (172.x.x.x) --->  VM Network (Virtual Machine Portgroup.) ----> vSwitch0 (vSwitch) ----> vmnic0,1,2 ---->Local LAN
0
 
atorexAuthor Commented:
That's correct my issue now is that I can't assign a .50ip to vmnic3, and without it the vm on that Vswitch can't get an IP
0
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
you do not assign an IP Address to vmnic3. (ever). vSwitch do not work that way. It's an unmanaged switch, it does not require an IP Address to bridge network traffic.

vmnic3 is connected to a switch, network traffic passes down vmnic3, to the vSwitch, down the network portgroup to the VM.

so what IP Address have you give the VM NIC in the OS?

have you assigned an IP Address to the Virtual Machine NIC in the OS?

where it vmnic3 connected?

where are vmnic0,1,2 connected?

to the same physical switch?
0
 
atorexAuthor Commented:
The hardware nic that is vmnic3 gets no ip?
The physical nics, 3 are on the 172 network (vmnic0 to vmnic2) and the fourth is attached to the ASA with the ISP NAT (vmnic3)
0
 
atorexAuthor Commented:
OK, Now I understand and its working thanks to your detailed knowlegeble help (I was about to move the systems back to Hyper-V) but I can communicate to the 192 LAN on all VM's in the new vSwitch and access the Internet, most importantly I have a much better understanding of how it showld work for future refrence. All is working as desired.
Again thanks for all the help
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.