Solved

WSS 3.0 - Under Construction page and "Cannot connect to the configuration database"

Posted on 2012-12-20
8
705 Views
Last Modified: 2012-12-21
This sharepoint site was working until we had to demote and promote the server. (Don't ask).  I had a good backup of the database but when i restore them I get the "Under Configuration" page when trying to connect to http://servername and I get "Cannot connect to the configuration database" when I try to connect to http://localhost or when I try to open Sharepoint 3.0 Central Administration.

What I did to get to this point.  I removed and reinstalled WSS 3.0.  This re-created the Windows Internal Database and then I ran the Sharepoint Products and Tech Configuration Wizard.  After that completed I restored the admin and config databases to the ones created by the wizard.

I'm sure I did something wrong but I don't know what.  

Anyone care to point out what i did wrong?

Thanks in advance!

Craig
0
Comment
Question by:computerconcepts
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 3
8 Comments
 
LVL 43

Expert Comment

by:Eugene Z
ID: 38710367
check if this WSS2 solution can work for you:

http://support.microsoft.com/kb/823287

or/and this one

WSS 3.0 – Cannot connect to the configuration database
http://blog.rojakstyle.com/?p=480
0
 

Author Comment

by:computerconcepts
ID: 38710408
Thanks but I've already visted those sites and no, unfortunately neither one helped.
0
 
LVL 43

Expert Comment

by:Eugene Z
ID: 38710452
I assume the IIS reset and sql server reboot were in place.

Any errors in EV  on the WSS server?
Any errors=in sql server? check Sql error it may tell you about failed login
you may need to check WSSWEBserver$ login there
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 

Author Comment

by:computerconcepts
ID: 38711092
Unknown SQL Exception 33002 occured. Additional error information from SQL Server is included below.

Access to module dbo.proc_getObjectsByClass is blocked because the signature is not valid.

That is what i get in the EV.  Event ID 5586.

*********************

Also get this one along with it:  Event ID 33002

The description for Event ID ( 33002 ) in Source ( MSSQL$MICROSOFT##SSEE ) cannot be found. The local computer may not have the necessary registry information or message DLL files to display messages from a remote computer. You may be able to use the /AUXSOURCE= flag to retrieve this description; see Help and Support for details. The following information is part of the event: module, dbo.proc_getObjectsByClass.
0
 

Author Comment

by:computerconcepts
ID: 38711258
More info:

The sharepoint_config database is in single user mode.  

From what i have learned this is because an update/upgrade didnt apply properly.  So i ran psconfig -cmd upgrade -inplace b2b -wait -force from C:\Program Files\Common File\Microsoft Shared\web server extensions\12\bin directory but now it gives me "An exception of type System.Data.SqlClient.SqlException was thrown." The login failed. Login failed for user DOMAIN\Administrator

Another site i found suggests finding the database id, then find who connected to it and look for spid, run master and kill 147 then set to multi_user but i have no idea how to do this.  Can anyone help me with this?  Anyone know what the heck that is?
0
 

Author Comment

by:computerconcepts
ID: 38711315
OK, so I figured out what the whole spid  run master and kill means.  But now it tells me when i run the query to kill the database id for the Sharepoint_config database "Cannot use KILL to kill your own process."

I'm using master and it still tells me this.  Any suggestions?
0
 
LVL 43

Accepted Solution

by:
Eugene Z earned 500 total points
ID: 38711359
<Cannot use KILL to kill your own process."

open another SSMS session and try to kill or change DB connection : from SSMS or use master or just close ssms , etc
0
 

Author Closing Comment

by:computerconcepts
ID: 38713526
I did that and still no luck.  I'm prob doing something wrong.  I ended up restoring a backup again and now it's in multi-user mode but I'm back to the original problem.  I'm going to suggest we start over from scratch with new database and manually enter he calendar data.  Turns out this sharepoint site was only used for vacation calendar and one other smaller calendar.  

Thanks for your help!
0

Featured Post

Complete VMware vSphere® ESX(i) & Hyper-V Backup

Capture your entire system, including the host, with patented disk imaging integrated with VMware VADP / Microsoft VSS and RCT. RTOs is as low as 15 seconds with Acronis Active Restore™. You can enjoy unlimited P2V/V2V migrations from any source (even from a different hypervisor)

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article explains how to reset the password of the sa account on a Microsoft SQL Server.  The steps in this article work in SQL 2005, 2008, 2008 R2, 2012, 2014 and 2016.
A Stored Procedure in Microsoft SQL Server is a powerful feature that it can be used to execute the Data Manipulation Language (DML) or Data Definition Language (DDL). Depending on business requirements, a single Stored Procedure can return differe…
Via a live example, show how to extract information from SQL Server on Database, Connection and Server properties
Viewers will learn how the fundamental information of how to create a table.

707 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question