Link to home
Start Free TrialLog in
Avatar of computerconcepts
computerconceptsFlag for United States of America

asked on

WSS 3.0 - Under Construction page and "Cannot connect to the configuration database"

This sharepoint site was working until we had to demote and promote the server. (Don't ask).  I had a good backup of the database but when i restore them I get the "Under Configuration" page when trying to connect to http://servername and I get "Cannot connect to the configuration database" when I try to connect to http://localhost or when I try to open Sharepoint 3.0 Central Administration.

What I did to get to this point.  I removed and reinstalled WSS 3.0.  This re-created the Windows Internal Database and then I ran the Sharepoint Products and Tech Configuration Wizard.  After that completed I restored the admin and config databases to the ones created by the wizard.

I'm sure I did something wrong but I don't know what.  

Anyone care to point out what i did wrong?

Thanks in advance!

Craig
Avatar of EugeneZ
EugeneZ
Flag of United States of America image

check if this WSS2 solution can work for you:

http://support.microsoft.com/kb/823287

or/and this one

WSS 3.0 – Cannot connect to the configuration database
http://blog.rojakstyle.com/?p=480
Avatar of computerconcepts

ASKER

Thanks but I've already visted those sites and no, unfortunately neither one helped.
I assume the IIS reset and sql server reboot were in place.

Any errors in EV  on the WSS server?
Any errors=in sql server? check Sql error it may tell you about failed login
you may need to check WSSWEBserver$ login there
Unknown SQL Exception 33002 occured. Additional error information from SQL Server is included below.

Access to module dbo.proc_getObjectsByClass is blocked because the signature is not valid.

That is what i get in the EV.  Event ID 5586.

*********************

Also get this one along with it:  Event ID 33002

The description for Event ID ( 33002 ) in Source ( MSSQL$MICROSOFT##SSEE ) cannot be found. The local computer may not have the necessary registry information or message DLL files to display messages from a remote computer. You may be able to use the /AUXSOURCE= flag to retrieve this description; see Help and Support for details. The following information is part of the event: module, dbo.proc_getObjectsByClass.
More info:

The sharepoint_config database is in single user mode.  

From what i have learned this is because an update/upgrade didnt apply properly.  So i ran psconfig -cmd upgrade -inplace b2b -wait -force from C:\Program Files\Common File\Microsoft Shared\web server extensions\12\bin directory but now it gives me "An exception of type System.Data.SqlClient.SqlException was thrown." The login failed. Login failed for user DOMAIN\Administrator

Another site i found suggests finding the database id, then find who connected to it and look for spid, run master and kill 147 then set to multi_user but i have no idea how to do this.  Can anyone help me with this?  Anyone know what the heck that is?
OK, so I figured out what the whole spid  run master and kill means.  But now it tells me when i run the query to kill the database id for the Sharepoint_config database "Cannot use KILL to kill your own process."

I'm using master and it still tells me this.  Any suggestions?
ASKER CERTIFIED SOLUTION
Avatar of EugeneZ
EugeneZ
Flag of United States of America image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
I did that and still no luck.  I'm prob doing something wrong.  I ended up restoring a backup again and now it's in multi-user mode but I'm back to the original problem.  I'm going to suggest we start over from scratch with new database and manually enter he calendar data.  Turns out this sharepoint site was only used for vacation calendar and one other smaller calendar.  

Thanks for your help!