Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people, just like you, are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
Solved

Cannot Remove Read only Attribute on sbs2003 install

Posted on 2012-12-20
5
521 Views
Last Modified: 2013-03-31
Hi Experts,

I have a strange one. I just rebuilt a customers sbs2003 machine, The drives used for files etc remained untouched and came up fine when the machine was rebuilt. As an admin I can do anytthing, create, rename folders and files etc, but when these users who access the same drive through a mapped share try to create a file/folder etc they get access is denied even though I have granted them full access as they should have.

I have gone through and given administrators ownership on the drive and folders. I have also tried right clicking on the folders and unticking the 'read only' option, but after applying it to folders/subfolders etc it just resets itself back to read only.

I have followed this KB http://support.microsoft.com/kb/326549

and ran the attrib -r +s drive:\<path>\<foldername> /s /d as described, but the attribute keeps resetting back to read only.

I really need to solve this so I can reinstall some applications for the users that run off the shared drive.

Thanks!
0
Comment
Question by:franklintech
  • 4
5 Comments
 
LVL 23

Expert Comment

by:Thomas Grassi
ID: 38710485
Try switching to D:, cd \ then issuing "attrib -R * /s /d" the "*" forces it to process all files and subfolders
change to which ever drive letter it is

Hope that helps
0
 

Author Comment

by:franklintech
ID: 38710571
Legend!

I think you are onto something there, ran that and got a errors such as " Not resetting hidden file - F:\newZ\Trees\Feijoa\Thumbs.db " 

so then found this http://support.microsoft.com/kb/81361

Looks like the files may be hidden also! will remove that attrib and see what happens.
Thanks for the reply! will award points once I have solved this.
0
 

Author Comment

by:franklintech
ID: 38753726
well im back on this, tried the above and it reset back to read only and only an admin on the server can create folders etc,

Tried copying the files to a portable drive and then running this command also and its reset itself, just going to robocopy the files minus permissions to a freshly formatted drive and see how that works.
0
 

Accepted Solution

by:
franklintech earned 0 total points
ID: 38753787
hurrah, looks like copying them to another drive via robocopy has solved it..
0
 

Author Closing Comment

by:franklintech
ID: 39035268
fixed
0

Featured Post

Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Because virtualization becomes more and more common, and, with Microsoft Hyper-V included in Windows Server at no additional costs, and, most server hardware nowadays is more than capable of running a physical Small Business Server (SBS) 2008 or 201…
You may have discovered the 'Compatibility View Settings' workaround for making your SBS 2008 Remote Web Workplace 'connect to a computer' section stops 'working around' after a Windows 10 client upgrade.  That can be fixed so it 'works around' agai…
Nobody understands Phishing better than an anti-spam company. That’s why we are providing Phishing Awareness Training to our customers. According to a report by Verizon, only 3% of targeted users report malicious emails to management. With compan…

828 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question