Linux and Erlang install

I just executed the following

        wget -O /etc/yum.repos.d/epel-erlang.repo http://repos.fedorapeople.org/repos/peter/erlang/epel-erlang.repo

Open in new window


I go to the directory and the repository is there

[root@rhel ~]# cd /etc/yum.repos.d
[root@rhel yum.repos.d]# ls epel-erlang.repo
epel-erlang.repo
[root@rhel yum.repos.d]#

Open in new window


The site I am getting this from has incomplete instructions

Now that I have the file what do I do.  Apparently not an rpm

Do I perofmr a yum command, how do I install the repository ?

Thanks
Los Angeles1Asked:
Who is Participating?
 
woolmilkporcConnect With a Mentor Commented:
These tools must be run as root.

Here is the HOWTO on subscription manager:

https://access.redhat.com/knowledge/docs/en-US/Red_Hat_Enterprise_Linux/6/html/Deployment_Guide/launching-ents-tools.html

If you don't even have that tool installed it's quite probable that you're not running certificate-based.
0
 
Los Angeles1Author Commented:
I just tried a yum install erlang, and got the following


--> Finished Dependency Resolution
erlang-odbc-R14B-04.1.el5.x86_64 from epel-erlang has depsolving problems
  --> Missing Dependency: libodbc.so.1()(64bit) is needed by package erlang-odbc-R14B-04.1.el5.x86_64 (epel-erlang)
wxGTK-2.8.12-1.el5.x86_64 from epel has depsolving problems
  --> Missing Dependency: libSDL-1.2.so.0()(64bit) is needed by package wxGTK-2.8.12-1.el5.x86_64 (epel)
Error: Missing Dependency: libodbc.so.1()(64bit) is needed by package erlang-odbc-R14B-04.1.el5.x86_64 (epel-erlang)
Error: Missing Dependency: libSDL-1.2.so.0()(64bit) is needed by package wxGTK-2.8.12-1.el5.x86_64 (epel)
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest
The program package-cleanup is found in the yum-utils package.
[root@rhel yum.repos.d]#

How can I install these dependencies ?
0
 
woolmilkporcCommented:
I think you should consult the Fedora EPEL project pages.

This one

http://fedoraproject.org/wiki/EPEL

says in regard to RHEL and dependencies:

You need to also enable the 'optional' repository to use EPEL packages as they depend on packages in that repository. This can be done by enabling the RHEL optional subchannel for RHN-Classic. For certificate-based subscriptions see RHEL Deployment Guide.

Here is how to enable an additional subchannel:

https://access.redhat.com/knowledge/solutions/11312

And this is the part of the Deployment Guide on supplementary repositories:

http://rdsrc.us/sjzdtd
0
Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

 
Los Angeles1Author Commented:
The guides gave the following example:

[root@server ~]# yum repolist all
repo id                      repo name                           status
rhel-6-server                Red Hat Enterprise Linux 6Server -  enabled
rhel-6-server-beta           Red Hat Enterprise Linux 6Server Be enabled
rhel-6-server-optional-rpms  Red Hat Enterprise Linux 6Server Op disabled
rhel-6-server-supplementary  Red Hat Enterprise Linux 6Server Su disabled

Open in new window


From which I could either perform

yum-config-manager --enable rhel-6-server-optional-rpms

Open in new window


or

yum install rubygems --enablerepo=rhel-6-server-optional-rpms  // for rubygems

Open in new window


So I went to my system and found

[root@rhel yum.repos.d]# yum repolist all
Loaded plugins: rhnplugin, security
repo id                repo name                                  status
epel                   Extra Packages for Enterprise Linux 5 - x8 enabled: 7,228
epel-debuginfo         Extra Packages for Enterprise Linux 5 - x8 disabled
epel-erlang            Erlang/OTP R14B                            enabled:   238
epel-erlang-source     Erlang/OTP R14B - Source                   disabled
epel-source            Extra Packages for Enterprise Linux 5 - x8 disabled
epel-testing           Extra Packages for Enterprise Linux 5 - Te disabled
epel-testing-debuginfo Extra Packages for Enterprise Linux 5 - Te disabled
epel-testing-source    Extra Packages for Enterprise Linux 5 - Te disabled
rhel-debuginfo         Red Hat Enterprise Linux 5Server - x86_64  disabled
rhel-debuginfo-beta    Red Hat Enterprise Linux 5Server Beta - x8 disabled
repolist: 7,466
[root@rhel yum.repos.d]#

Open in new window


So I do not see an 'optional' repository.

Is there a way to get an 'optional' repository, and how can I get one ?
0
 
woolmilkporcCommented:
Could it be that your subscription is incomplete?

You could try "subscription-manager" or "subscription-manager-gui" to check.

Do you use RHEL Classic channels or RHEL Certificate-based product certificates?

If Classic, did you look here?

https://www.redhat.com/wapps/sso/login.html?redirect=https%3A%2F%2Frhn.redhat.com%2Frhn%2Fsoftware%2Fchannels%2FAll.do

I don't have an RHEL entitlement, so I can't give any further detail.
0
 
Los Angeles1Author Commented:
I tried the following but it did not work

[root@rhel yum.repos.d]# subscription-manager
bash: subscription-manager: command not found
[root@rhel yum.repos.d]#
[root@rhel yum.repos.d]# subscription-manager-gui
bash: subscription-manager-gui: command not found
[root@rhel yum.repos.d]#

Did I perform that correctly ?

Also, how do I tell if I use RHEL Classic channels or RHEL Certificate-based product certificates?
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.