• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 626
  • Last Modified:

Exchange 2010 Global Address Book not updating

We recently migrated to Exchange 2010 from 2003.  When adding new users they are not being added to the global address list.  I ran the below command a few minutes ago and still when even maually updating the address book it's not working.  Do I need to wait longer?

http://blogs.technet.com/b/exchange/archive/2007/01/11/3397719.aspx
0
gopher_49
Asked:
gopher_49
  • 4
  • 3
1 Solution
 
jramsierCommented:
With the GAL you always got to find out if it is an issue with GAL or Outlook, often time it is outlook.  If you open up OWA you will see a direct connection into the exchange server and from there see if the address book is updated.  

On outlook make sure you send and recieve all items (F9 i think works too)
0
 
gopher_49Author Commented:
OWA see's the new addresses...  My Outlook and many others are not updating.. I tried F9, send/receive, and the update of address book too..  What else should I try?
0
 
jramsierCommented:
Can be many items:

Try these steps to ensure it is not a downloading problem:
http://help.unc.edu/help/exchange-how-to-update-the-global-address-book-in-outlook/

Swap to or from cached mode

Delete all items in this folder (with outlook closed, may reset some settings):
C:\Users\jramsier\AppData\Local\Microsoft\Outlook

Open the Address Book and right-click on Global Address List, then click Properties.  Where does it say it is pulling from?
0
NFR key for Veeam Agent for Linux

Veeam is happy to provide a free NFR license for one year.  It allows for the non‑production use and valid for five workstations and two servers. Veeam Agent for Linux is a simple backup tool for your Linux installations, both on‑premises and in the public cloud.

 
BillBondoCommented:
I have seen the cached mode do this. Try (un)checking it.
0
 
gopher_49Author Commented:
The global address book properties show the below information.  I tried everything suggested except disabling cache mode and re-enabling.  That is not a good solution for I have too many users with these symptoms with huge mailboxes.  I'm currently downloading the addresss book without the check mark stating to download since last send/receiving.  I'm hoping this will force it.  

C:\Users\myusername\AppData\Local\Microsoft\Outlook\Offline Address Books\a02badd4-9cad-46b9-a602-6f477ca0306b\

\Global Address List
0
 
jramsierCommented:
Is this a 1 server or multi exchange server?  I have seen IIS have funcky settings with multiple servers are installed.

try to delete the folder location above.  As for the enable disable cache, if that fixes you can do it through GPO is you have that setup.
0
 
gopher_49Author Commented:
I deleted every item in 'C:\Users\myusername\AppData\Local\Microsoft\Outlook\Offline Address Books' and it now works..  I can easily send these instructions to most users.... The one that aren't capable I'll do via admin share from my desk or use a GPO.

Thanks!
0
 
gopher_49Author Commented:
As mentioned in my previous post deleting the items in 'C:\Users\myusername\AppData\Local\Microsoft\Outlook\Offline Address Books' fixed it.
0

Featured Post

Prep for the ITIL® Foundation Certification Exam

December’s Course of the Month is now available! Enroll to learn ITIL® Foundation best practices for delivering IT services effectively and efficiently.

  • 4
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now