• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 514
  • Last Modified:

ora 904 invalid identifier 10g

I have two database links going from one database to two others.
I do a

select owner.function_name@database_link ('50458093010') from dual;

one works the other doesn't
other than the owner and the database link everything is the same including the function

have no clue as to why

the database links test successfully
0
bkreynolds48
Asked:
bkreynolds48
  • 4
  • 3
1 Solution
 
slightwv (䄆 Netminder) Commented:
It looks like the function on the one server isn't correct/working.
0
 
bkreynolds48Author Commented:
I tried taking the function that works and putting it in the other database but still have the same error
0
 
slightwv (䄆 Netminder) Commented:
Log into the other database and make sure the function works.
Double check the database link is using the correct user and thus executing the correct function.

Are the database versions between the working server and non-working server the same?
0
Veeam and MySQL: How to Perform Backup & Recovery

MySQL and the MariaDB variant are among the most used databases in Linux environments, and many critical applications support their data on them. Watch this recorded webinar to find out how Veeam Backup & Replication allows you to get consistent backups of MySQL databases.

 
bkreynolds48Author Commented:
it runs fine in the destination server but when it is run in database one with the database link it doesn't work - link is fine - very weird  - database version / os are the same - will go and check the user in the link
0
 
slightwv (䄆 Netminder) Commented:
As a sanity check, on the failed server add a dbms_output.put_line('Hello World'); to the function.  Then "set serveroutput on" on the calling session and call the function.

You should see the output to make sure you are calling the correct function.
0
 
bkreynolds48Author Commented:
will give that a try tomorrow - thanks
0
 
Guy Hengel [angelIII / a3]Billing EngineerCommented:
if one function works, and the other one reports "invalid identifier", you may be missing execute permissions on the other one ...
0
 
bkreynolds48Author Commented:
the permissions were granted through a role and work fine elsewhere - this is a new build so something was missed

Thanks
0

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 4
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now