Solved

another dmz question

Posted on 2012-12-20
3
422 Views
Last Modified: 2012-12-25
sorry but is anybody able to look at this config and tell me what to change to allow access from the outside to machines in the dmz ?  Like if I wanted to plug in a machine with ip 10.10.10.30, what would need to be changed?
thank you so much if you are.  sorry I am still studying this

:
PIX Version 8.0(4)
!
hostname pixfirewall
enable password kXFUkE.9ihdHDCyV level 5 encrypted
enable password bE.iKxBAtjsVUrl8 encrypted
passwd lQidpnRbuUXg7iHi encrypted
names
!
interface Ethernet0
 speed 100
 duplex full
 nameif outside
 security-level 0
 ip address 12.12.12.148 255.255.255.248
!
interface Ethernet1
 speed 100
 duplex full
 nameif inside
 security-level 100
 ip address 192.168.1.1 255.255.255.0
!
interface Ethernet2
 speed 100
 duplex full
 nameif dmz
 security-level 50
 ip address 10.10.10.1 255.255.255.0
!
boot system flash:/pix804-32.bin
ftp mode passive
object-group protocol TCPUDP
 protocol-object udp
 protocol-object tcp
object-group service tcp3389 tcp
 description tcp3389
 port-object eq 3389
object-group service imap993 tcp
 port-object eq 993
object-group service smtp587 tcp
 port-object eq 587
object-group service pop995 tcp
 port-object eq 995
object-group service DM_INLINE_TCP_1 tcp
 group-object imap993
 group-object pop995
 group-object smtp587
 port-object eq www
 port-object eq https
 port-object eq smtp
 group-object tcp3389
object-group service DM_INLINE_TCP_2 tcp
 port-object eq www
 port-object eq https
object-group service DM_INLINE_TCP_3 tcp
 port-object eq www
 port-object eq https
access-list inside_access_in extended deny ip host 192.168.1.54 any
access-list inside_access_in extended deny ip host 192.168.1.100 any
access-list inside_access_in extended permit ip host 192.168.1.110 any
access-list inside_access_in extended permit ip host 192.168.1.179 any
access-list inside_access_in extended permit tcp 192.168.1.0 255.255.255.0 any object-group DM_INLINE_TCP_3
access-list inside_access_in extended permit ip host 10.10.10.12 any
access-list outside_access_in extended permit tcp any host 12.12.12.150 object-group DM_INLINE_TCP_1
access-list outside_access_in extended permit tcp any host 12.12.12.147 object-group DM_INLINE_TCP_2
access-list outside_access_in extended permit tcp any host 12.12.12.156 eq www
pager lines 24
logging enable
logging asdm informational
mtu outside 1500
mtu inside 1500
mtu dmz 1500
ip local pool ipppoolzojio2 192.168.22.2-192.168.22.20 mask 255.255.255.0
icmp unreachable rate-limit 1 burst-size 1
icmp deny any outside
icmp permit any inside
asdm image flash:/asdm-615.bin
asdm history enable
arp timeout 14400
nat-control
global (outside) 1 12.12.12.150 netmask 12.12.12.150
nat (inside) 1 12.12.12.150 255.255.255.255
nat (inside) 1 192.168.1.0 255.255.255.0
nat (inside) 1 0.0.0.0 0.0.0.0
static (dmz,dmz) tcp 12.12.12.147 www 10.10.10.12 www netmask 255.255.255.255
static (inside,outside) tcp 12.12.12.150 smtp 192.168.1.17 smtp netmask 255.255.255.255
static (inside,outside) tcp 12.12.12.150 pop3 192.168.1.17 pop3 netmask 255.255.255.255
static (inside,outside) tcp 12.12.12.150 993 192.168.1.17 993 netmask 255.255.255.255
static (inside,outside) tcp 12.12.12.150 587 192.168.1.17 587 netmask 255.255.255.255
static (inside,outside) tcp 12.12.12.150 https 192.168.1.17 https netmask 255.255.255.255
static (inside,outside) tcp 12.12.12.150 www 192.168.1.17 www netmask 255.255.255.255
static (dmz,dmz) 12.12.12.153 10.10.10.9 netmask 255.255.255.255
static (dmz,dmz) 12.12.12.157 10.10.10.8 netmask 255.255.255.255
static (dmz,dmz) 12.12.12.158 10.10.10.30 netmask 255.255.255.255
static (inside,outside) 12.12.12.156 192.168.1.201 netmask 255.255.255.255
static (inside,outside) 12.12.12.147 192.168.1.179 netmask 255.255.255.255
static (inside,outside) 12.12.12.146 192.168.1.11 netmask 255.255.255.255
access-group outside_access_in in interface outside
access-group inside_access_in in interface inside
route outside 0.0.0.0 0.0.0.0 12.12.12.145 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
dynamic-access-policy-record DfltAccessPolicy
http server enable
http 0.0.0.0 0.0.0.0 inside
http 12.12.12.148 255.255.255.255 outside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac
crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac
crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set security-association lifetime seconds 28800
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set security-association lifetime kilobytes 4608000
crypto isakmp policy 5
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
crypto isakmp policy 10
 authentication pre-share
 encryption des
 hash sha
 group 2
 lifetime 86400
client-update enable
telnet 0.0.0.0 0.0.0.0 inside
telnet 192.168.1.0 255.255.255.0 inside
telnet timeout 5
ssh 12.12.12.148 255.255.255.255 outside
ssh timeout 5
console timeout 0
management-access inside
dhcpd dns 208.67.222.222 208.67.220.220
!
dhcpd address 192.168.1.100-192.168.1.200 inside
dhcpd dns 192.168.1.4 192.168.1.17 interface inside
dhcpd enable inside
!
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
group-policy DfltGrpPolicy attributes
 vpn-tunnel-protocol IPSec
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny  
  inspect sunrpc
  inspect xdmcp
  inspect sip  
  inspect netbios
  inspect tftp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:990c15ac073b3f49a776ac0fa7043cc3
: end
0
Comment
Question by:elmert
  • 2
3 Comments
 
LVL 10

Expert Comment

by:djcanter
ID: 38711164
-edit - deleted comment
0
 

Accepted Solution

by:
elmert earned 0 total points
ID: 38711603
weird, I figured it out (I think).
:
PIX Version 8.0(4)
!
hostname pixfirewall
enable password kXFUkE.9ihdHDCyV level 5 encrypted
enable password bE.iKxBAtjsVUrl8 encrypted
passwd lQidpnRbuUXg7iHi encrypted
names
!
interface Ethernet0
 speed 100
 duplex full
 nameif outside
 security-level 0
 ip address 12.12.12.148 255.255.255.248
!
interface Ethernet1
 speed 100
 duplex full
 nameif inside
 security-level 100
 ip address 192.168.1.1 255.255.255.0
!
interface Ethernet2
 speed 100
 duplex full
 nameif dmz
 security-level 50
 ip address 10.10.10.1 255.255.255.0
!
boot system flash:/pix804-32.bin
ftp mode passive
object-group protocol TCPUDP
 protocol-object udp
 protocol-object tcp
object-group service tcp3389 tcp
 description tcp3389
 port-object eq 3389
object-group service imap993 tcp
 port-object eq 993
object-group service smtp587 tcp
 port-object eq 587
object-group service pop995 tcp
 port-object eq 995
object-group service DM_INLINE_TCP_1 tcp
 group-object imap993
 group-object pop995
 group-object smtp587
 port-object eq www
 port-object eq https
 port-object eq smtp
 group-object tcp3389
object-group service DM_INLINE_TCP_2 tcp
 port-object eq www
 port-object eq https
object-group service DM_INLINE_TCP_3 tcp
 port-object eq www
 port-object eq https
access-list inside_access_in extended deny ip host 192.168.1.54 any
access-list inside_access_in extended deny ip host 192.168.1.100 any
access-list inside_access_in extended permit ip host 192.168.1.110 any
access-list inside_access_in extended permit ip host 192.168.1.179 any
access-list inside_access_in extended permit tcp 192.168.1.0 255.255.255.0 any object-group DM_INLINE_TCP_3
access-list inside_access_in extended permit ip host 10.10.10.12 any
access-list outside_access_in extended permit tcp any host 12.12.12.150 object-group DM_INLINE_TCP_1
access-list outside_access_in extended permit tcp any host 12.12.12.147 object-group DM_INLINE_TCP_2
access-list outside_access_in extended permit tcp any host 12.12.12.156 eq www
access-list outside_access_in extended permit tcp any host 12.12.12.153 eq www
access-list outside_access_in extended permit tcp any host 12.12.12.158 eq www
pager lines 24
logging enable
logging asdm informational
mtu outside 1500
mtu inside 1500
mtu dmz 1500
ip local pool ipppoolzojio2 192.168.22.2-192.168.22.20 mask 255.255.255.0
icmp unreachable rate-limit 1 burst-size 1
icmp deny any outside
icmp permit any inside
asdm image flash:/asdm-615.bin
asdm history enable
arp timeout 14400
nat-control
global (outside) 1 12.12.12.150 netmask 12.12.12.150
nat (inside) 1 12.12.12.150 255.255.255.255
nat (inside) 1 192.168.1.0 255.255.255.0
nat (inside) 1 0.0.0.0 0.0.0.0
static (inside,outside) tcp 12.12.12.150 smtp 192.168.1.17 smtp netmask 255.255.255.255
static (inside,outside) tcp 12.12.12.150 pop3 192.168.1.17 pop3 netmask 255.255.255.255
static (inside,outside) tcp 12.12.12.150 993 192.168.1.17 993 netmask 255.255.255.255
static (inside,outside) tcp 12.12.12.150 587 192.168.1.17 587 netmask 255.255.255.255
static (inside,outside) tcp 12.12.12.150 https 192.168.1.17 https netmask 255.255.255.255
static (inside,outside) tcp 12.12.12.150 www 192.168.1.17 www netmask 255.255.255.255
static (inside,outside) 12.12.12.156 192.168.1.201 netmask 255.255.255.255
static (inside,outside) 12.12.12.147 192.168.1.179 netmask 255.255.255.255
static (inside,outside) 12.12.12.146 192.168.1.11 netmask 255.255.255.255
static (dmz,outside) 12.12.12.153 10.10.10.9 netmask 255.255.255.255
static (dmz,inside) 12.12.12.153 10.10.10.9 netmask 255.255.255.255
static (dmz,outside) 12.12.12.158 10.10.10.30 netmask 255.255.255.255
static (dmz,inside) 12.12.12.158 10.10.10.30 netmask 255.255.255.255
access-group outside_access_in in interface outside
access-group inside_access_in in interface inside
route outside 0.0.0.0 0.0.0.0 12.12.12.145 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
dynamic-access-policy-record DfltAccessPolicy
http server enable
http 0.0.0.0 0.0.0.0 inside
http 12.12.12.148 255.255.255.255 outside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac
crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac
crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set security-association lifetime seconds 28800
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set security-association lifetime kilobytes 4608000
crypto isakmp policy 5
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
crypto isakmp policy 10
 authentication pre-share
 encryption des
 hash sha
 group 2
 lifetime 86400
client-update enable
telnet 0.0.0.0 0.0.0.0 inside
telnet 192.168.1.0 255.255.255.0 inside
telnet timeout 5
ssh 12.12.12.148 255.255.255.255 outside
ssh timeout 5
console timeout 0
management-access inside
dhcpd dns 208.67.222.222 208.67.220.220
!
dhcpd address 192.168.1.100-192.168.1.200 inside
dhcpd dns 192.168.1.4 192.168.1.17 interface inside
dhcpd enable inside
!
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
group-policy DfltGrpPolicy attributes
 vpn-tunnel-protocol IPSec
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny  
  inspect sunrpc
  inspect xdmcp
  inspect sip  
  inspect netbios
  inspect tftp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:72d3a7dbd1842e7d1c76bddc1446d942
: end
0
 

Author Closing Comment

by:elmert
ID: 38719882
whatever
0

Featured Post

PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

Join & Write a Comment

Have you experienced traffic destined through a Cisco ASA firewall disappears and you do not know if the traffic stops in the firewall or somewhere else? The solution is the capture feature. This feature was released in 6.2(1) and works in all firew…
Quality of Service (QoS) options are nearly endless when it comes to networks today. This article is merely one example of how it can be handled in a hub-n-spoke design using a 3-tier configuration.
It is a freely distributed piece of software for such tasks as photo retouching, image composition and image authoring. It works on many operating systems, in many languages.
Here's a very brief overview of the methods PRTG Network Monitor (https://www.paessler.com/prtg) offers for monitoring bandwidth, to help you decide which methods you´d like to investigate in more detail.  The methods are covered in more detail in o…

706 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

12 Experts available now in Live!

Get 1:1 Help Now