Can't Install Joomla

I'm trying to Install Joomla on my local computer, Windows 7.

I bought a book called "Joomla for Dummies".

It doesn't work.

See attached.

I installed XAMPP on my computer & set up a user / password using phpMyAdmin & a database called joomladb.

Is there some way around this?
install-error1.jpg
Richard KortsAsked:
Who is Participating?
 
Bill BachConnect With a Mentor PresidentCommented:
Actually, Joomla is the EASIEST thing -- copy up the install files, then launch the web browser, and click next/next through it, providing some basic into as you go.  I literally just did a Joomla v2.5 install on Tuesday as I added a new web site to my internal server -- it is a 5-minute task to get Joomla, JSN Epic Pro, and ImageShow installed & running.

As for your MySQL Admin password, this is set at install time, if I recall. Use "root" as the username, but you need to know your password.  Try the obvious ones, like "root", "admin", and anything else you use as a default password.  I know mine (which won't be yours), and it is one that is extra secure, because it houses a lot of data for 5 different web sites.  I did find this in a quick web search:  "The default password is "mysql", and I should read the Readme.txt file. Well, somebody could have said something... "

Again, if you don't have it, try starting over from scratch.
0
 
Bill BachPresidentCommented:
Either MySQL isn't set up properly and running, or you have the wrong password.  Can you confirm that you can sign onto the MySQL database with the username of root and the password you have provided?
0
 
Richard KortsAuthor Commented:
To BillBach,

Sure, but I have no clue how to do that.

Can I do that from XAMPP? How?
0
Introducing Cloud Class® training courses

Tech changes fast. You can learn faster. That’s why we’re bringing professional training courses to Experts Exchange. With a subscription, you can access all the Cloud Class® courses to expand your education, prep for certifications, and get top-notch instructions.

 
Bill BachPresidentCommented:
Whew.  It's been a REALLY long time.  You can go to the XAMPP control panel, find the line for MySQL, and click "Admin".  This should launch an admin console.  Login should be the credentials you were using.  If not, then you were using the wrong credentials.  

If you don't remember the credentials, then it is time to remove XAMPP and reinstall it.  Be sure to write down each user/password as you go.
0
 
Richard KortsAuthor Commented:
Doing what you suggested takes you to phpmyadmin.

The database is there.

I am TOTALLY confused on how to configure the UserID & password; there seems to be NO WAY to do that. I set up this database in the phpmyadmin db with a users & in the user table (of phpmyadmin) set the password. That appears to be unconnected to the db in question
0
 
Bill BachPresidentCommented:
Now I see your problem.  Do NOT create the database ahead of time!  The Joomla installation will create the database with the name you provide it on this screen.  The password is asks for is for the MySQL administrative access so that it can create the database.  

Because it is possible to have multiple web sites hosted on a single server, I would recommend creating a new database with the name of the site.  For example, if you are creating a Joomla install for SiteA, call the database SiteA.  That way, if you decide to add a new site, or if you decide to redeploy with a new set of templates and want to start fresh, you can create the next database as SiteB, SiteC, and so on.
0
 
Richard KortsAuthor Commented:
To BillBach,

OK, maybe that's a step. How do I find the MySQL admin password?

When I installed XAMPP, it did everything & didn't tell me about any passwords.

FYI, the Joomla for Dummies says I have to create the databse BEFORE I install Joomla. Page 27 in case you have it. They assume GoDaddy.

Installing Joomla is one of the most difficult things I've ever tried to do & I've been doing computers, databases, etc. for a LOOOOOOOOOOOG time.

All I'm try to do now is teach myself how to use Joomla on my own computer without having to do everything on a web server.
0
 
Dave BaldwinFixer of ProblemsCommented:
@BillBach, this is the second time for this question.  The original problem was that the version of Joomla would not install without a password for the MySQL user and the XAMPP install does not set a password for 'root' but phpMyAdmin does use 'root' without a password.  The sequence of setting a password for 'root' and getting phpMyAdmin to come back failed on @rkorts previous try and I wasn't able to walk him thru getting it to work.
0
 
Richard KortsAuthor Commented:
To BillBach,

OK, I've tried the following:

(1) went into mysql.ini & found a line called password = xxx commented out. I put in the password I wanted to use & uncommented it, saved the file.

(2) Made sure the database joomladb did NOT exist.

(3) Went through the Joomla install. It fails (as it always does) on step 4. See attached.

(4) I tried 3 with both "root" & "admin" as user. Same result.

(5) In looking at the text on the right, it is not clear if the database needs to have been created BEFORE or AFTER the Joomla install.

(5) Created a database in MySQL called joomladb.

(6) Tried it again; exact same result (as attached).

Any ideas?
install-error2.jpg
0
 
Bill BachPresidentCommented:
Did you restart MySQL (or the entire server) after you changed the INI file?  Honestly, I don't recall what I did to set this up originally.  I did my first XAMPP/Joomla 1.x install by following the directions provided.  I do seem to recall that there was a separate step for securing the database, now that you mention it, but I am not sure what that was.  A quick inquiry to Professor Google provided several useful hits, like this one:
    http://www.devshed.com/c/a/Administration/Install-XAMPP-on-Windows/1/

On my own server, I did find a batch file in the E:\xampp\mysql directory called resetroot.bat, which purports to reset the root password.  Not sure if that works until AFTER you go through the other steps, but both may be viable options for you.
0
 
Richard KortsAuthor Commented:
To All,

I found the solution. It is:

(1) Create a new mySQL database to use for joomla (I called it joomladb).

(2) Use "root" as the user name.

(3) Leave the password blank. This is apparently the key.

Doing this, it goes right through, I now have it installed.

Thanks,

rkorts
0
 
Richard KortsAuthor Commented:
The points are awarded for EFFORT. Solution found using another method; I had to pay,
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.