• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 740
  • Last Modified:

Windows 7 Pro file sharing permissions with user and password not accessible by other computers

created shared folder 'taxdata'. accessed it from other computers. yes it's accessible. but when i put  permissions with eligible users and passwords, no one can access the folder from other computers. error: you don't have permission to access this  folder.. yes, it prompts for user and password. but, when variables are entered, it does not recognize any.

however, when i allow everyone, it's accessible by other computers.

perhaps the correct question to ask is: how do i configure the shared folder to allow only those users and passwords including those from other computers?
0
Forinsight
Asked:
Forinsight
  • 8
  • 5
4 Solutions
 
dekkarCommented:
try this:

where it asks for a username, put it in the following format:


computername\username

so if the computer you are sharing from is called PC1 and the user is aaaa

the username would be PC1\aaaa
0
 
John HurstBusiness Consultant (Owner)Commented:
Make sure taxdata is c:\taxdata and not  buried down in your users folder.

Go to Control Panel, Network and Sharing Center, Advanced Sharing Options.

Make sure you are using Home/Work and not Public.
Make sure Network Discovery is on All computers.
Make sure File and Print Sharing is on All computers.
Turn off public sharing All computers.
Set for 128-bit encryption All computers.
Turn on Password Protected sharing All computers.
Set for User Accounts and Passwords All computers and don't use Home Group for this.

Restart all the computers and try accessing again. I use the above method and it works on my Windows 7 computers.

.... Thinkpads_User
0
 
ForinsightAuthor Commented:
to dekkar
when i removed the everyone it does not prompt for any user/password anymore.

to Thinkpads_User
the setup configuration for network as listed in your  answer has been my configuration.

no solution yet on sight.  

i can see from computer 2 the shared folder on computer 1. but, when i expand it, then pops up a window with the error: you don't have permission to access this folder. see your network admin....
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 
John HurstBusiness Consultant (Owner)Commented:
Open a regular command prompt one of the machines trying to access. Type:

NET USE Z: \\nameofwin7PC\foldername   and press enter. Authenticate.

What answer do you get?   Is taxdata in the root of C?  I was not clear.

... Thinkpads_User
0
 
John HurstBusiness Consultant (Owner)Commented:
@Forinsight,  

Try the following:

On the machine with c:\taxdata, set up a user of the other machine. So right click on Computer, select Manage, Local Users and Groups, Users and add the userid and the password from one of the machines trying to access C:\taxdata.  

Then restart both machines and try again using NET USE so we can see the errors.

Thanks, .... Thinkpads_User
0
 
ForinsightAuthor Commented:
"add the userid and the password from one of the machines trying to access C:\taxdata. "
the problem with this is that there is only one 'Locations" i could add user and that is the local workgroup, whichis the computer having the share. there is no option i could see that i could add other computer's users of the same workgroup.

i'm sure you could help me  with this because you helped once with just one statement i solved my problem.
0
 
John HurstBusiness Consultant (Owner)Commented:
I think you may be in a different spot than I was trying to point to. Where I want you to add users is in a spot different than where Workgroup lives. Leave Workgroup just as Workgroup.

Go to Local Users and Groups on the machine with c:\taxdata and add the user of the other machine here.  See below. The userid being added on the machine with c:\taxdata is the userid (and password) of one of the machines trying to connect.

Local-Users-and-Groups
... Thinkpads_User
0
 
ForinsightAuthor Commented:
thank you so much for your  snapshot. yes indeed i was on that spot. when you said that i need to add the user of the computer connecting to the computer with the share, you meant that i need to add the user by accessing the user from the 'Location" of the computer trying to connect, ie: *Locations, *computer2(one connecting), then find the user. then i can add it from the network location.

so what you mean is that i just have to duplicate the username of computer2. i'll do that now.
0
 
John HurstBusiness Consultant (Owner)Commented:
so what you mean is that i just have to duplicate the username of computer2

Yes, and also the password for username of computer2.

So you are adding username and password of computer2, not the "location" of computer2.

I share out my Windows 7 desktop that way so that my Windows 7 laptop can readily access it (and only my laptop).

...... Thinkpads_User
0
 
ForinsightAuthor Commented:
i added the computer user and password. the same result. nothing
added it even to the administrators. no difference
added it to the shared folder's access permissions. no difference. all the while both computers were restarted before trying to test the share.
0
 
John HurstBusiness Consultant (Owner)Commented:
So with the way it is set up now, from one of the other other computers, and assuming all computers are all WORKGROUP, type:

NET USE Z: \\name_of_shared_windows_7_computer\C$ and authenticate and
NET USE Z: \\name_of_shared_windows_7_computer\foldername and authenticate,

what answers do you get?

.... Thinkpads_User
0
 
ForinsightAuthor Commented:
prompted for username and password.
'system error 5 has occurred. access denied.' did verify password. it's correct.
0
 
John HurstBusiness Consultant (Owner)Commented:
I see system error 53 a lot when access is out of the question. System error 5 is a bit different.

Work through this attached Microsoft Article on System Error 5 and see if any symptoms or causes match your situation.

http://support.microsoft.com/kb/555644

Here is another article with some possible resolutions.

http://answers.microsoft.com/en-us/windows/forum/windows_7-windows_install/system-error-5-has-occurred-access-is-denied/77a124e3-7aea-4dab-a9cc-805c363aa9b9

.... Thinkpads_User
0
 
John HurstBusiness Consultant (Owner)Commented:
@Forinsight - Thank you. I was very pleased to help you with this.
... Thinkpads_User
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

  • 8
  • 5
Tackle projects and never again get stuck behind a technical roadblock.
Join Now