Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

RPC over http connection exchange 2010 and outlook2010

Posted on 2012-12-21
9
Medium Priority
?
727 Views
Last Modified: 2012-12-23
In outlook 2010 I connected by puttings in the servername and username, went into connetions tab, checked the microsot exchange using http, and clicked the button, exchange proxy settings, there I put the following settings:
https://mail3.mydomain.com
check connect using ssl only, checked only connect to proxy....
msstd:mail3.mydomain.com
checked on slow.......
under proxy auth....
NTLM
and thats it I was connected to my exchange 2010.................why did't it asked me for the username and password?
am I missing some setting on my exchange2010? anyone could connect to my exchnage like this? or I have misconfigured a step?
Help plz
0
Comment
Question by:amanzoor
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
9 Comments
 
LVL 6

Assisted Solution

by:traoher
traoher earned 200 total points
ID: 38714821
Were you on a domain computer with domain credential?

If you were using Internet Explorer along a domain account and has forward authentication enable (inside the browser setting), it is passing the domain credential across in the background so you don't see the prompt.
0
 
LVL 7

Accepted Solution

by:
Scobber earned 1600 total points
ID: 38715466
Try using BASIC authentication on the Proxy settings page. This will be safe because your using SSL in your example

Use DOMAIN\USERNAME or username@domain.local for your username and your regular domain password.
Make sure you change the DOMAIN to what it actually is for your infrastructure

Don't worry about the other security setting in the options before proxy, it can stay on NTLM


HTH Scobber
0
 
LVL 4

Author Comment

by:amanzoor
ID: 38715683
Hi there,
May be this would help me to identify problem:  My OWA is fine and clients work fine. via http://mail3.mydomain.com.

''the action cannot be completed.  The connection to Microsoft Exchange is unavailable.  Outlook must be online or connected to complete this action.''
This error pops up everytime I try to connect to my Exchagne 2010 RPC over https with outlook 2010

I am using external address https://mail3.mydomain.com
internal address of server exchage2010: https://exchange2010.mydomain.com
also: https://autodiscover.mydomain.com

All top three addresses are inclusive in my SSL certificate:


Outlook 2010: settings:
under connections tab:
connection settings: https://mail3.mydomain.com   (my external OWA address)
connect using SSL only checked
Only connect to proxy servers that have this principal name...........
msstd://exchange2010.fernhillschool.com  (my internal exchange server name, note that my ssl certificate has this name)
On slow networks, connect using http..............checked
NTLM auth under Proxy auth settings is selected



On my Exchange 2010:
Under EMC:
server config, CAS:

Under Client Access, right click over server name: outlook anywhere External host name: exchange2010.mydomain.com and NTLM auth is selected

Under outlook web app
Internal URL https://mail3.mydomain.com/owa
External URL https://mail3.mydomain.com/owa
under authentication tab, USE forms based auth, UPN selected

Under ecp:
internal URL: https://mail3.mydomain.com/ecp
External: https://mail3.mydomain.com/ecp
authentication=forms based authentication

Exchange active sync:
internal url: https://exchange2010.mydomain.com/Microsoft-Server-ActiveSync
External url: https://mail3.mydomain.com/Microsoft-Server-ActiveSync
authentication tab: Basic auth checked, ignore client cert

OAB:
inteternal URL: http://exchange2010.mydomain.com/OAB  <<<......note that this is http
External URL: https://mail3.mydomain.com/OAB


Under POP3 and IMAP4:
POP3: under authentication, x509 cert: mail3.mydomain.com
IMAP4: under authentication, x509 cert: mail3.mydomain.com


I need help plz
0
Veeam Task Manager for Hyper-V

Task Manager for Hyper-V provides critical information that allows you to monitor Hyper-V performance by displaying real-time views of CPU and memory at the individual VM-level, so you can quickly identify which VMs are using host resources.

 
LVL 7

Expert Comment

by:Scobber
ID: 38716083
as I said previously in my comment

your exchange server is set for BASIC authentication

Exchange active sync:
internal url: https://exchange2010.mydomain.com/Microsoft-Server-ActiveSync
External url: https://mail3.mydomain.com/Microsoft-Server-ActiveSync
authentication tab: Basic auth checked, ignore client cert

so:-
in your HTTP Proxy settings, change NTLM authentication to BASIC.

then login using your correct username notation and password.
0
 
LVL 4

Author Comment

by:amanzoor
ID: 38716439
Hi scobber,
I have confirmed that I checked the Basic auth in outlook 2010, when I click check names it keeps on poping up username and pass window, I click ok ok, then sometimes the error becomes the same as my last post.
A new error in outlook 2010, 'the name cannot be resolved the connection to mic exchange is unavailable.  Outlook must be online or connected to ..............................
Help plz
0
 
LVL 4

Author Comment

by:amanzoor
ID: 38716457
Is it normal.  On my exchage 2010 under iis when I click to browse the default website *80(http) it gives 403.4 forbidden the page you are trying to access is secured with ssl....
where as browse 443 is fine
0
 
LVL 15

Assisted Solution

by:Rajkumar-MCITP
Rajkumar-MCITP earned 200 total points
ID: 38716849
Yes. that is normal... OWA published by default with the ssl cert and normal access using http will show the warning to use https..
0
 
LVL 4

Author Comment

by:amanzoor
ID: 38717674
OK finally I got connected:
In outlook 2010
Under the server: it should be the name of the local server
username: only username
Under connection via http:
https://mail3.mydomain.com
msstd://mail3.mydomain.com
select both options of http
Basic auth
0
 
LVL 4

Author Closing Comment

by:amanzoor
ID: 38717675
Thank all I really appreciate your time.
0

Featured Post

Hire Technology Freelancers with Gigs

Work with freelancers specializing in everything from database administration to programming, who have proven themselves as experts in their field. Hire the best, collaborate easily, pay securely, and get projects done right.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

One-stop solution for Exchange Administrators to address all MS Exchange Server issues, which is known by the name of Stellar Exchange Toolkit.
Want to know how to use Exchange Server Eseutil command? Go through this article as it gives you the know-how.
The basic steps you have just learned will be implemented in this video. The basic steps are shown to configure an Exchange DAG in a live working Exchange Server Environment and manage the same (Exchange Server 2010 Software is used in a Windows Ser…
This video demonstrates how to sync Microsoft Exchange Public Folders with smartphones using CodeTwo Exchange Sync and Exchange ActiveSync. To learn more about CodeTwo Exchange Sync and download the free trial, go to: http://www.codetwo.com/excha…
Suggested Courses

618 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question