Solved

point ip to folder on server

Posted on 2012-12-21
6
322 Views
Last Modified: 2012-12-28
I have just setup a static IP (external) to point to my local pc using wamp.

On my web host, Ive also created an 'A' record of client.mydomain.com to point to the static ip.

problem is when I access client.mydomain.com, it goes to the root of my wamp server (showing all projects.)

how to I make it point to the client. I assume its a specific entry in http.conf.

Any help would be appreciated.
0
Comment
Question by:TBerripub
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
6 Comments
 
LVL 17

Expert Comment

by:Kent Dyer
ID: 38715106
Here are a number of methods including http.conf..

http://www.yolinux.com/TUTORIALS/ApacheRedirect.html

HTH,

Kent
0
 
LVL 7

Expert Comment

by:Milind Koyande
ID: 38715471
Hello,

You need to add a VirtualHost entry in Httpd.conf file.

Please refer: http://www.thegeekstuff.com/2011/07/apache-virtual-host/ which show how you can configure virtual host with example.
0
 
LVL 53

Expert Comment

by:COBOLdinosaur
ID: 38715639
It is pretty much the same as your other Q:

in your httpd.conf file find DocumentRoot "C:/wamp/www"

and change it to DocumentRoot "f:/wamp/www/xxxx"

Cd&
0
Windows Server 2016: All you need to know

Learn about Hyper-V features that increase functionality and usability of Microsoft Windows Server 2016. Also, throughout this eBook, you’ll find some basic PowerShell examples that will help you leverage the scripts in your environments!

 

Author Comment

by:TBerripub
ID: 38716060
Thanks guys for all of your comments, but still not working.

So here is what ive done so far.

1. I have added an A record to client.mydomain.com which uses my ip address as provided my service provider. this is static.

2. I have added port forwarding for http to port 80.
http://awesomescreenshot.com/099qop77d

3. I have installed wamp (running windows).

Expectations.

1. When I type in client.mydomain.com (externally : e.g if im in another country) I want it to load the website on my pc, which is currently located in c:/wamp/www/client

Issues

1. when I type in my ip directly, I get the error
"Forbidden You don't have permission to access / on this server."

2. when I do a port forwarding tester (http://www.yougetsignal.com/tools/open-ports/), it says port 80, along with every other port is blocked.

I have disabled my firewalls.

So a bit stuck here.
0
 
LVL 16

Accepted Solution

by:
grahamnonweiler earned 500 total points
ID: 38716840
1) Not able to access port 80 "externally"
Assuming you are trying to access your server from an external source (outside of your home/office)  and you have a consumer/broadband Internet connection it is quite possible that your ISP is in fact blocking port 80 (along with a number of other ports). Although you said you assigned a "static IP" you did not state if that was "inside" or "outside", where "outside" means a Public IP Address.

If your "static IP" is a Public  IP address (assigned by your ISP) then ask them to open port 80 at their firewall.

If you "static IP" is an internal IP address, and you are using a dynamic external IP address, and your ISP is blocking port 80, then you will need to use a different port from outside to access your internal server, and using port forwarding translation to forward the external port to internal port 80.

2) Once you have established external access to your server, then you will have to setup a "virtual host" entry in your Apache conf file for "client.mydomain.com" which is pointing at the directory (folder) you have placed on your server for that client.
0
 

Author Comment

by:TBerripub
ID: 38728218
ISP was blocking port,
0

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Does your audience prefer people in photos or no people? How can you best highlight what you’re selling? What are your competitors doing, and what can you do that is different and unique from them?  Continue reading to learn how to make your images …
Although a lot of people devote their energy toward marketing for specific industries, there are some basic principles that can be applied to any sector imaginable. We’ll look at four steps to take and examine how those steps were put into action fo…
Explain concepts important to validation of email addresses with regular expressions. Applies to most languages/tools that uses regular expressions. Consider email address RFCs: Look at HTML5 form input element (with type=email) regex pattern: T…
This tutorial walks through the best practices in adding a local business to Google Maps including how to properly search for duplicates, marker placement, and inputing business details. Login to your Google Account, then search for "Google Mapmaker…

732 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question