Avatar of Arnold Layne
Arnold Layne
Flag for United States of America asked on

Alerts problem

I am sending alerts to external email addresses. The alert creation email gets sent successfully, and I have the alert set to "anything changes" but the alert never gets sent after any changes. Alerts are enabled in Central Admin and obviously Sharepoint has no problem talking to the SMTP server. Manually ran the immediate alerts job timer service. Still no luck. No Exchange installed because all mail will be outgoing via the SMTP service Any ideas? Thanks
Microsoft SharePoint

Avatar of undefined
Last Comment
Arnold Layne

8/22/2022 - Mon
Tony Giangreco

Check for SMTP authentication. It might be required and possibly change a port for it.
Arnold Layne

ASKER
Sorry, I'm confused. How could the alert creation notification emails work if SMTP auth isn't correct? It's just the actual alerts that don't get sent, so I don't understand how this relates to SMTP auth.. Thanks
Justin Smith

Disregard TG's comment, it's irrelevant.  The initial email is sent correctly, so SMTP is fine.

I'll assume you set the alerts to send immediately, and not a summary email at the end?  Do all users have at least read access to the list and site in question?
I started with Experts Exchange in 2004 and it's been a mainstay of my professional computing life since. It helped me launch a career as a programmer / Oracle data analyst
William Peck
Arnold Layne

ASKER
Yes, I set the alert for immediate sending, and it was the administrator (me) that set the alert and I received the confirmation email for creating the alert but after that, I receive no actual alerts when changes are made to the list. So there seems to be something different about the initial confirmation email and the actual alert emails. I know regular alerts are sent out by the immediate alerts job within the SPTimer, but maybe initial alert creation confirmation does not, so that gets sent out, but if the SPTimer has a problem, immediate alerts won't go out. That's all i can think of, because I've done all of the simple, straightforward things that everybody has mntioned and I am very familiar with the smpt properties tabs..
Justin Smith

The confirmation emails go out via the web application (app pool acct), the immediate and summary alert emails go out via the Timer service account.

Alerts have had several fixes since RTM (I'm assuming you are on 2010 as you've never specified your version).  Have you deployed SP1 + any of the post SP1 cumulative updates?

Do you only have one domain in your environment?  Does the list/library you are testing on have any managed metadata columns?
Arnold Layne

ASKER
Installed SP1 for Sharepoint Foundation 2010 and cumulative refresh june 2011. Ran config wizard again as their instructions said to have sharepoint implement the changes.

One Domain Environment where SP, SMTP and SQL are all on the DC. It's a simple dev setup strictly for learning and experimenting.

The list has no managed metadata columns, strictly an out of the box task list

I watch my smtp queue folder and a message shows up for the notification, but when I change something in the task list it generates no mail in the queue or pickup folders. For demo purposes, I am using the default windows administrator account for everything. The account has a external gmail address for its email field in AD because I don't want to bother with Exchange or receiving email to the domain, the drop box is fine.

In central admin, immediate alert shows as successful, but it and all timer jobs show a duration of 0:00:00. Is that normal? Ran the immediate alerts job manually. Made no difference.
⚡ FREE TRIAL OFFER
Try out a week of full access for free.
Find out why thousands trust the EE community with their toughest problems.
Justin Smith

You are testing on a task list?

Can you create a custom list, and do the same testing?
Arnold Layne

ASKER
Created a blank custom list with only the title column. Created an alert for anything changes and send immediately. Ran the immediate alert job manually in central admin. Immediate alert job and all jobs show as successful in central admin but with a 0:00:00 duration. Now, I'm not even getting the notification email in the smtp queue folder or pickup. Added an item to the list and the alert emailt did not go to the smtp folders either. Also, i get "Accounts used by application pools or service identities are in the local machine Administrators group. " warning in the health monitor. Don't think that's the problem.
Arnold Layne

ASKER
The smtp service was stopped for some reason. Ran the immediate alerts job manually again and now it showed as a 1 sec duration rather than 0 and the alert shows up in the queue. Was it because I had a blank custom list? The task list was an out of the box list.
This is the best money I have ever spent. I cannot not tell you how many times these folks have saved my bacon. I learn so much from the contributors.
rwheeler23
Arnold Layne

ASKER
Correction. smtp service was stopped, started it and saw the notifications in the queue folder, so the custom list is working. However when I add a new item to the task list, it still does not work. The task list is an out of the box list with no additions or customizations on my part
Arnold Layne

ASKER
I've requested that this question be deleted for the following reason:

Never received any final answer and more more answers were given
ASKER CERTIFIED SOLUTION
Justin Smith

THIS SOLUTION ONLY AVAILABLE TO MEMBERS.
View this solution by signing up for a free trial.
Members can start a 7-Day free trial and enjoy unlimited access to the platform.
See Pricing Options
Start Free Trial
GET A PERSONALIZED SOLUTION
Ask your own question & get feedback from real experts
Find out why thousands trust the EE community with their toughest problems.
Arnold Layne

ASKER
That works, sometimes. I gave it a B because I really don't know why this happens and if it won't happen again, but it does work. Thanks much.
⚡ FREE TRIAL OFFER
Try out a week of full access for free.
Find out why thousands trust the EE community with their toughest problems.