Slow browsing after advanced network configutation

All of the computers on my network have slow browsing for the last few days. When I plug directly into the modems, skipping the router, browsing is no problem And it definitely not the PC's. Because they all have the same (slow browsing). Downloading and uploading work great, and you don't notice problems with all the traffic other than browsing. Interefering is a significant amount of P2P traffic at certain times, but the problem persists even when there is none.

What I have tried:
Setting the TCP timeout to 3600, 1500, 120, 90
Setting the maximum ports to 16384
Setting the static DNS's
Not Setting the static DNS's
Giving high QoS priority to http
Gving low priority to traffic on ports 1023-65535 (tryiing to get P2P)


Setup:
WAN: Dual DSL lines, load balanced
ROUTER: Cisco E4200 DD-WRT v24-sp2 big
Release: 03/19/12 (SVN revision: 18777)
LVL 1
Jeff swicegoodTechnicianAsked:
Who is Participating?
 
JohnConnect With a Mentor Business Consultant (Owner)Commented:
Two things:

1. Go to speeedtest.net. What speed direct through modem? What speed through router?

2. Do a hard reset of your router back to factory specs and check. Then if you wish to to change things, change one thing at a time and check browsing. I have PnP turned off on my router but that is about all.

... Thinkpads_User
0
 
Jeff swicegoodTechnicianAuthor Commented:
1. The speed is the about the same through the router and through the modem 3.9M down and .49M up.

2. Good idea. that will take some time. Unfortunately, I need a highly configured router state.

Jeff
0
 
JohnBusiness Consultant (Owner)Commented:
Thanks. Any decent router should handle 4Mbits/sec down. My own will do 8Mbits, but the ISP has recently upgraded to 25Mbits, so I have to replace the router (on order).

Let us know about the reset. I know it takes time (same issue for me), but with changing ports, DNS and QoS, it is hard to say from here which one is causing the issue.

.... Thinkpads_User
0
Improve Your Query Performance Tuning

In this FREE six-day email course, you'll learn from Janis Griffin, Database Performance Evangelist. She'll teach 12 steps that you can use to optimize your queries as much as possible and see measurable results in your work. Get started today!

 
Sandeep GuptaConsultantCommented:
first internet work on Best Effort not on QoS. since you have already checked the connectivity
directly via modem then surely there is some router config. issue.

What I wud recommend, keep you router config simple...remove all LAN/WAN ACL or any.and then check the speed...if possible please share you router's configs.
0
 
SachinNamdeoSableCommented:
Please check MTU setting configured in Router. OR try with another alternativv Router for Testing to check if Router Hardware is faulty.
Only having issue with Internet or sharing files also.
0
 
iconnectuCommented:
Slow Browsing but fast up and downloads have often to do with wrong DNS Settings. Set your Networkcard to static and enter one of googles public DNS Servers 8.8.8.8, 8.8.4.4. Now check some Websites again. If it is fast, check the DNS Settings on your DHCP / DNS Server and change it there.
0
 
Jeff swicegoodTechnicianAuthor Commented:
@iconnectu I tried the google DNS. It made no difference.

@Thinkpads I am doing the reset now.

@Sachin the MTU is 1500. I'll report more configs after I try the reset and re-config.
0
 
iconnectuCommented:
An MTU from 1500 is only by cable modem or ethernet connections. if your provider sent you an ADSL, VDSL or other DSL modem, it will be less than that. Check with your provider to get the right MTU. In Switzerland, the Standard MTU for DSL is 1492, Business DSL 1460.
0
 
Jeff swicegoodTechnicianAuthor Commented:
After a factory reset browsing on my laptop was super fast. I was able to add back most of my settings (the important ones) without affecting the browsing. I added back my second DHCP server, but couldn't get it working anyway, that's a separate issue. That's why I say I added back most of my settings. Some other PC's browse well, too. However, on my desktop PC browsing is slow. I guess that PC is to blame there.
0
 
gheistCommented:
E4200 has no DSL port - so what is up the wire?

dd-wrt has mss clamping option that may work if your provider changed something upstream.
0
 
JohnBusiness Consultant (Owner)Commented:
@Jagadguru - Since a hard router reset (as suggested) brought back your browing speed, it is probably appropriate now to close the question.  Thanks ..... Thinkpads_User
0
 
Jeff swicegoodTechnicianAuthor Commented:
Yes, You are right, Thinkpads_user. I was distracted by Christmas, and the fact that my system hard drive died,  but your initial solution did work. Now everything is fast. Thank you.
0
 
JohnBusiness Consultant (Owner)Commented:
Thank you, and I was happy to help you with this. No problem with the distraction and I offer you my best wishes for the holiday season and the coming New Year.
.... Thinkpads_User
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.