Solved

Slow browsing after advanced network configutation

Posted on 2012-12-22
13
402 Views
Last Modified: 2012-12-27
All of the computers on my network have slow browsing for the last few days. When I plug directly into the modems, skipping the router, browsing is no problem And it definitely not the PC's. Because they all have the same (slow browsing). Downloading and uploading work great, and you don't notice problems with all the traffic other than browsing. Interefering is a significant amount of P2P traffic at certain times, but the problem persists even when there is none.

What I have tried:
Setting the TCP timeout to 3600, 1500, 120, 90
Setting the maximum ports to 16384
Setting the static DNS's
Not Setting the static DNS's
Giving high QoS priority to http
Gving low priority to traffic on ports 1023-65535 (tryiing to get P2P)


Setup:
WAN: Dual DSL lines, load balanced
ROUTER: Cisco E4200 DD-WRT v24-sp2 big
Release: 03/19/12 (SVN revision: 18777)
0
Comment
Question by:Jeff swicegood
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 4
  • 2
  • +3
13 Comments
 
LVL 95

Accepted Solution

by:
John Hurst earned 500 total points
ID: 38715682
Two things:

1. Go to speeedtest.net. What speed direct through modem? What speed through router?

2. Do a hard reset of your router back to factory specs and check. Then if you wish to to change things, change one thing at a time and check browsing. I have PnP turned off on my router but that is about all.

... Thinkpads_User
0
 
LVL 1

Author Comment

by:Jeff swicegood
ID: 38715700
1. The speed is the about the same through the router and through the modem 3.9M down and .49M up.

2. Good idea. that will take some time. Unfortunately, I need a highly configured router state.

Jeff
0
 
LVL 95

Expert Comment

by:John Hurst
ID: 38715710
Thanks. Any decent router should handle 4Mbits/sec down. My own will do 8Mbits, but the ISP has recently upgraded to 25Mbits, so I have to replace the router (on order).

Let us know about the reset. I know it takes time (same issue for me), but with changing ports, DNS and QoS, it is hard to say from here which one is causing the issue.

.... Thinkpads_User
0
Visualize your virtual and backup environments

Create well-organized and polished visualizations of your virtual and backup environments when planning VMware vSphere, Microsoft Hyper-V or Veeam deployments. It helps you to gain better visibility and valuable business insights.

 
LVL 9

Expert Comment

by:Sandeep Gupta
ID: 38715778
first internet work on Best Effort not on QoS. since you have already checked the connectivity
directly via modem then surely there is some router config. issue.

What I wud recommend, keep you router config simple...remove all LAN/WAN ACL or any.and then check the speed...if possible please share you router's configs.
0
 
LVL 2

Expert Comment

by:SachinNamdeoSable
ID: 38716018
Please check MTU setting configured in Router. OR try with another alternativv Router for Testing to check if Router Hardware is faulty.
Only having issue with Internet or sharing files also.
0
 
LVL 4

Expert Comment

by:iconnectu
ID: 38716720
Slow Browsing but fast up and downloads have often to do with wrong DNS Settings. Set your Networkcard to static and enter one of googles public DNS Servers 8.8.8.8, 8.8.4.4. Now check some Websites again. If it is fast, check the DNS Settings on your DHCP / DNS Server and change it there.
0
 
LVL 1

Author Comment

by:Jeff swicegood
ID: 38717694
@iconnectu I tried the google DNS. It made no difference.

@Thinkpads I am doing the reset now.

@Sachin the MTU is 1500. I'll report more configs after I try the reset and re-config.
0
 
LVL 4

Expert Comment

by:iconnectu
ID: 38717954
An MTU from 1500 is only by cable modem or ethernet connections. if your provider sent you an ADSL, VDSL or other DSL modem, it will be less than that. Check with your provider to get the right MTU. In Switzerland, the Standard MTU for DSL is 1492, Business DSL 1460.
0
 
LVL 1

Author Comment

by:Jeff swicegood
ID: 38718619
After a factory reset browsing on my laptop was super fast. I was able to add back most of my settings (the important ones) without affecting the browsing. I added back my second DHCP server, but couldn't get it working anyway, that's a separate issue. That's why I say I added back most of my settings. Some other PC's browse well, too. However, on my desktop PC browsing is slow. I guess that PC is to blame there.
0
 
LVL 62

Expert Comment

by:gheist
ID: 38720344
E4200 has no DSL port - so what is up the wire?

dd-wrt has mss clamping option that may work if your provider changed something upstream.
0
 
LVL 95

Expert Comment

by:John Hurst
ID: 38720549
@Jagadguru - Since a hard router reset (as suggested) brought back your browing speed, it is probably appropriate now to close the question.  Thanks ..... Thinkpads_User
0
 
LVL 1

Author Closing Comment

by:Jeff swicegood
ID: 38724881
Yes, You are right, Thinkpads_user. I was distracted by Christmas, and the fact that my system hard drive died,  but your initial solution did work. Now everything is fast. Thank you.
0
 
LVL 95

Expert Comment

by:John Hurst
ID: 38724898
Thank you, and I was happy to help you with this. No problem with the distraction and I offer you my best wishes for the holiday season and the coming New Year.
.... Thinkpads_User
0

Featured Post

Secure Your WordPress Site: 5 Essential Approaches

WordPress is the web's most popular CMS, but its dominance also makes it a target for attackers. Our eBook will show you how to:

Prevent costly exploits of core and plugin vulnerabilities
Repel automated attacks
Lock down your dashboard, secure your code, and protect your users

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Join Greg Farro and Ethan Banks from Packet Pushers (http://packetpushers.net/podcast/podcasts/pq-show-93-smart-network-monitoring-paessler-sponsored/) and Greg Ross from Paessler (https://www.paessler.com/prtg) for a discussion about smart network …
Most of the applications these days are on Cloud. Cloud is ubiquitous with many service providers in the market. Since it has many benefits such as cost reduction, software updates, remote access, disaster recovery and much more.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Here's a very brief overview of the methods PRTG Network Monitor (https://www.paessler.com/prtg) offers for monitoring bandwidth, to help you decide which methods you´d like to investigate in more detail.  The methods are covered in more detail in o…

738 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question