Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

I can Ping but cant browse

Posted on 2012-12-22
14
Medium Priority
?
1,126 Views
Last Modified: 2013-01-01
Hi,

Strange problem with SBS 2011... I can ping the server and connect via RDC, but the server cant access the internet. if i ping google.com it resolves, and pinging external addresses works fine too so it looks like DNS is resolving correctly.

Any Ideas?

Thanks,

Josh
0
Comment
Question by:joshhough
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 3
  • 2
  • +3
14 Comments
 
LVL 17

Expert Comment

by:bigeven2002
ID: 38716143
Hello,

Just some clarification, are you saying you can ping google.com from SBS2011?  

Do you have a firewall on the network or running on SBS?  It may be blocking port 80 which is web traffic.  Try turning off the firewall on SBS first and see if you can surf.

Also, assuming you are using Internet Explorer to browse, if you don't use a proxy, make sure that the proxy server is not specified in Internet Options.  That option is under Internet Options > Connections > LAN Settings.  Also make sure that Automatically detect settings is unchecked.

You might also have Internet Explorer Enhanced Security activated so you might also try turning that off and try to browse.

Lastly, there is another setting in Internet Options for Protected Mode under the Security tab.  If that is on, try turning it off.
0
 
LVL 6

Expert Comment

by:Leon Teale
ID: 38716169
are you able to test alternate browsers? can you browse to a website running on something else other than port 80.

e.g.

technoid.co.uk:8880

can you get to that address thats mine
0
 
LVL 1

Author Comment

by:joshhough
ID: 38716177
Hi,

Yep, ping google.com resolves from CMD on my SBS2011 box.

I'm using firefox and IE doesn't work either. The firewall on the router is just 'standard' there have never been any modifications to it other than allowing ports through for the VOIP system.

Google either through HTTPS or HTTP doesn't work so it's at least 443 and 80 that are shut. However, i can access the server remotely through HTTP so port 80 is at least redirecting on the router.

Thanks,

Josh
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
LVL 6

Expert Comment

by:Leon Teale
ID: 38716182
can you telnet to a webserver on port 80?
0
 
LVL 15

Expert Comment

by:Perarduaadastra
ID: 38716185
By default, Internet Explorer on Windows servers is locked down very tight, and is a real pain to use because of it.

Try installing Firefox and see if that works OK. If it does, you know that the problem is with IE.
0
 
LVL 17

Expert Comment

by:bigeven2002
ID: 38716186
Ok on your workstation, is your primary DNS pointing to the SBS server or the router?  Is your secondary DNS pointing to either?  Can your workstation surf just fine?

Also, do you use DNS forwarding on the SBS server?
0
 
LVL 6

Expert Comment

by:Leon Teale
ID: 38716187
if his dns was a problem he wouldnt be able to resolve dns hostnames.

please test a telnet connection on port 80 it will then rule out some possibilities
0
 
LVL 71

Expert Comment

by:Qlemo
ID: 38716206
The incoming services are not related to the outgoing ones. Even the port forwarding should not be relevant. But somehow I've got the feeling it is. Can you switch off the port forwarding temporarily?
0
 
LVL 3

Expert Comment

by:SolracM
ID: 38716367
If I may ask,, does your SMS have 1 or 2 NIC cards? can you verify the correct interface is routed correctly by doing a ROUTE PRINT from the command prompt? also when you do a TRACERT where does it end before your browser returns page not found?
0
 
LVL 15

Expert Comment

by:Perarduaadastra
ID: 38716726
If your SBS 2011 server has two NIC cards, then disable one of them. The dual-NIC configuration was dropped in SBS 2008 onwards, and you will have no end of problems if you attempt to use two NICs because SBS doesn't work that way any more.
0
 
LVL 1

Author Comment

by:joshhough
ID: 38717470
There is a second NIC but it is disabled.
0
 
LVL 3

Expert Comment

by:SolracM
ID: 38717480
By any chance did you take a look at the ROUTE PRINT and verify the respective NIC CARD has the correct GATEWAY IP ADRRESS?
this can also be verifed in the TRACERT command
try a  TRACERT to a well known outside IP ADDRESS see the packets destined for the GATEWAY is actualy routed to the GATEWAY or if there is a VIRTUAL ETHERNET ADPATER in the picture somewhere. you may need to reset your winsock (netsh int ip reset) from the command prompt.
0
 
LVL 1

Accepted Solution

by:
joshhough earned 0 total points
ID: 38726413
Turns out the issue was with BT having issues on a particular exchange with port 80 traffic... eh?! Oh well, it works now. Actually it isn't the first time i've had problems with them doing silly things like that.
0
 
LVL 1

Author Closing Comment

by:joshhough
ID: 38734284
Turns out the issue was with BT having issues on a particular exchange with port 80 traffic... eh?! Oh well, it works now. Actually it isn't the first time i've had problems with them doing silly things like that.
0

Featured Post

[Webinar] Lessons on Recovering from Petya

Skyport is working hard to help customers recover from recent attacks, like the Petya worm. This work has brought to light some important lessons. New malware attacks like this can take down your entire environment. Learn from others mistakes on how to prevent Petya like worms.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

#Citrix #Internet Explorer #Enterprise Mode #IE 11 #IE 8
Use of TCL script on Cisco devices:  - create file and merge it with running configuration to apply configuration changes
Shows how to create a shortcut to site-search Experts Exchange using Google in the Chrome browser. This eliminates the need to type out site:experts-exchange.com whenever you want to search the site. Launch the Search Engine Menu: In chrome, via you…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

604 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question