Avatar of Amanda Watson
Amanda Watson
Flag for Australia asked on

Hover state looks odd in IE9 and IE10?

Hi there,
I am having a terrible time getting a site to be compatible for a client using IE9.
I cannot test it as I am only using windows 7.
Can someone help me to iron out an issue.
On this site here http://cisrd.com/  if you go to hover over the "about our conference" you will see the hover menu looks odd - see screenshot...

I cannot seem to get the code right to make this work for them.  It looks good in my browsers, just not theirs?
Thanks
aaaimage003.jpg
WordPressHTMLCSS

Avatar of undefined
Last Comment
Amanda Watson

8/22/2022 - Mon
bigeven2002

Hello,

I did not see the problem either.  There is a line in the header
<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1" />

Open in new window

Can you try removing or commenting out this line and then have them refresh to see if there is any difference?
wadehults

I would look at how your cells inherit their width. It appears as if the IE9 is using a default size for your cell at one level or another. It may help if you explicitly control the size of the child cell instead of allowing the browser to make default style decisions.

On a separate note, how does IE9 have anything to do with Windows 7? IE9 can be installed on anything Windows Vista or newer.
Amanda Watson

ASKER
Hi there,
Thanks for the reply.
Sorry it was IE10 that is causing the issue - IE9 is ok.
Also in my wordpress theme I can't seem to find the line you mentioned...it isn't in the header file
?
If the cells are inheriting their width, where can I change this and in which tag in the CSS to stop this from inheritng a default size...?
Thanks for helping me with this
All of life is about relationships, and EE has made a viirtual community a real community. It lifts everyone's boat
William Peck
ASKER CERTIFIED SOLUTION
wadehults

THIS SOLUTION ONLY AVAILABLE TO MEMBERS.
View this solution by signing up for a free trial.
Members can start a 7-Day free trial and enjoy unlimited access to the platform.
See Pricing Options
Start Free Trial
GET A PERSONALIZED SOLUTION
Ask your own question & get feedback from real experts
Find out why thousands trust the EE community with their toughest problems.
bigeven2002

Yes it should be in either one of the header php files or index php file.  If you are using a web developer program like dreamweaver then it should be able to search the relevant files' content for that particular line of code.  It will probably be in the folder of the name of the template you are using.

Seeing that it is IE10 specifically now, that line I think could be changed to
<meta http-equiv="X-UA-Compatible" content="IE=9,chrome=1" />

Open in new window

After changing that, have the client do a refresh to see if any change.

Is the client using a beta version of IE10?  Are they running Windows 7 or 8?  I loaded the site just fine on a Windows 8 machine and it runs IE 10.  I viewed it in both the legacy and metro versions.
Amanda Watson

ASKER
Great finding the culprit for the strange hover state...can you please have a look and see if you can see it ok now?  Anyone?  I used width: 100%
wadehults

It looks fine using the Windows 8/IE 10 emulator on BrowserStack.com
⚡ FREE TRIAL OFFER
Try out a week of full access for free.
Find out why thousands trust the EE community with their toughest problems.
Alicia St Rose

As wadehults has hinted at please check out BrowserStack.com. You can test your site on any OS, browser, device. It's been a lifesaver for me! Worth the monthly fee.
Matthew Kelly

The issue appears in IE9 when running compatibility mode (see attached screenshot). It doesn't appear in IE9 running normally. If you are running IE9 on your Win7 machine you should be able to see the problem by clicking the compatibility mode button.

This can be fixed by adding "width:auto;" to all of the sub-menu "a" tags.

<a style="width: auto;" href="http://cisrd.com/about/conference-aims-themes/">

Open in new window


You may be able to fix it via changing "width: 100%" to "width: auto" on the "ul.nav ul li a" element in layout.css: http://cisrd.com/wp-content/themes/athena/css/layout.css?ver=3.4.2
ul.nav ul li a {
    -moz-box-sizing: border-box;
    display: inline-block;
    width: auto;
}

Open in new window


Either way, you should be able to test each of those on your Win 7 machine using compatibility mode to see it.

As a tip, I used IE developer tools (hit F12 with the website open in IE) to debug the css.
ie9-compatibility-mode.jpg
Amanda Watson

ASKER
Ok on line 59 in layout.css I changed the width from 100% to auto.

Thanks for all the information regarding testing this on non Win 8 machines.
I started with Experts Exchange in 2004 and it's been a mainstay of my professional computing life since. It helped me launch a career as a programmer / Oracle data analyst
William Peck
Amanda Watson

ASKER
Can everyone report now how they see it with this change?
Amanda Watson

ASKER
Thank you