• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 816
  • Last Modified:

Can't Get a Working Internet Connection on My Windows 7 Laptop

I have a Dell Latitude E5400 laptop running Window 7 Ultimate w/ SP1(32-bit). I have a Netgear WGR614 v6 wireless router. I can see the SSID and the laptop connects to it but it's not getting a usable internet connection. When I go into Network setting and click on Repair, the Windows Network Diagnostics comes back with: "Problem found: The DNS server isn't responding." I tried plugging in with an Ethernet cable and get the same result.

I have an iPad and a MacBook that both connect to the Wifi w/o a problem, so issue must be on the laptop. And I also booted the laptop with a Knoppix Live Linux CD that was able to connect via Ethernet.

Also, I have used this Dell laptop at another location connecting via Wifi to a Airport Extreme and that works fine.
0
anuneznyc
Asked:
anuneznyc
2 Solutions
 
ded_chCommented:
The Problem could lie with the DHCP Settings of your router.
When you connect to the wireless network you receive your ip, your netmask, your gatway and your DNS records from the Router if your laptop has DHCP activated and no fixed ip configuration.

Most likely the router has an invalid DNS server setup in the DHCP Settings. Also possible is, that your Laptop was configure with a fixed DNS Server entry that is not working from your location.

Try going in to the Network settings and set your DNS Setting manually.
To do this go to Start, Control Panel, Network settings. Then click on Change adapter settings, then right click your connection and choose properties. From there go to the TCP/IP v4 settings. Click on Properties again. Select "use the following DNS Settings" and enter 8.8.8.8 (Google DNS Server) in first field.

Then hit ok until you're back in the network settings window.

Try if your internet connection is working.
You can also try to open a command prompt by hitting Start and typing CMD in the search field. Then hit enter. A little black window will open. Without changing mouse focus, type:

ping www.google.com

and hit enter. It will now either show you "www.google.com" could not be found, or answer with an ip address. If you get an ip address, then DNS is working.
Next try the command:

ping 8.8.8.8

and hit enter. You will either get a No response or Response recieved message a few times.
If you did get a "www.google.com" could not be found but get a response received in the second command, it defenitely is a DNS server setting issue.

In this case, login to your routers page and add a valid DNS entry to the DHCP Settings.
0
 
John HurstBusiness Consultant (Owner)Commented:
Try resetting TCP/IP using this Microsoft Support article.

http://support.microsoft.com/kb/299357

TCP/IP affects both wired and wireless connections.

Also look in your hosts file (C:\windows\system32\drivers\etc\hosts) to make sure all the entries in the hosts file are just comments.

.... Thinkpads_User
0
 
anuneznycAuthor Commented:
Thanks for the input, guys. I'm away from that computer for a couple of hours, so I won't be able to try your suggestions until later.

ded_ch, if the problem does lie with the DHCP Settings on the Netgear router, why isn't that causing a problem for the MacBook, which connected just fine.

Also, remember that the Dell laptop connected via Ethernet when booted from a Live Linux CD. So I'm guessing the issue is on the Windows network configuration side. Although I'm pretty sure both DNS & DHCP Windows settings on the laptop are set to Dynamic, not static.
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
AkinsdNetwork AdministratorCommented:
Problem is IPv6 is not configured properly on your DNS server.

Just disable IPv6 on your wireless card (on the Windows 7 client) to troubleshoot. If it works....you can then choose to fix your ipv6 or work without it
0
 
anuneznycAuthor Commented:
Resetting TCP/IP by entering "netsh int ip reset c:\resetlog.txt" at the command prompt did the trick. Thanks.
0
 
John HurstBusiness Consultant (Owner)Commented:
Thank you and I am glad you got it working .
.... Thinkpads_User
0

Featured Post

 The Evil-ution of Network Security Threats

What are the hacks that forever changed the security industry? To answer that question, we created an exciting new eBook that takes you on a trip through hacking history. It explores the top hacks from the 80s to 2010s, why they mattered, and how the security industry responded.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now