Solved

ZFS: Solaris on Microserver

Posted on 2012-12-23
48
964 Views
Last Modified: 2013-12-27
Hi,

I want to dual boot ESXi (usb stick)/Solaris. I changed the boot order so now it should boot from an SSD after install.
 I mapped the live iso Oracle via RAC, this way I don't need to plugin an usb key-which I do have succesfully made btw, but as last resort).

The screens just stays black with a white cursor. Not sure if it does do anything. Not a lot of ways to find out either. Any idea if it's normal in this setup (waiting for 15 minutes now).

rac
 

Notes:
-blinking speed of cursor varies, so maybe it does do something ...?
-drive is mapped from within vm which is close to the NAS (on which the iso is), so network speed should be ok (would it need to fully download the iso, didn't think it would)?

J.
0
Comment
Question by:janhoedt
  • 28
  • 18
48 Comments
 
LVL 117
ID: 38717603
why do you want to dual boot? ESXi & Solaris?

I would test if you can boot a normal OS ISO in this way. e.g. Windows OS Bootable CDROM, if you can, clearly Oracle Solaris is not bootable in this fashion.
0
 

Author Comment

by:janhoedt
ID: 38718059
Dual boot to have option to boot into esx and do testing with vm solaris.
I booted from USB with solaris now (made with tool you suggested), GRUB is showing and cursor blinks but not much happens for 10 minutes now ....
0
 
LVL 117
ID: 38718075
be careful, that you do not end up with ESX or Solaris over writing a non OS disk.
0
 

Author Comment

by:janhoedt
ID: 38718087
Doesn t matter, they are all empty.
0
 

Author Comment

by:janhoedt
ID: 38718095
More important: I cannot seem to install. Either on bare metal (cursor blinks) or vm (cannot map drives behind lsi).
0
 

Author Comment

by:janhoedt
ID: 38718527
Any further idea on this?
0
 
LVL 117
ID: 38718588
does not boot from cdrom?

does not boot from usb?

remove gskill ram?
0
 

Author Comment

by:janhoedt
ID: 38718624
There is no cdrom, that s why I use usb. Boots from usb but stays blinking on grub.
Remove ram? Why, nothing is wrong with ram itself.
0
 
LVL 117
ID: 38718671
we do not have any issues here installing from USB, but we are not using 16GB in our Solaris SANs only ESXi!
0
 
LVL 117
ID: 38718692
we have no issues booting from USB and installing.
0
 

Author Comment

by:janhoedt
ID: 38718697
And you created it with the tool you mentioned? Will try to do it again.
0
 
LVL 117
ID: 38718724
yes, the very same tool.
0
 

Author Comment

by:janhoedt
ID: 38718780
Will try again then. Or could it be because of rac I m using to install? Probably not.
0
 
LVL 117
ID: 38718785
its possibly, we do not have RAC.
0
 

Author Comment

by:janhoedt
ID: 38719292
Exactly the same with feeshly created usb. Directly connected to server (no rac): GRUB showing with blinking cursor. Nothing happens.

Please advise.
0
 
LVL 117
ID: 38719306
very odd, not in the office, so cannot get to the lab, to conduct tests.

its possible the Oracle Solaris build has changed, usb tool does not work anymore, or solaris build is not compatible with your hardware.
0
 

Author Comment

by:janhoedt
ID: 38719351
It would be a really big help if you could test on your lab! If it works for you, not for me we can find differencs which lead to root cause (just as octopus cable).
0
 

Author Comment

by:janhoedt
ID: 38721718
Note: not sure what they mean with "Download - From this site ( Please rename to "OsolLiveUSB003.zip" )"
http://devzone.sites.pid0.org/OpenSolaris/opensolaris-liveusb-creator
Works fine without any rename.
0
 
LVL 117
ID: 38721731
thats irrelevant, to the issue unless the usb image has now changed and is incompatible.
0
 

Author Comment

by:janhoedt
ID: 38721834
Strange thing is that usb key is always made within seconds ... and empty when checking within windows. Could be normal since format (ext4 or specific solaris format?) isn't recognized but still.
If anybody could give me input he/she can boot succesfully with usb stick cretated solaris 11 and the mentioned tool ....
0
 
LVL 117
ID: 38721933
that was the tool we used successfully, in the past. note the past, with usb image downloaded in the past, that tool has not been updated since 2009.

if its created in seconds its failed, it takes at least 10-15mins to prepare
0
 

Author Comment

by:janhoedt
ID: 38721987
But it said successfull at the end. Last time creating took ore time. Maybe I need another tool to make the usb then.
0
 

Author Comment

by:janhoedt
ID: 38721997
I could try rufus, http://rufus.akeo.ie/, but what filetype I should take, ntfs/fat32?
0
Do You Know the 4 Main Threat Actor Types?

Do you know the main threat actor types? Most attackers fall into one of four categories, each with their own favored tactics, techniques, and procedures.

 
LVL 117
ID: 38722014
you could try that tool.

the filetype is probably based on iso size
0
 

Author Comment

by:janhoedt
ID: 38722037
Ok, I ll do that. Other option is to use a cloning tool and try to clone from mounted iso to usb (f.e. Poweriso).
0
 

Author Comment

by:janhoedt
ID: 38722105
Doesn't work with Rufus, it doesn't want to make the usb with the Oracle ISO.
0
 

Author Comment

by:janhoedt
ID: 38722121
Trying with poweriso now.
0
 

Author Comment

by:janhoedt
ID: 38722126
VM doesn't want to boot from USB also, it says I have to format it if I want to use it.
0
 

Author Comment

by:janhoedt
ID: 38722135
Booted microserver with usb,  the same: blinking cursor only. Drives me nuts.
0
 
LVL 117
ID: 38722157
you need the correct tool.
0
 
LVL 47

Expert Comment

by:dlethe
ID: 38722414
When you yanked the USB stick you changed the device names.  A USB "speaks" SCSI protocol so if you had a USB stick before then it was probably /dev/sda, so it might have mapped the root partition to /dev/sdb.

But with the USB taken out, then /dev/sdb got remapped to /dev/sda, which is no longer there.  That is most likely root cause.

I can't tell you how to fix it, because using ZFS and solaris under ESX is frankly, nuts, because it hurts performance and you lose many of the advantages and entire point of using ZFS by using it in a virtual environment.  Only exception is a test system or one where you don't care about ZFS as much as having a test system for software development/compatibility purposes.

But this may help
http://www.virtualbox.org/manual/ch03.html
0
 

Author Comment

by:janhoedt
ID: 38722966
>I can't tell you how to fix it, because using ZFS and solaris under ESX is frankly, nuts
? I m not doing that. I m trying to install solaris on bare metal, just as you suggested and just as I mentioned in this ticket.
0
 

Author Comment

by:janhoedt
ID: 38723262
If somebody could try installing Oracle Solaris11 from usb and tell me if it works, then I know it s a problem related to my config.
0
 
LVL 117
ID: 38723294
as I said We will do this later when back in the office!
0
 

Author Comment

by:janhoedt
ID: 38723306
Ok, thanks! Merry Christmas btw :-)
0
 
LVL 117
ID: 38725238
okay, as promised dropped by the office, and popped into one of the labs to test.

the latest sol-11_1-live.x86.usb download we cannot get the OsolLiveUSB003 tool to create a bootable usb flash drive.

we checked our bootable Oracle Solaris USB flash drive, and it still boots a HP ProLiant Microserver.

It helps you by confirming this tool no longer works with the latest ISO from Oracle, but highlights that only an ISO (for VM) or bootable cdrom of the ISO, will boot a server.

So I would look at alternate means to boot your server.
0
 

Author Comment

by:janhoedt
ID: 38726104
Great! Helps a lot indeed! I ll have to buy a dvd/cd rom player then. Would an external dvd writer be recognized (then the money isn t fully wasted for only installation Solaris).
0
 
LVL 117

Accepted Solution

by:
Andrew Hancock (VMware vExpert / EE MVE) earned 500 total points
ID: 38726223
yes, any external removal device should do.
0
 

Author Comment

by:janhoedt
ID: 38726656
Attached a basic Samsung external dvd-writer and booted with Solaris. Looks like it's working!
0
 

Author Comment

by:janhoedt
ID: 38727764
Seemed to be installed, but when I reboot, blinking cursor is there again ... and nothing happens.
No lsi raid to configure, right? Tried to get in lsi bios to check (ctrl + c), it says invoking bios but doesn t do it (ends up on blinking cursor screen).
Please advise!
0
 
LVL 117
ID: 38727775
Tried to get in lsi bios to check (ctrl + c), it says invoking bios but doesn t do it (ends up on blinking cursor screen).

That's the BIOS BUG! That I mentioned, I think trying to get into LSI BIOS.

Clearly, GRUB is not installed correctly.
0
 

Author Comment

by:janhoedt
ID: 38727822
I knew that was the bug, but I thought I should eventually get into it (after a few tries?), but I cannot. So I don t need to check or configure anything in it?
Everything went fine during install, no errors + I installed to ssd of 60 gb without any problem (it suggested to use 2nd ssd of 60 gb, I took first, it suggested to make partitions, I choose option to take full disk).
I could reinstall but don t see where the error/faulty install could be.
0
 

Author Comment

by:janhoedt
ID: 38727870
Please advise, you would try reinstall, hanccocka?
0
 
LVL 117
ID: 38727895
Yes, I would certainly try a re-install.
0
 

Author Comment

by:janhoedt
ID: 38727905
Ok, thanks for quick reply.
Meanwhile I'm trying to install Nexenta, just to see where it gets me.
Interesting: it gives me the option to install OS to 2 disks (mirrored I guess) at once. During install, I see two blue leds of Sharkoon (in which ssd's 60 GB to which I'm installing) flashing at the same time, cool :-)
I'll keep you updated.
0
 

Author Comment

by:janhoedt
ID: 38727940
It boots into Nexenta (and two leds of ssd's are flashing so fault redundant at once)! Wow, I'm a happy man :-)
I'll stick to Nexenta for now. When I can make this working correctly, I might spend some time in the future with Solaris :-)
0
 
LVL 117
ID: 38727958
No problems, very little difference, and Nexenta is easier to manage for the "layman"
0

Featured Post

Control application downtime with dependency maps

Visualize the interdependencies between application components better with Applications Manager's automated application discovery and dependency mapping feature. Resolve performance issues faster by quickly isolating problematic components.

Join & Write a Comment

Create your own, high-performance VM backup appliance by installing NAKIVO Backup & Replication directly onto a Synology NAS!
It Is not possible to enable LLDP in vSwitch(at least is not supported by VMware), so in this article we will enable this, and also go trough how to enabled CDP and how to get this information in vSwitches and also in vDS.
This tutorial will walk an individual through the steps necessary to enable the VMware\Hyper-V licensed feature of Backup Exec 2012. In addition, how to add a VMware server and configure a backup job. The first step is to acquire the necessary licen…
This Micro Tutorial steps you through the configuration steps to configure your ESXi host Management Network settings and test the management network, ensure the host is recognized by the DNS Server, configure a new password, and the troubleshooting…

708 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

19 Experts available now in Live!

Get 1:1 Help Now