network connectivity system tray icon shows exclamation and no internet when in fact there is internet connection

I have a puzzling problem. The network status notification icon displays a yellow bang (exclamation point) and the accompanying message that says "no internet connection" when in fact there is, and I am able to surf the web.  I have installed the latest release of the intel drivers relevant to the onboard nics to no avail.  This is a brand new server with an Intel mobo and nics and is running under windows server 2008r2.  This is a dedicated MS Exchange 2010 Server, and also has Active Directory and DNS roles installed.  How can I resolve this?  I have an identical server that is a domain controller/file server that does not have this problem.  Each server has two nics--one is configured on a local subnet that services the internal network and the other is configured on a different subnet to accommodate an apc ups PowerChute Network Shutdown protocol.  Thanks for any help you can offer...
LVL 1
aerblichAsked:
Who is Participating?
 
gt2847cConnect With a Mentor Sr. Security ConsultantCommented:
The yellow bang is due to Network Connectivity Status Indicator (NCSI) failing one of the checks that it attempts:

A request for DNS name resolution of dns.msftncsi.com - expects 131.107.255.255
and
A request for http://www.msftncsi.com/ncsi.txt - expects a plain text file with "Microsoft NCSI"

If one or both of those fail, you get the yellow bang.  It's Microsoft's attempt to do network awareness.  It's more useful on Win7 and client based systems than on servers, however it's not necessarily a "this is broken you must fix it" scenario.  If you use a proxy server with authentication and the MS site is not permitted without authentication, this can show up.  If your server doesn't have a proxy configured (and is required for Internet access due to firewall settings)  this can show up.  There are numerous other scenarios that are innocuous and don't impact functionality.  If your server is working as you expect and this is just a distraction, you can shut off the NCSI functionality through group policy and it won't show up anymore.

Here's the Technet article on it.
0
 
pony10usCommented:
Since you are running dual NIC's I would first check to see that it is the NIC being used for Internet that is displaying the "!".
0
 
Andrej PirmanConnect With a Mentor Commented:
It might be due to dual gateway config. If your second NIC (for APC PowerShute) has gateway configured, then it might be the problem. Remove GW from that NIC.

Also try from command prompt:
route print

Open in new window

and see, how many routes do you have for 0.0.0.0 destination. If there is only one, it is correct, if there are multiple, it means problem.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.