Solved

Exchange 2010 issues

Posted on 2012-12-24
10
410 Views
Last Modified: 2013-03-20
I have an Exchange server with some issues, which I think they are related.

The Exchange server used to be hosted by a trusted domain in a different site, we recently moved it over to the local LAN, and it is now part of the same domain and site as the rest of the network.

The issues we are having are as follows:

1. Autodiscover configures Outlook using 'HTTP Proxy'. Any attempt to change that so that Outlook should connect to the Exchange server using the local DNS name, reverts itself back when Outlook is restarted.

2. The GAL does not update on the client Outlook. Forcing an update does not help.

3. Occasionally, 'some' users keep on getting popups to enter an Exchange password..

Please advise how to fix auto-discover first.

Thank you.
0
Comment
Question by:clesin
10 Comments
 
LVL 25

Expert Comment

by:Tony Giangreco
ID: 38719349
Initially I would check the dns entried and make those corrections. Then verify the dns replicates. After that cycle, I'd check your certificates and see if the domain changes the server went through require your certificates to be regeneratd or corrected.
0
 

Author Comment

by:clesin
ID: 38719355
What do you mean by DNS replicates??

And also, how/where would I change the auto-configure settings to NOT configure outlook with HTTP??
0
 
LVL 25

Expert Comment

by:Tony Giangreco
ID: 38719366
No Check and change (if necessary) the dns each Pc uses in TCP/IP properties of the nics.
0
 

Author Comment

by:clesin
ID: 38719376
All the PC's are pointing to the local DNS server, and they all have the correct entry for the Exchange server.
0
 
LVL 8

Expert Comment

by:SeaSenor
ID: 38719500
have you manually set up a profile putting in the exchange server name?

if not, try that, and see if it keeps the settings.

Also, was the Outlook/Office install set up using the OCT? (office customization tool)

I have seen where that has an old entry causing it to look for the old server.
0
Comprehensive Backup Solutions for Microsoft

Acronis protects the complete Microsoft technology stack: Windows Server, Windows PC, laptop and Surface data; Microsoft business applications; Microsoft Hyper-V; Azure VMs; Microsoft Windows Server 2016; Microsoft Exchange 2016 and SQL Server 2016.

 
LVL 27

Expert Comment

by:davorin
ID: 38719920
Here is a couple of links about autodiscover hoping they will help you.
http://blogs.technet.com/b/ilvancri/archive/2010/02/03/some-autodiscover-fun.aspx
http://www.networksteve.com/exchange/topic.php/How_Do_I_change_settings_set_by_autodiscover/?TopicId=17388&Posts=2
http://www.networksteve.com/exchange/topic.php/Is_there_a_way_to_disable_Autodiscover_for_Outlook_or_Exchange_2/?TopicId=30703&Posts=4

I would firstly try to check and correct autodiscover configuration. Check used certificates also.
In one case the certificate was incorrectly issued and the decided that they will wait with wrong certificate until it expires, so I was "forced to" disable internal autodiscover setting ExcludeScpLookup registry entry to 0 on problematic end user PCs. Complete path is in first link.
Hope this will help you a little bit.
0
 

Author Comment

by:clesin
ID: 38720047
I did try and create a new outlook profile, configuring it manually. No, I did not use OCT.

And yes, it does revert back to the http settings automatically.
0
 
LVL 9

Expert Comment

by:sirakov
ID: 38720963
it seems that outlook can't find SCP and falls back to use HTTP
in  exchange power shell run:
get-clientAccessServer | fl *uri*

Check the returned URL and see if you can access it with a client ... (any proxy? or dns issues?)
0
 
LVL 63

Accepted Solution

by:
Simon Butler (Sembee) earned 500 total points
ID: 38723071
If you have Outlook Anywhere enabled in Exchange, then all clients will get the configuration for Outlook Anywhere. However that does NOT mean they will use it.
To confirm what method is being used to connect, once Outlook has started, right click on the Outlook icon while holding down CTRL and choose Connection Status. If the protocol is HTTPS then Outlook Anywhere is being used, if it is TCP then it is not.

As for the autodiscover issues, if you had Exchange in another forest then your forest might have been setup to allow autodiscover to work. It would be something like the method outlined here: http://blogs.technet.com/b/exchange/archive/2011/03/04/3412075.aspx

Simon.
0
 

Author Closing Comment

by:clesin
ID: 39003149
I ended up disabling Outlook Anywhere on this Exchange 2010 server since it was causing me more trouble than what it was worth..

All seems to work now.
0

Featured Post

Free book by J.Peter Bruzzese, Microsoft MVP

Are you using Office 365? Trying to set up email signatures but you’re struggling with transport rules and connectors? Let renowned Microsoft MVP J.Peter Bruzzese show you how in this exclusive e-book on Office 365 email signatures. Better yet, it’s free!

Join & Write a Comment

The recent Microsoft changes on update philosophy for Windows pre-10 and their impact on existing WSUS implementations.
Following basic email etiquette rules will help you write a professional email and achieve a good, lasting impression with your contacts.
To efficiently enable the rotation of USB drives for backups, storage pools need to be created. This way no matter which USB drive is installed, the backups will successfully write without any administrative intervention. Multiple USB devices need t…
This tutorial will show how to configure a single USB drive with a separate folder for each day of the week. This will allow each of the backups to be kept separate preventing the previous day’s backup from being overwritten. The USB drive must be s…

747 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

13 Experts available now in Live!

Get 1:1 Help Now