Solved

How to connect VM machines to internet

Posted on 2012-12-25
21
864 Views
Last Modified: 2013-02-04
I have VM Workstation. I have installed windows 2008 and linux Fedora as Virtual machines within VM workstation. on the VM settings, the ethernet Network Connection is set to Bridged.
However, I cannot connect to internet neither from Windows nor from Linux.

Any help?

Thanks
0
Comment
Question by:jskfan
  • 14
  • 4
  • 2
  • +1
21 Comments
 
LVL 10

Assisted Solution

by:Subhashish Laha
Subhashish Laha earned 72 total points
ID: 38720068
Please check below things

1. NIC is set to Connect at Power ON
2. VMTools installed
3. Change NIC connection from Bridged to NAT and try accessing Internet.
0
 
LVL 117

Assisted Solution

by:Andrew Hancock (VMware vExpert / EE MVE)
Andrew Hancock (VMware vExpert / EE MVE) earned 286 total points
ID: 38720070
are the machines receiving a DHCP IP Address?

do you use DHCP on your LAN

or select NAT for both in the VM Network Settings
0
 
LVL 40

Assisted Solution

by:coolsport00
coolsport00 earned 142 total points
ID: 38720083
Sometimes a simple reboot of your Host workstation will clear things up. Bridged or NAT will work (should work) for you.

~coolsport00
0
 

Author Comment

by:jskfan
ID: 38722799
I still don't know why I cannot connect to internet..
the VM does not pick up IP address.
Ok....if I need to set the IP address of the VM manually.. which IP should I use as Default Gateway, because on my laptop when I run the Ipconfig /all, I see IP for the wireless adapter and IPs for the VMnet8 and Vmnet1 or 3.. I don't remember since I am not in front of the laptop computer now
0
 
LVL 117

Assisted Solution

by:Andrew Hancock (VMware vExpert / EE MVE)
Andrew Hancock (VMware vExpert / EE MVE) earned 286 total points
ID: 38723311
if using Bridged the default gatewaybfor your LAN
0
 

Author Comment

by:jskfan
ID: 38729011
hanccocka

I have installed VMWorkstation on my laptop, virtual machines(windows 2008 and Linux Fedora) are installed inside VMWorkstation.
My Laptop is connected to internet wirelessly.
Windows2008 and Linux Fedora are set to get IP automatically through DHCP.
I set them to Bridged , it did not work then to NAT and it did not work.

This is my laptop IPCONFIG
=======================

 
C:\>ipconfig /all

Windows IP Configuration

   Host Name . . . . . . . . . . . . : TEST-PC
   Primary Dns Suffix  . . . . . . . :
   Node Type . . . . . . . . . . . . : Hybrid
   IP Routing Enabled. . . . . . . . : No
   WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Bluetooth Network Connection:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Bluetooth Device (Personal Area Network)
   Physical Address. . . . . . . . . : 68-5D-43-CA-9D-23
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes

Wireless LAN adapter Wireless Network Connection 3:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Microsoft Virtual WiFi Miniport Adapter #
2
   Physical Address. . . . . . . . . : 68-5D-43-CA-9D-20
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes

Wireless LAN adapter Wireless Network Connection 2:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Microsoft Virtual WiFi Miniport Adapter
   Physical Address. . . . . . . . . : 68-5D-43-CA-9D-20
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes

Wireless LAN adapter Wireless Network Connection:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Intel(R) Centrino(R) Wireless-N 2230
   Physical Address. . . . . . . . . : 68-5D-43-CA-9D-1F
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : fe80::f05c:6a11:73ff:e86a%12(Preferred)
   IPv4 Address. . . . . . . . . . . : 192.168.1.2(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Lease Obtained. . . . . . . . . . : Friday, December 28, 2012 1:21:09 PM
   Lease Expires . . . . . . . . . . : Sunday, December 30, 2012 3:27:21 AM
   Default Gateway . . . . . . . . . : 192.168.1.1
   DHCP Server . . . . . . . . . . . : 192.168.1.1
   DHCPv6 IAID . . . . . . . . . . . : 325606723
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-18-4C-2C-31-8C-89-A5-03-C3-8D

   DNS Servers . . . . . . . . . . . : 192.168.1.1
   NetBIOS over Tcpip. . . . . . . . : Enabled

Ethernet adapter Local Area Connection:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Killer e2200 PCI-E Gigabit Ethernet Contr
oller (NDIS 6.20)
   Physical Address. . . . . . . . . : 8C-89-A5-03-C3-8D
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes

Ethernet adapter VMware Network Adapter VMnet1:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : VMware Virtual Ethernet Adapter for VMnet
1
   Physical Address. . . . . . . . . : 00-50-56-C0-00-01
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : fe80::7492:720b:d25c:1001%17(Preferred)
   IPv4 Address. . . . . . . . . . . : 192.168.17.1(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . :
   DHCPv6 IAID . . . . . . . . . . . : 335564886
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-18-4C-2C-31-8C-89-A5-03-C3-8D

   DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1
                                       fec0:0:0:ffff::2%1
                                       fec0:0:0:ffff::3%1
   NetBIOS over Tcpip. . . . . . . . : Enabled

Ethernet adapter VMware Network Adapter VMnet8:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : VMware Virtual Ethernet Adapter for VMnet
8
   Physical Address. . . . . . . . . : 00-50-56-C0-00-08
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : fe80::19b6:60b3:b87f:6cd8%18(Preferred)
   IPv4 Address. . . . . . . . . . . : 192.168.248.1(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . :
   DHCPv6 IAID . . . . . . . . . . . : 352342102
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-18-4C-2C-31-8C-89-A5-03-C3-8D

   DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1
                                       fec0:0:0:ffff::2%1
                                       fec0:0:0:ffff::3%1
   NetBIOS over Tcpip. . . . . . . . : Enabled

Tunnel adapter isatap.{FA4D5D5F-EF4F-4B2A-B8DE-5DE3CC303601}:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Microsoft ISATAP Adapter
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes

Tunnel adapter isatap.{F5E5C94E-0A96-4B2E-9CBC-BA5671482004}:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Microsoft ISATAP Adapter #2
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes

Tunnel adapter isatap.{E74DAB4C-EDB1-4F26-9642-1F68812FE2EA}:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Microsoft ISATAP Adapter #3
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes

Tunnel adapter isatap.{766F655A-5488-408F-B59C-EA66D18CEFED}:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Microsoft ISATAP Adapter #4
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes

Tunnel adapter Local Area Connection* 9:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes

Tunnel adapter isatap.{D6E50738-83C6-4876-A41B-0E7630BEA344}:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Microsoft ISATAP Adapter #5
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes

Tunnel adapter isatap.{4776ABC8-6BA5-4AE7-9B60-A1B5E7C6C6BE}:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Microsoft ISATAP Adapter #6
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes

Tunnel adapter isatap.{A3CFF511-FB9C-47B7-B410-C29646F8742F}:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Microsoft ISATAP Adapter #7
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes

C:\>

Open in new window

0
 

Author Comment

by:jskfan
ID: 38729019
I disabled IPv6 on my wireless adapter as well as on my windows 2008 VM ,but still did not resolve the issue
0
 

Author Comment

by:jskfan
ID: 38729047
Mmmm,
iI configured local area connection for windows 2008 as static with DG IP the same as the one of my laptop wireless adapter, Now the Local area connection, does not show "unidentified" as it used to be. but when I run ipconfig /all on windows 2008, it shows :
dhcp enable=NO
Autoconfiguration enabled=yes
Autoconfiguration IPv4 address=169.254.46.16(Duplicate)
 Subnet Mask=255.255.0.0
IPv4 address=192.168.1.3(Duplicate)

I cannot ping windows 2008 IP (itself), nor the DG,nor the IP of the laptop wireless adapter.
0
 

Author Comment

by:jskfan
ID: 38729060
something wrong...I rebooted w2008, now the adapter shows "unidentified network"
0
 

Author Comment

by:jskfan
ID: 38729066
I used this link instructions. it worked up to where I  can ping myself(win2008) as well as DG 192.168.1.1, but cannot get to internet.
http://lyngtinh.blogspot.com/2011/12/how-to-disable-autoconfiguration-ipv4.html
0
IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

 

Author Comment

by:jskfan
ID: 38729106
I rebooted win2008
now when I ping 192.168.1.1
I get Destination host unreachable.

that s weird.
0
 

Author Comment

by:jskfan
ID: 38729113
Wow...I have no idea how I got it working:
the thing I remeber I have done was...changing it back to Bridged..then run Ipconfig /flushdns then Ipconfig /registerdns.
I remember I have run ipconfig /flushdns before a bunch of times, but it did not resolve the issue.
it could be that ipconfig /registerdns resolved the issue....but I am not sure where it will register DNS...??? since it s a standalone server.
0
 
LVL 40

Assisted Solution

by:coolsport00
coolsport00 earned 142 total points
ID: 38729147
@jskfan...the really sounds like the issue I had like a yr ago. I posted on here & me & @hanccocka worked through everything but still didn't work. I think I ended up rebooting, maybe even did an ipconfig /flushdns kind of thing & it worked. With Workstation, your VMs are getting their IP from the 'internal' DHCP of Workstation....no DNS.

Well...regardless...glad it's working for you now :)

Regards.
~coolsport00
0
 

Author Comment

by:jskfan
ID: 38729172
I can ping DG 192.168.1.1
I can get to internet....
But I still cannot ping the IP address of my laptop wireless adapter 192.168.1.2 from VM (win2008)

in case I want to \\192.168.1.2\C$ and run a program from there, I will not be able to.
0
 
LVL 117

Assisted Solution

by:Andrew Hancock (VMware vExpert / EE MVE)
Andrew Hancock (VMware vExpert / EE MVE) earned 286 total points
ID: 38729526
can you ping the following IP address:-

158.152.1.222 ?

can you traceroute to

158.152.1.222 ?
0
 

Author Comment

by:jskfan
ID: 38731022
Yes I can ping 158.152.1.222 nd able to Traceroute using Tracert
the 19th hop shows : demon-du-demon.co.uk [158.152.1.222]
0
 

Author Comment

by:jskfan
ID: 38731029
The one thing that I cannot understand is on my laptop windows7, when I open command prompt and the ping by reverse IP and hostname, I cannot 2 different outputs, though IPv6 is not enabled.

C:\>ping -a 192.168.1.2

Pinging TEST-PC [192.168.1.2] with 32 bytes of data:
Reply from 192.168.1.2: bytes=32 time<1ms TTL=128
Reply from 192.168.1.2: bytes=32 time<1ms TTL=128
Reply from 192.168.1.2: bytes=32 time<1ms TTL=128
Reply from 192.168.1.2: bytes=32 time<1ms TTL=128

Ping statistics for 192.168.1.2:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 0ms, Maximum = 0ms, Average = 0ms

C:\>ping test-pc

Pinging TEST-PC [fe80::7492:720b:d25c:1001%17] with 32 bytes of data:
Reply from fe80::7492:720b:d25c:1001%17: time<1ms
Reply from fe80::7492:720b:d25c:1001%17: time<1ms
Reply from fe80::7492:720b:d25c:1001%17: time<1ms
Reply from fe80::7492:720b:d25c:1001%17: time<1ms

Ping statistics for fe80::7492:720b:d25c:1001%17:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 0ms, Maximum = 0ms, Average = 0ms

C:\>
0
 
LVL 117

Accepted Solution

by:
Andrew Hancock (VMware vExpert / EE MVE) earned 286 total points
ID: 38731066
Internet is working then!

DNS resolution is working, and traffic is passing through your gateway to the internet.

that's local DNS issue
0
 

Author Comment

by:jskfan
ID: 38758178
hanccocka
sorry for the delay.
When you say Local DNS, are you  talking about DNS client? because I have not installed any DNS server.

plus, even when I type \\192.168.1.2\C$
to see what is in my laptop C: drive , I cannot get to it from VM
0
 

Author Comment

by:jskfan
ID: 38850179
I will close this question for now and open one later when I do some testing
0
 

Author Closing Comment

by:jskfan
ID: 38850184
Thank you
0

Featured Post

Free Gift Card with Acronis Backup Purchase!

Backup any data in any location: local and remote systems, physical and virtual servers, private and public clouds, Macs and PCs, tablets and mobile devices, & more! For limited time only, buy any Acronis backup products and get a FREE Amazon/Best Buy gift card worth up to $200!

Join & Write a Comment

In this article, I will show you HOW TO: Suppress Configuration Issues and Warnings Alert displayed in Summary status for ESXi 6.5 after enabling SSH or ESXi Shell.
A procedure for exporting installed hotfix details of remote computers using powershell
This tutorial will walk an individual through the steps necessary to install and configure the Windows Server Backup Utility. Directly connect an external storage device such as a USB drive, or CD\DVD burner: If the device is a USB drive, ensure i…
This Micro Tutorial steps you through the configuration steps to configure your ESXi host Management Network settings and test the management network, ensure the host is recognized by the DNS Server, configure a new password, and the troubleshooting…

760 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

16 Experts available now in Live!

Get 1:1 Help Now