Solved

Exchange 2003 SP2 Activesync no longer working with iPhones

Posted on 2012-12-25
20
1,068 Views
Last Modified: 2013-01-03
Exchange 2003 sp2 on Windows server 2003 Enterprise (NOT small business server)
Single email server setup as backend on single domain

I have been through the famous walkthrough on EE about activesync on Exchange 2003.  It still isn't working.
It was working until last Thursday or Friday...we had one guys iphone still working with ActiveSync on Monday...while his was working we plugged in the information for an employee's that wasn't working.  It didn't work.  When he put his information back in the phone it no longer worked.

I am at a complete loss to explain this or fix it.
0
Comment
Question by:rand1964
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 11
  • 8
20 Comments
 
LVL 9

Assisted Solution

by:djsharma
djsharma earned 200 total points
ID: 38720811
Check the status of activesync whether it is enabled or disabled,refer the below link.
http://technet.microsoft.com/en-us/library/aa997489(v=exchg.65).aspx

Check the Microsoft Exchange ActiveSync Connectivity Tests using the below link.
https://www.testexchangeconnectivity.com/
0
 
LVL 76

Assisted Solution

by:Alan Hardisty
Alan Hardisty earned 300 total points
ID: 38720867
Are you using Forms-Based Authentication (pretty login screen vs plain window) for Webmail?

If you have been through my article, did anything need changing?

Are all other users working happily?

What Anti-Virus software is installed in the server?  If you have Microsoft Security Essentials, uninstall it as it breaks Activesync.

Alan
0
 

Author Comment

by:rand1964
ID: 38721641
I had Microsoft Security Essentials and removed it.  It still didn't work.
Activesync is enabled on the users.

I reset all the IIS directories using adsutil.vbs

It hasn't solved the problem.

The Exchange Analyzer tells me :

An ActiveSync session is being attempted with the server.
 Errors were encountered while testing the Exchange ActiveSync session.
 Test Steps
 Attempting to send the OPTIONS command to the server.
 Testing of the OPTIONS command failed. For more information, see Additional Details.
  Tell me more about this issue and how to resolve it
 Additional Details
 ExRCA couldn't find MS-Server-ActiveSync and MS-ASProtocolVersions header. Headers received were: MS-Author-Via: DAV
DASL: <DAV:sql>
DAV: 1, 2
Public: OPTIONS, TRACE, GET, HEAD, DELETE, PUT, POST, COPY, MOVE, MKCOL, PROPFIND, PROPPATCH, LOCK, UNLOCK, SEARCH
Allow: OPTIONS, TRACE, GET, HEAD, LOCK, UNLOCK
Accept-Ranges: bytes
Content-Length: 0
Cache-Control: private
Date: Wed, 26 Dec 2012 17:21:24 GMT
Server: Microsoft-IIS/6.0
X-Powered-By: ASP.NET
0
Get 15 Days FREE Full-Featured Trial

Benefit from a mission critical IT monitoring with Monitis Premium or get it FREE for your entry level monitoring needs.
-Over 200,000 users
-More than 300,000 websites monitored
-Used in 197 countries
-Recommended by 98% of users

 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 38721835
Okay - is the error you get via the test site an error 500 which is why you followed kb883380?

What about the answer to the Forms-Based Authentication question?

Alan
0
 

Author Comment

by:rand1964
ID: 38722091
I have tried with and without forms based...neither works.  For years we have had forms based enabled and it has worked.
0
 

Author Comment

by:rand1964
ID: 38722102
I don't see any error number via the test site...where do I find it?
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 38722230
Okay - do you currently have Forms-Based Authentication enabled?

The error number is usually under the last expandable area on the test site.

You need to run the test (without Autodiscover) and specify manual server settings.

Alan
0
 

Author Comment

by:rand1964
ID: 38722240
Yes...Forms based is enabled and test run without autodiscover
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 38722246
Okay - with FBA enabled, have you followed KB817379 to create the exchange-oma virtual directory?

With SSL enabled on the Exchange virtual directory, you need the exchange-oma setup and using port 80 (no SSL) to make Activesync work properly.
0
 

Author Comment

by:rand1964
ID: 38722248
The error at the end is exactly as posted above:

An ActiveSync session is being attempted with the server.
 Errors were encountered while testing the Exchange ActiveSync session.
 Test Steps
 Attempting to send the OPTIONS command to the server.
 Testing of the OPTIONS command failed. For more information, see Additional Details.
  Tell me more about this issue and how to resolve it
 Additional Details
 ExRCA couldn't find MS-Server-ActiveSync and MS-ASProtocolVersions header. Headers received were: MS-Author-Via: DAV
DASL: <DAV:sql>
DAV: 1, 2
Public: OPTIONS, TRACE, GET, HEAD, DELETE, PUT, POST, COPY, MOVE, MKCOL, PROPFIND, PROPPATCH, LOCK, UNLOCK, SEARCH
Allow: OPTIONS, TRACE, GET, HEAD, LOCK, UNLOCK
Accept-Ranges: bytes
Content-Length: 0
Cache-Control: private
Date: Wed, 26 Dec 2012 17:21:24 GMT
Server: Microsoft-IIS/6.0
X-Powered-By: ASP.NET
0
 

Author Comment

by:rand1964
ID: 38722295
OK....I applied the KB817379  and made the new directory.  Nothing...still not working.
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 38722301
Did you add the registry key too?

Once done, did you run iisreset?
0
 

Author Comment

by:rand1964
ID: 38722314
Yes on both counts
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 38722329
Can you please post a screen-dump of the forward lookup zones of your DNS Server (hide the internal domain name if you want to protect your identity, but not more that the domain part please).

Alan
0
 

Author Comment

by:rand1964
ID: 38722337
I will get back tomorrow on this.
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 38722342
No problems.

Catch you tomorrow.

Alan
0
 

Author Comment

by:rand1964
ID: 38722607
What are you looking for with the forward lookup zones....it would take a lot of name changing on my part to get information off there that I don't want public...
looking for MX records?
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 38722672
No - want to see the internal.local name and _msdcs.internal.local names.

Nothing more than the top level domains.

If you prefer - you can email me a picture to alan @ it-eye.co.uk - I'll keep it private.

Alan
0
 

Accepted Solution

by:
rand1964 earned 0 total points
ID: 38729958
Solved:   in IIS, the "Default Website" properties for authentication were set wrong.  Anonymous was disabled and Basic and Integrated was checked.  I am still not sure how this happened...I didn't do it mself.
However, when "Anonymous" was checked and all others unchecked it started working and all iphones are connecting once again.
0
 

Author Closing Comment

by:rand1964
ID: 38739497
I appreciate everyone's help.  Thanks to Alan Hardisty for following through multiple steps with me.  That's why I am a member of Experts Exchange...there is no other forum where you can get this kind of "tech support" at such a high rate of quality and experience.

Thanks djsharma the exchange analyzer tool was helpful and previously I didn't know about it.

This issue with iPhones and Exchange seems to be a huge issue with many, many different reasons and solutions.  
Hopefully somebody that has this same issue will be helped by this particular solution.
0

Featured Post

Online Training Solution

Drastically shorten your training time with WalkMe's advanced online training solution that Guides your trainees to action. Forget about retraining and skyrocket knowledge retention rates.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In-place Upgrading Dirsync to Azure AD Connect
A couple of months ago we ran into an issue that necessitated re-creating our Edge Subscriptions. However, when we attempted to execute the command: New-EdgeSubscription -filename C:\NewEdgeSub_01.xml we received an error indicating that the LDAP se…
To show how to create a transport rule in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Mail Flow >> Rules tab.:  To cr…
The basic steps you have just learned will be implemented in this video. The basic steps are shown to configure an Exchange DAG in a live working Exchange Server Environment and manage the same (Exchange Server 2010 Software is used in a Windows Ser…
Suggested Courses

636 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question