?
Solved

Workflow Server (2008) can not access shares on File Server (2003)

Posted on 2012-12-26
12
Medium Priority
?
758 Views
Last Modified: 2013-01-02
Hello,

My workflow server (running Server 2008) continually has issues connecting to shared folders on my file server (running Server 2003).

The workflow server has one of the shared folders from the file server mapped.  Then, suddenly, it can not longer access it.  I get this error:

"(\\servername\shared folder) is not accessible.  You might not have permission to use this network resource.  Contact the administrator of this server to find out if you have access permissions.  NO MORE INTERNAL FILE IDENTIFIERS AVAILABLE."

My administrative account DOES have access to this server/share/folder and I do not get this message when accessing our secondary file server (also running Server 2003).  After restarting the workflow server, I can access the shared folder/drive for a while and then suddenly I can not and get the above error.  I have checked the Event Logs on both servers and see nothing out of the ordinary and not warnings or errors (well, the usual for print spoolers but nothing else).  

Please provide some assistance and if you need anything further I will provide it quickly.  Thanks!
0
Comment
Question by:JSPtechserv
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 6
  • 4
  • 2
12 Comments
 
LVL 10

Expert Comment

by:akhalighi
ID: 38721957
hmm .. usually not easy to track these types of issues ... to begin with .. would you please elaborate a little bit more about  the issue :

1- does your workflow server use IP address or DNS name to connect to 2003 ?
2- when it fails to connect , before you restart the service , are you able to connect to the same share using windows explorer ? can you access using IP address ? can you ping 2003
from 2008 when share is not accessible ?

3- next time this issue happens , try restarting "server service "  on 2003 machine.
4- Any other machine\server has the same issue connecting to 2003 server ?
0
 

Author Comment

by:JSPtechserv
ID: 38722122
Hello alkhalighi,

1 - The servers use DNS to connect
2 - I just restarted the server so I can not tell you this piece of information yet but a ping is possible (tried that before)
3 - Again, I just restarted but I will try this if/when the problem occurs again
4 - No, no other machines have the same problem connecting to the file server, only my workflow server.  It appears to be an issue ONLY between my workflow server and my primary file server.

Would clearing the DNS cache on the workflow server accomplish anything?  Initially it appears to be either a problem with DNS or DFS
0
 

Author Comment

by:JSPtechserv
ID: 38722354
Hello again,

The error occurred again.  

I can not connect to any shares on the file server using windows explorer HOWEVER using an IP address in windows Explorer I can access the shares!  I can also ping the file server.  I can also Remote Desktop Connect to the File server from the workflow server.

I will be restarting the server service on the file server tomorrow morning to see if that resolves any issues.  Right now it appears to be a DNS issue.  Keep in mind that other servers can see and access my primary file server shares just fine.  It is only the workflow server that sometimes can not (quid pro quo: This workflow server has been online for six months and has not had this error before).
0
Simplifying Server Workload Migrations

This use case outlines the migration challenges that organizations face and how the Acronis AnyData Engine supports physical-to-physical (P2P), physical-to-virtual (P2V), virtual to physical (V2P), and cross-virtual (V2V) migration scenarios to address these challenges.

 
LVL 11

Accepted Solution

by:
marek1712 earned 1500 total points
ID: 38723811
NO MORE INTERNAL FILE IDENTIFIERS AVAILABLE
Are there ay unusual applications running? The above error states that the OS has ran out of FIDs (every file opened in the system receives its' own FID which should be programatically returned after the file operation is finished). Seems like application error or memory leak.
You can try running ProcMon or Process Explorer on both servers to look for the issues.
0
 

Author Comment

by:JSPtechserv
ID: 38724012
Marek1712,

Yes, we are running Enfocus Switch on our workflow server.  This program heavily relies on DNS and opens/moves several files at once.  It does this by "chopping" each file up and renaming the parts and then reassembling them at the destination.  I will check with their maintenance team to see if this could cause FID issues.  Thanks!

Alkhalighi,

I restarted the Server Service on our file server and that seemed to do the trick right away.  I am monitoring it to make sure the DNS connection between the two does not drop again but that may have been the solution.
0
 

Author Comment

by:JSPtechserv
ID: 38724284
Hello All,

It appears that restarting the Server Service fixes the issues for about three hours or so and then it reverts back to not being able to see the shared folder.  

Marek1712,

What am I looking for in ProcMon that would show a memory leak?
0
 
LVL 11

Expert Comment

by:marek1712
ID: 38724378
Maybe not a memory leak, but number of files being opened. But since you know the application that MAY BE responsible I'd wait for the support's response. In the meantime I'd set a scheduled task to restart the service hourly.
Another thing to check is HANDLE.EXE - it should show you all the open handles (the same can be achieved in ProcExp).
0
 
LVL 10

Expert Comment

by:akhalighi
ID: 38724541
hmm ... there is one more thing .. do you have the same issue with explorer from a different machine once your workflow server fails to connect ?

as a temporary workaround , could you use IP address instead of DNS name in your application ?
0
 
LVL 10

Expert Comment

by:akhalighi
ID: 38724546
do you run Symantec anti virus on File server ? any security application ?
0
 

Author Comment

by:JSPtechserv
ID: 38725131
Yes, but Symantec is not causing the issue.

I have used the IP as a temporary work around.

I do not have the same error on any other machine using Explorer, only the workflow server
0
 
LVL 10

Expert Comment

by:akhalighi
ID: 38726026
Okay , then .. next question ; when the issue happens , are you able to ping DNS name ? if not .. what is DNS setting on workflow server , is it connecting to the same DNS server as other machines ?

It's possible that for some reason DNS server blocks this machine every once in a while. have you check DNS server log files ? do you have security applications on DNS servers ?

as a troubleshooting step ; you can change host file on workflow server and hard code DNS name and IP address of your file server in there so that workflow server doesn't go to DNS server to resolve that name and it always refers to local host file . this will tell you if something goes wrong with DNS handling .
0
 

Author Closing Comment

by:JSPtechserv
ID: 38737896
It was a memory leak on Switch 11 Upgrade 3 as noted by the manufacturer.  I rolled back to Switch 11 U2 and it is working fine.  THanks!
0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

You might have come across a situation when you have Exchange 2013 server in two different sites (Production and DR). After adding the Database copy in ECP console it displays Database copy status unknown for the DR exchange server. Issue is strange…
Sometimes drives fill up and we don't know why.  If you don't understand the best way to use the tools available, you may end up being stumped as to why your drive says it's not full when you have no space left!  Here's how you can find out...
This tutorial will show how to configure a new Backup Exec 2012 server and move an existing database to that server with the use of the BEUtility. Install Backup Exec 2012 on the new server and apply all of the latest hotfixes and service packs. The…
This tutorial will walk an individual through setting the global and backup job media overwrite and protection periods in Backup Exec 2012. Log onto the Backup Exec Central Administration Server. Examine the services. If all or most of them are stop…
Suggested Courses

765 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question