Solved

Server 2012 Group Policy Proxy Settings not being applied to XP, 7 clients

Posted on 2012-12-26
9
7,878 Views
Last Modified: 2013-01-08
Hello all

so basically the issue is this: Server 2012 group policy is not applying proxy address settings to client computers as the title states. Here are the details:


-Server 2012 domain controller (just one), a "XPTEST" computer (XP Pro x86 SP3, Group Policy Client Side Extensions update installed) and a "WIN7TEST" computer (Windows 7 Pro x64), both joined to domain.
-Group Policy Management roll installed on Server2012 DC.

-"InternetRestriction" GPO created, link enabled to the "Users" OU containing "testuser", Security Filtering contains the user "testuser" only.
-In the InternetRestriction GPO, the following edits have been made:

-User Configuration\Preferences\Control Panel Settings\Internet Settings\Internet Explorer 8 and 9\
-General Tab: www.ups.com set as home page
-Connections Tab\LAN Settings\Proxy Server \"Use proxy server for your LAN" box checked
-Proxy address specified as 0.0.0.0
-"Bypass proxy server for local addresses" box checked
-Under Advanced, exceptions created is www.ups.com
-all edits have been activated by changing the red dashed line to the solid green line (F6).

That’s it.

When tested, the home page setting is successfully applied as www.ups.com, however the proxy address of 0.0.0.0 and the exception of www.ups.com is NOT APPLIED.

Group Policy Results Wizard indicates the policy is being applied successfully to my "testuser"

running gpupdate /force on the clients is successful, however the results are unchanged.

Running gpresult /v on the clients indicates that the policy is successfully being applied, nothing is blocked.

running rsop.msc shows me the classic group policy screen (which does have the Internet Explorer maintenance in User Config\Policies that was omitted from Server 2012 Group Policy), and the proxy settings are blank.

This is the case on both the XP machine running IE8, and the Windows 7 machine running IE9.

I know at least part of the policy is successfully being applied because the homepage is being changed, however the proxy address settings are not. It’s strange that the home page setting is being applied, but yet the proxy address settings in that same settings window is not being applied.

*note: I do believe Server 2012 and Server 2008 R2 are very similar (if not identical) in this regard.

I am completely out of ideas.......
0
Comment
Question by:HarryTennison
9 Comments
 
LVL 18

Expert Comment

by:Sarang Tinguria
ID: 38722569
try upgrading IE on XP machine to 8 version
0
 
LVL 47

Accepted Solution

by:
Donald Stewart earned 500 total points
ID: 38722580
Under your proxy settings that you are trying to apply, do you have "Gopher" selected??


If so, deselect it and try again....Gopher will interfere with proxy settings starting with IE7.
0
 
LVL 19

Expert Comment

by:compdigit44
ID: 38731131
I've had similar issues in the past deploying proxy server setting via GP to my client workstations. I have found the only way to get the proxy server setting to correctly apply to all workstations XP & 7 was to set the Proxy Setting in the  <Internet Explorer Maintenance> area of the GP with is the old way do doing things but does get seem to work.

I would love to find out what causes this issue any why....
0
Complete VMware vSphere® ESX(i) & Hyper-V Backup

Capture your entire system, including the host, with patented disk imaging integrated with VMware VADP / Microsoft VSS and RCT. RTOs is as low as 15 seconds with Acronis Active Restore™. You can enjoy unlimited P2V/V2V migrations from any source (even from a different hypervisor)

 

Author Comment

by:HarryTennison
ID: 38736543
we did have set to all proxy settings which we changed to setting all but gopher.  this did seem to solve the issue.  Thank you for your input and assistance
0
 

Author Comment

by:HarryTennison
ID: 38755188
As a follow up just for anyone looking at this answer it turns out the key was managing the group policy from a Windows 7 computer and not from the Server 2012.   As the server 2012 does not contain an Internet Explorer Maintenance area.   However when you manage the GPO from a Windows 7 or XP computer your computer will insert the desired Internet Explorer Maintenance fields in order to give the desired behavior.   I should have given split credit for the answer above to both compdigit44 and dstewartjr as it was both their answers that led me in the right direction.

As a cautionary warning after you create the GPO in the lower operating system I have run into the issue of when you edit it from the server 2012; it  causes you to lose its ability to work correctly.  I believe this is because even though it still shows the Internet Explorer Maintenance area it no longer is effective.  I tried just editing it from the lower OS but this did not seem to work for me and thus  I had to delete the GPO and recreate it from the lower OS again in order for it to work correctly or as intended.
0
 
LVL 47

Expert Comment

by:Donald Stewart
ID: 38755739
AGAIN since Internet Explorer 7(and beyond) does not support the Gopher protocol, this was the main cause of "Internet Explorer maintenance" settings not getting applied.

http://www.techrepublic.com/forum/discussions/102-265300
0
 

Author Comment

by:HarryTennison
ID: 38755906
I agree dstewartjr. However, where your answer is incomplete is that even if you change the Gopher settings in the preference field in windows server 2012 it does not work for setting proxy settings.  You have to do it in the   "Internet Explorer maintenance" and that is not an option that is available in windows server 2012.  thus you must edit the GPO from a lower OS and not from the server itself
0
 
LVL 47

Expert Comment

by:Donald Stewart
ID: 38755945
On the 2012 look under Group Policy Preferences/and or IEAK

http://technet.microsoft.com/en-us/library/hh846772.aspx
0
 

Author Comment

by:HarryTennison
ID: 38755960
We did and we set those with the gopher being excluded and it does not work. Which was the problem and the reason we posted the question
0

Featured Post

Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In this article, I am going to show you how to simulate a multi-site Lab environment on a single Hyper-V host. I use this method successfully in my own lab to simulate three fully routed global AD Sites on a Windows 10 Hyper-V host.
This article runs through the process of deploying a single EXE application selectively to a group of user.
This tutorial will walk an individual through the process of transferring the five major, necessary Active Directory Roles, commonly referred to as the FSMO roles to another domain controller. Log onto the new domain controller with a user account t…
This tutorial will walk an individual through the process of installing of Data Protection Manager on a server running Windows Server 2012 R2, including the prerequisites. Microsoft .Net 3.5 is required. To install this feature, go to Server Manager…

830 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question