Solved

Firefox window on OS X opens from minimized state, cannot be clicked

Posted on 2012-12-26
5
639 Views
Last Modified: 2012-12-31
I am new to OS X, seeing if I can transition from Windows to Mac.  I use Firefox on Windows and Mac, and while it works well, there is one odd behavior on OS X.

I typically keep 7 or 8 tabs open in Firefox:  Yahoo, NY Times, WSJ, LA Times, Slashdot, etc.  I then minimize Firefox when I'm not actively browsing.

On OS X, the Firefox window will suddenly open.  When this happens, even though the window is visible, the window is not "active".  I cannot move or resize the window, and I can't click on tabs on the browser.  But, when I click on the open Firefox window, the Firefox menu bar does appear at the top of OS X.  The Firefox window is displayed in a lighter gray color.

To make the window active, I have to either go to the Window menu and select the Firefox window from the list, or click on the Firefox icon on the right side of the Dock.  Once I select it, the Firefox window either redisplays completely, or switches to the slightly darker gray color to indicate it has focus and is active.

My only guess is that one of the web pages I have open is doing an automatic page refresh, and that is causing the Firefox window to open, even though OS X thinks Firefox is still minimized.  OS X then keeps the window disabled, even though I try and click on it.

Has anyone else seen this?  Any ideas or workarounds?
0
Comment
Question by:Steve Endow
  • 4
5 Comments
 
LVL 10

Assisted Solution

by:schaps
schaps earned 500 total points
Comment Utility
Have not seen that specifically, but have seen similar oddities. I assume the most current version of Firefox? When that little Window is visible, click in the "Window" menu and determine what the window is called -- maybe that will be a clue as to why it is opening.

If nothing else, I'd go to Tools--> Clear recent history and choose to clear "Everything" and under "Details" choose all the options.

Please report back any additional info.
0
 
LVL 18

Author Comment

by:Steve Endow
Comment Utility
Ya, it's a new install on a new Mac Mini, so it's Firefox 17.0.1 on OS X 10.8.2.

I just resumed the Mac from sleep, opened Firefox, then minimized it, and the problem happened right away.

Attached are two screen shots.  The first shows Firefox visible, but not "active".  Under the Windows menu, you see My Yahoo, the title for the first tab, but there is no check next to it.  I couldn't click on any tabs, and couldn't minimize or close Firefox, and you can see that a few tabs were still loading--the blue circles on those tabs weren't moving.  It as if Firefox is frozen and not responding, but there doesn't seem to be an actual problem with the app.

Once I click on Window -> My Yahoo, Firefox instantly becomes "active".  The title bar has slight gray shading, and the "My Yahoo" text goes from faded to dark, and the red / yellow / green buttons in the upper left corner become accessible.  In previous tests, clicking on the minimized Firefox in the Dock seemed to activate it as well.

I don't think I have seen this issue with any other apps, so my guess is that it is Firefox specific.  I guess it could be an Add-on I'm using is causing some problem.

I'll try:

1. Disabling most add-ons
2. I'll try using Safari and Chrome for a while with similar tabs loaded to see if they exhibit similar behavior
3. Try uninstalling Firefox completely and reinstalling (hail mary)
Firefox-Mac-1.jpg
Firefox-Mac-2.jpg
0
 
LVL 18

Author Comment

by:Steve Endow
Comment Utility
Well, I think I confirmed my theory, but unfortunately I don't have any good solutions.

I Quit Firefox, then launched it again.  While the tabs were still loading, I minimized it by pressing Command M.  Within a few seconds (presumably when the pages had all loaded), the Firefox window popped open.  Although the red/yellow/green buttons were colored, I couldn't click on any tabs or use the browser.  I had to go to the Windows menu to reactivate Firefox.

I'll try this on my Macbook Air to see if it behaves the same, and I'll see if Safari or Chrome do something similar.

Seems unlikely that I'm the only person on the planet having this issue, but I don't even know what to google for this type of issue.
0
 
LVL 18

Accepted Solution

by:
Steve Endow earned 0 total points
Comment Utility
Since I was able to figure out how to consistently reproduce it, I was able to track down what I believe to be the cause of the problem.

I use RoboForm, which has an integrated Firefox toolbar.  It seems the RoboForm extension is causing the problem.  When I disable it, the problem doesn't occur.  When I enable it again, the problem occurs.

I'll submit a support case with them and see if they can reproduce.

Thanks for the help, it at least got me started in a different direction to figure it out.
0
 
LVL 18

Author Closing Comment

by:Steve Endow
Comment Utility
I was able to identify the cause of the problem with continued testing.
0

Featured Post

How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

Join & Write a Comment

Now-a-days, indirectly, postal services have been replaced by email services. Yes, whenever we hear the word "email" a lot of people only think of gmail. Some people still think that email and gmail are one and the same thing :-). Let's see some …
Introduction If you're like most people, you have occasionally made a typographical error when you're entering information into an online form.  And to your consternation, the browser remembers the error, and offers to autocomplete your future entr…
This Micro Tutorial will demonstrate how to add subdomains to your content reports. This can be very importing in having a site with multiple subdomains.
How to create a custom search shortcut to site-search Experts Exchange using Google in the Firefox browser. This eliminates the need to type out site:experts-exchange.com whenever you want to search the site. Launch your Bookmark Menu: Press 'Ctrl +…

771 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

11 Experts available now in Live!

Get 1:1 Help Now