Avatar of PCF IT
PCF IT
Flag for Canada asked on

ubuntu server + samba +AD

Hi there,
The ubuntu file server was installed with no additional packages.
Then server was joined to Windows domain using:

apt-get install likewise-open
domainjoin-cli join example.com Administrator

domain users can login using SSH with no problem.

Samba was installed following :
https://help.ubuntu.com/10.04/serverguide/samba-fileserver.html

Result:
I cannot access the shared folder using any domain account.
here is smb.conf

[global]
        log file = /var/log/samba/log.%m
        load printers = no
        name resolve order = host bcast
        passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully* .
        obey pam restrictions = Yes
        map to guest = Bad User
        encrypt passwords = yes
        realm = TORONTO.local
        passwd program = /usr/bin/passwd %u
        dns proxy = No
        server string = UBUNTU-SERVER
        winbind enum users = Yes
        workgroup = TORONTO
        winbind enum groups = Yes
        security = ADS
        syslog = 0
        panic action = /usr/share/samba/panic-action %d
        max log size = 1000
        pam password change = Yes




[test]
        browseable = yes
        writeable = yes
        create mode = 0770
        path = /home/test


Thank you.
LinuxLinux NetworkingLinux Distributions

Avatar of undefined
Last Comment
PCF IT

8/22/2022 - Mon
ASKER CERTIFIED SOLUTION
PCF IT

THIS SOLUTION ONLY AVAILABLE TO MEMBERS.
View this solution by signing up for a free trial.
Members can start a 7-Day free trial and enjoy unlimited access to the platform.
See Pricing Options
Start Free Trial
GET A PERSONALIZED SOLUTION
Ask your own question & get feedback from real experts
Find out why thousands trust the EE community with their toughest problems.
I started with Experts Exchange in 2004 and it's been a mainstay of my professional computing life since. It helped me launch a career as a programmer / Oracle data analyst
William Peck