Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

2008 r2 denies local login

Posted on 2012-12-26
7
Medium Priority
?
475 Views
Last Modified: 2012-12-28
I had all users showing on the server login screen so I did the following.

1. Select Local Security Policy from Administrative Tools.
2. Expand Local Policies.
3. Select User Rights Assignment.
4. Double-click Deny log on locally to display dialog.
5. Add users or groups.
6. Click OK to save.
7. Reboot.

Then I tested and the 3 users did not show then rebooted and all was well.

Then to hide all users I accedentally put everyone as clear all users except Administrator.

It the would not allow local users to access the server.
The server is not a domain and no remote acces had been setup

Can you help ??


Dan Landry
0
Comment
Question by:DanielBLandry
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
7 Comments
 
LVL 23

Expert Comment

by:yo_bee
ID: 38723559
EDIT:  Did not read it completely.  Please ignore my suggestion.

You can try to RDP to the machine and access it that way.
Do you have RDP enabled.
0
 
LVL 23

Expert Comment

by:yo_bee
ID: 38723567
You can try Safe Mode boot and see if that works.
Also if this a production machine?
0
 

Author Comment

by:DanielBLandry
ID: 38723650
Tried safe mode and got the option go to safe mode then continued and started normally.
So I cannot login.  This is a production machine so I am in bad way.


Dan Landry
0
Are your AD admin tools letting you down?

Managing Active Directory can get complicated.  Often, the native tools for managing AD are just not up to the task.  The largest Active Directory installations in the world have relied on one tool to manage their day-to-day administration tasks: Hyena. Start your trial today.

 
LVL 42

Expert Comment

by:kevinhsieh
ID: 38724226
Have you tried reboot into the last known good configuration?

Do you have a recent backup?
0
 
LVL 12

Assisted Solution

by:Sommerblink
Sommerblink earned 999 total points
ID: 38724288
Is the built-in firewall or another firewall enabled on the computer?

If not, perhaps you can open up the registry remotely from another computer and enable terminal services?

There is a key HKLM\SYSTEM\CurrentControlSet\Control\Terminal Server\fDenyTSConnections. This is set to 1 if RD is disabled. 0 for enabled.

Otherwise, there is a program that Microsoft published called NTRights.exe (http://support.microsoft.com/kb/315276) but to be honest, I don't have an environment to give this a shot in, but the command might look like this:

ntrights -u Everyone -m \\computername -r SeDenyInteractiveLogonRight

I've never played with this before, so you might need to fine tune that, but from the commandline help file, this should remove the Everyone group from the Deny Interactive Logon Right. Also, I don't know if this program will work with a firewall enabled as well.
0
 
LVL 23

Accepted Solution

by:
yo_bee earned 501 total points
ID: 38724460
Can this server be restarted?
Do you have the ability to connect to the server HKLM hive?
if so there is a means to getting to GPEDIT.MSC

Connect to the HKLM\SYSTEM\STARTUP  and change startupType = 2 and CmdLine to cmd.exe  
Reboot and this will get you to a command prompt and it will be like it running for the first time.
In the CMD enter GPEDIT.MSC and modify the settings for Logon Locally

I just tested this on a server in my Lab and it worked.
0
 
LVL 12

Assisted Solution

by:Sommerblink
Sommerblink earned 999 total points
ID: 38728257
Not sure how it is going since you haven't responded back yet.

But just for future reference, in order to remove the user icons from the login screen, you need to disable Do not require CTRL-ALT-DEL to Logon Policy.

This is located at Computer Configuration\Policies\Windows Settings\Security Settings\Local Policies\Security Options\Interactive Logon: Do not require CTRL+ALT+DEL and set this to Disable.
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Possible fixes for Windows 7 and Windows Server 2008 updating problem. Solutions mentioned are from Microsoft themselves. I started a case with them from our Microsoft Silver Partner option to open a case and get direct support from Microsoft. If s…
Resolving an irritating Remote Desktop connection that stops your saved credentials from being used.
This tutorial will walk an individual through the steps necessary to configure their installation of BackupExec 2012 to use network shared disk space. Verify that the path to the shared storage is valid and that data can be written to that location:…
This tutorial will walk an individual through the steps necessary to join and promote the first Windows Server 2012 domain controller into an Active Directory environment running on Windows Server 2008. Determine the location of the FSMO roles by lo…

661 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question