Solved

My Documents Library/Folder redirection

Posted on 2012-12-27
5
646 Views
Last Modified: 2013-01-04
I recently did a server upgrade which ended up requiring us to remake a number of users on local machines (rename old user from the 'Users' or 'Documents and Settings' folders) and then create a new user. The users are all on a domain but the local user profiles were having issues.

We were able to get the user profiles remade but now the 'My Documents' folder doesn't point to the server location but, rather, the local 'My Documents' folder/library. If anyone has advice for getting them to point back to the proper server location, that would be great!

Thanks!
0
Comment
Question by:dkuhlman
5 Comments
 
LVL 3

Expert Comment

by:binumicrosoft
ID: 38723872
Can you please share more information about the current setup?

From Which OS to Which OS was the upgrade done?
Did you follow some white paper ?
0
 
LVL 25

Accepted Solution

by:
Tony Giangreco earned 500 total points
ID: 38723885
For each user, map the folder on the server where their docuemnts are. On each user's desktop, right click that folder and select Make Offline Always

After it completes that process, right click the Documents ink in the start menu and select properties.

Add the new folder in there, set it as the Default Save Lovation, Delete any other folder that you don;t want the usr to save to.
0
 

Author Comment

by:dkuhlman
ID: 38724129
Thank you  TG-TIS, I will attempt that

binumicrosoft, I believe the upgrade was from SBS2003 to SBS2011, we ended up having a permissions issue where users were unable to access their previous document location on the server, we reset the user profiles on the local machines and the permissions issue was no longer present. However, instead of 'my documents' pointing to something like server/usershares/username they now point to the default windows location. We can now map and access the //server/usershares/username location, so the permissions issue is gone, but I want to get the users back to having the server location be where 'my documents' points.

Thanks
0
 
LVL 14

Expert Comment

by:ThomasMcA2
ID: 38730823
The location of My Documents is defined in the Registry. To change it, change this key:

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders

Value Name: Personal
Value Type: REG_SZ

You can change that with a group policy or the reg.exe command in a script.

After changing this, any documents that were created locally  will have to be manually moved to the server share.
0
 
LVL 25

Expert Comment

by:Tony Giangreco
ID: 38730900
Hi Dkuhlman,

Did you try my solution? Did it resolve your problem?
0

Featured Post

Netscaler Common Configuration How To guides

If you use NetScaler you will want to see these guides. The NetScaler How To Guides show administrators how to get NetScaler up and configured by providing instructions for common scenarios and some not so common ones.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

If you are a user of the discontinued Microsoft Office Accounting 2008 (MSOA) and have to move to a new computer running Windows 8, you will be unhappy to discover that it won't install.  In particular, Microsoft SQL Server 2005 Express Edition (SSE…
A quick step-by-step overview of installing and configuring Carbonite Server Backup.
In this Micro Tutorial viewers will learn how to use Boot Corrector from Paragon Rescue Kit Free to identify and fix the boot problems of Windows 7/8/2012R2 etc. As an example is used Windows 2012R2 which lost its active partition flag (often happen…
The viewer will learn how to successfully download and install the SARDU utility on Windows 7, without downloading adware.

773 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question