Avatar of gregelectronics
gregelectronics
Flag for United States of America asked on

Citrix Applications will not Launch

Error: An error has occurred while connecting to the requested resource

Greetings, I have 2 Citrix Farms (XenApp 6.0 & XenApp 6.5 with XenDesktops ) where I am using a single Web Interface with Citrix Secure Gateway to access both farms. When I  logged onto either of the farms (externally) I can see a list of applications to choose from. When I click on any  application it takes a few minutes and a error is return stating an error has occurred.

1. I am able to telnet to the Web Server (CSG) on port 80 & 443
2. I have NAT setup on the Firewall to allow Ports 1494 & 2598
3. There is an SSL certificate install on the CSG
4. I am able to launch the applications internally behind the firewall
5. Have all the latest hotfixes for both farms & CSG
6. Reviewed the checklist & articles from previous questions and websites

I have checked XenApp Servers (Worker Groups)
I have checked Firewall Settings (Open Ports)
I have checked CSG Settings (Configurations pointing to Data Collector)
I have checked License (No Issues)

Surely I must be missing something (there must be something simple)
Citrix

Avatar of undefined
Last Comment
Carl Webster

8/22/2022 - Mon
Carl Webster

If you are using CSG, the ONLY port you need open on your firewall is 443.

In Web Interface, what is your Gateway setting set for?  Should be Gateway Direct.
gregelectronics

ASKER
Previously before using the CSG, I had the ALTADDR configure this is why the firewall is configured. Please note that the CSG is behind the firewall and not in the DMZ. Local Windows firewall is turned off and the Gateway settings ate configured to point to the CSG not Direct (Gateway Direct). Should it be Direct instead?
Carl Webster

You need to undo all the altaddr stuff.

Follow this article I wrote:

http://carlwebster.com/learning-the-basics-of-xa5-fp3-for-windows-server-2003-and-xs-5-6-part-10-of-12/
Experts Exchange has (a) saved my job multiple times, (b) saved me hours, days, and even weeks of work, and often (c) makes me look like a superhero! This place is MAGIC!
Walt Forbes
gregelectronics

ASKER
Thanks Carl, after changing the Firewall settings to Direct I am able to get to launch the application but I get a different error message (see attachment). "Your app is not available; try again later"

I have checked the check the XenApp settings in the farm and ensure I have a Worker Group created. There is only one server in the Work Group to minimize if it is server related. I have also remove another application from the Worker Group and only place the server as the published application same issue (Full Desktop).
Carl Webster

What XML port are you using on your XenApp servers?  Do you have the XML port specified in the web interface?

Worker Groups are flakey.
gregelectronics

ASKER
Yes I do, I am using XML 8080 and have verified that is working properly. Also the ALTADDR was removed before I installed the CSG.

What makes the XenApp to display a 5000 or 7500 from time to time?
⚡ FREE TRIAL OFFER
Try out a week of full access for free.
Find out why thousands trust the EE community with their toughest problems.
Carl Webster

Are you talking about qfarm /load?  If so, that is the load on the server when you ran the command (technically the last time the load was reported to the collector server being asked for the load numbers)..
gregelectronics

ASKER
Yes, I checked DNS to ensure I do not have any resolution issue going on. Are there any hotfixes or service packs that I missing. In the attached screenshot I can access applications without any issues, truly there must be something going on with CSG/Web and the XenApp boxes.
Internal-App.png
Carl Webster

Did you follow the article I linked earlier?
I started with Experts Exchange in 2004 and it's been a mainstay of my professional computing life since. It helped me launch a career as a programmer / Oracle data analyst
William Peck
gregelectronics

ASKER
Yes I did, I have a SSL Cert from Go Daddy and I am using IIS7 (Windows 2008 R2) as the Web Server OS. The certificate imported successfully and works fine. If the issue is IIS Port 444 vs. CSG Port 443 where do I change the post on IIS as posted (Figure 10-75)?
Carl Webster

When you install the SSL cert you give it port 444 to use for SSL.  That is what 10-75 is showing. Then CSG will use 443.
gregelectronics

ASKER
At this point for test I will remove the cert and re-import it and assigning it the Port 444 to see if this works.
⚡ FREE TRIAL OFFER
Try out a week of full access for free.
Find out why thousands trust the EE community with their toughest problems.
gregelectronics

ASKER
I have re-added the cert, same issue. Also I ran the Citix CSG Diag and not error messages found. Surely there must be an easy way to fix this issue.
Carl Webster

WHat errors are recorded on the WI/CSG server and the XenApp server?
gregelectronics

ASKER
Sorry for late respond, there are no error messages in the event logs for either WI/CSG or XenApp Servers. I believe is a configuration error on the CSG in which I am not seeing, the firewall has the proper ports open. I am able to telnet to the web server from client (externally) to port 443.

The number one question is why can the external client recieved back applications from the CSG which is talking to the XenApp Servers.
All of life is about relationships, and EE has made a viirtual community a real community. It lifts everyone's boat
William Peck
Carl Webster

gregelectronics

ASKER
Carl Thanks for all your comments, this is my setup I have a single WI/CSG with SSL (combined on same server) behind the firewall (pix 501). The proper ports are open on the firewall (80 & 443 NAT to WI/CSG), I have 2 farms XenApp 6.0 & XenApp 6.5 (all hotfixes) using the single web interface.

I have see all published applications from both farms from the Citrix receiver externally and can successfully launch the applications internally. The main issue is that attempting to launch externally the applications are not available.

There are no error messages on the Wi/CSG or XenApp servers.
ASKER CERTIFIED SOLUTION
Carl Webster

THIS SOLUTION ONLY AVAILABLE TO MEMBERS.
View this solution by signing up for a free trial.
Members can start a 7-Day free trial and enjoy unlimited access to the platform.
See Pricing Options
Start Free Trial
GET A PERSONALIZED SOLUTION
Ask your own question & get feedback from real experts
Find out why thousands trust the EE community with their toughest problems.
gregelectronics

ASKER
Yes, I used this article to setup the WI and CSG. It is straight forward however I am not sure why I am getting this result.
⚡ FREE TRIAL OFFER
Try out a week of full access for free.
Find out why thousands trust the EE community with their toughest problems.
gregelectronics

ASKER
I found an application called Citrix Diagnostic Tool to help start the troubleshooting process.
gregelectronics

ASKER
So I broke the Wi/CSG configuration and started over (Uninstalled Citix Web Interface & CSG), with just the WI installed and configure I am getting the same error message "Your App is Not Available, Try Again Later". I am only configuring one Citrix Farm at this time (XenApp 6.0). Default XML is 8080 for XenApp 6.0 and 80 for the external web (Not using the SSL Certificate at this time of testing).
Carl Webster

http://carlwebster.com/learning-the-basics-of-xa5-fp3-for-windows-server-2003-and-xs-5-6-part-9-of-12/

This article walks you thru configuring altaddr to test external access.
Your help has saved me hundreds of hours of internet surfing.
fblack61
gregelectronics

ASKER
This may some like a dump question but what server (FQDN) needs to go in the Specify Secure Ticket Authority in the settings tab? Is this the Web Server that internal users connect to or the Data Collector that the XenApp Servers respond to?
Carl Webster

The xenapp server that is the most preferred data collector.
gregelectronics

ASKER
I was able to get AltAddr working so I know it is not a Firewall issue, I believe it is completely my CSG configuration (Has to be in the secure access). I cannot believe this is being more difficult than what it should be.

With AltAddr I was able to access published applications from both Citrix Farms, but with CSG I can only view them but when I click on them application is not available. I have gone over your entire document from end to end and not sure what I am missing. I will award you the points because you have been so helpful Carl Webster. Your documents are great!
⚡ FREE TRIAL OFFER
Try out a week of full access for free.
Find out why thousands trust the EE community with their toughest problems.
Carl Webster

Thanks for the compliments.

I have never had an issue with CSG and accessing published resources.

My email address is in my profile.  If you are allowed to, send me the external link when you get CSG installed and I will see if I can see anything amiss.