Link to home
Start Free TrialLog in
Avatar of Kevin Smith
Kevin SmithFlag for United States of America

asked on

Access frontend gets hung on"calculating..." and never fully loads data

I have an Access 2007 frontend that connects to a sql server 2005 backend.  Everything's been working just fine, but now one user (XP) will open the frontend (on everyone's machine) and it'll hang up.  The status bar will stay on "calculating..." forever (well, seems like forever).  I deleted out all the linked tables and put them back in, but it even does that very, very slowly.  I even deleted the odbc connection and made a new one...same thing.  What should I look at?
Avatar of newmath
newmath
Flag of United States of America image

Have you re-compiled and compacted the front-end DB?
Avatar of Kevin Smith

ASKER

Yes I have.
Hmm, ok, what happens when you try to link tables from fresh DB? Is it still slow. Sluggish SQL connections can point to all sorts of issues. The SQL server itself may be the issue. In that case, you would need to check network saturation, disk access, etc. - system resources. Also, check the event log of the SQL server itself. See anything strange?
Avatar of Jeffrey Coachman
<now one user (XP)>
So this is only for this one user?

< will open the frontend (on everyone's machine) and it'll hang up. >
So this issue follows the "User" to each workstation...?
Make sure this rogue user has all the exact same permissions as all the other users.

JeffCoachman
ASKER CERTIFIED SOLUTION
Avatar of Kevin Smith
Kevin Smith
Flag of United States of America image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Then "your" post above is the solution...
;-)

You can accept your own solution as the answer, as this will better help other members searching here with the same issue.
;-)

Enjoy the weekend.

Jeff
The answers provided did not fix the problem, but restoring it did.  It was suggested that since that fixed the issue, then it'd be better to choose my own comment as the solution.