Solved

RemoteApp Server 2008 R2

Posted on 2012-12-27
8
1,048 Views
Last Modified: 2013-11-21
Hello,

When we deploy RemoteApp in Server 2008 R2. Upon clicking on the app:

1) Is the application opened using port 80/443  or still uses 3389?
2) Is there anyway to just move RemoteApp data on 80/443 and block 3389?
3) Is there a way to disable RDP and only enable RemoteApp. My understanding of RemoteApp is that it still uses RDP to open the Apps, but not exactly sure..

Thanks
0
Comment
Question by:masdf123
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
8 Comments
 
LVL 13

Expert Comment

by:rhinoceros
ID: 38726200
0
 
LVL 4

Expert Comment

by:jjjosef
ID: 38726216
Have a look at the article published on Expert-Exchange itself

It might be helpful for You

Expert Exchange Article

For your Third Query follow the bellow procedure
      
Go to the RDP properties in Terminal Services Configuration Console
In environment tab, select the option "Start the following program when the user....”
Path: c:\windows\system32\logoff.exe
 Start in: c:\windows\system32
0
 
LVL 1

Author Comment

by:masdf123
ID: 38726960
Can someone please answer my questions specifically?
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 77

Assisted Solution

by:Rob Williams
Rob Williams earned 334 total points
ID: 38730891
I think a general answer, will answer all 3 questions.
If you enable the TS Gateway service, when you connect to the server you use only port 443 to access the server.  You are authenticated, and then the TS Gateway server uses port 3389 internally to connect to the Terminal Server (now called Remote Desktop Services (RDS)  server, which can be but does not need to be the same server.  In this case external access to port 3389 is not needed at all, no router/firewall opening or port forwarding for port 3389 is required.  Port 3389 is only needed internally, but is needed.  Without the TS Gateway service port 3389 is required externally.  RDP is always needed, even with RemotApps, as it is the protocol/service used for accessing and communicating with the server or PC to which you are connecting.  It is possible to change the the RDP listening port to something other than 3389.

These days due to a virus that spreads via RDP and port 3389, the TS Gateway service, which uses SSL, should always be used instead of direct connections using 3389.
0
 
LVL 27

Assisted Solution

by:Steve
Steve earned 166 total points
ID: 38732529
1) Is the application opened using port 80/443  or still uses 3389?

3389

2) Is there anyway to just move RemoteApp data on 80/443 and block 3389?

Kindof. You can set RDP port to anything you like but you will find issues if it conflicts with another used port, like 443. This doesnt change how it connects, it just changes the port number.
You should try the Web Access feature of Remoteapp, as that uses port 443 (https) and may do what you want.


3) Is there a way to disable RDP and only enable RemoteApp. My understanding of RemoteApp is that it still uses RDP to open the Apps, but not exactly sure..

Again, it's a yes & no. You can use remote web apps and block port 3389 completely, or just set the TS to log users straight off if they log in directly (using login script or group policy etc.)
0
 
LVL 77

Accepted Solution

by:
Rob Williams earned 334 total points
ID: 38733133
As mentioned, if TS Gateway is used there is no need for 3389 or any other redirected port. Handshaking and Internet to server RDP traffic all uses SSL/443.
0

Featured Post

Migrating Your Company's PCs

To keep pace with competitors, businesses must keep employees productive, and that means providing them with the latest technology. This document provides the tips and tricks you need to help you migrate an outdated PC fleet to new desktops, laptops, and tablets.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

While rebooting windows server 2003 server , it's showing "active directory rebuilding indices please wait" at startup. It took a little while for this process to complete and once we logged on not all the services were started so another reboot is …
This article runs through the process of deploying a single EXE application selectively to a group of user.
To efficiently enable the rotation of USB drives for backups, storage pools need to be created. This way no matter which USB drive is installed, the backups will successfully write without any administrative intervention. Multiple USB devices need t…
Are you ready to implement Active Directory best practices without reading 300+ pages? You're in luck. In this webinar hosted by Skyport Systems, you gain insight into Microsoft's latest comprehensive guide, with tips on the best and easiest way…

710 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question