SQL problem unable to see port 1433

Pranav_IT
Pranav_IT used Ask the Experts™
on
Dear Team,

I have installed windows server 2008 R2 and SQL Enterprize Server 2008 R2 on my server.

But there is some problem ...when i run the following command.

netstat -a -n , i am not able to see the SQL port 1433 as listening.

The connections are enabled on the firewall end.

What can be the possible reson how can i switch on the Port 1433 , is there something wrong in SQL installation.


Thanks & Regards

Pranav IT
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Kamaraj SubramanianApplication Support Analyst

Commented:
you can assign a port number manually.

http://msdn.microsoft.com/en-us/library/ms177440.aspx
Qlemo"Batchelor", Developer and EE Topic Advisor
Top Expert 2015

Commented:
If you have installed a named instance, the port is usually different from 1433, and defined dynamically, as the article the above link points to mentions. In that case you either need to fix the port, and provide it with each connection if different from 1433, or let SQL Browser manage the port negotiation. SQL Browser uses 1434/udp for that, and is asked for ports of a specific instance.
Commented:
The problem is you did not configured the network protocols in the SQL server configuration manager tool you can find under the program group in the start menu.

You should enable TCP/IP and Named Pipes since AFAIK those are not enabled by default.

You'll have to restart the SQL server service in order for you to see the port.
Acronis in Gartner 2019 MQ for datacenter backup

It is an honor to be featured in Gartner 2019 Magic Quadrant for Datacenter Backup and Recovery Solutions. Gartner’s MQ sets a high standard and earning a place on their grid is a great affirmation that Acronis is delivering on our mission to protect all data, apps, and systems.

Author

Commented:
Okay I will recheck, can I remove the Enterpize 2008 R2 edition and put the Standard edition for SQL 2008 will it soilve the problem.

Author

Commented:
How can the SQL browser manage the Port negotiation, can any body help i dont want to uninstall the server.
Qlemo"Batchelor", Developer and EE Topic Advisor
Top Expert 2015

Commented:
Changing from Enterprise to Standard will not change anything in regard of protocols and ports.
Start your SQL Server Configuration Manager, go into SQL Server Network Configuration, Protocol for ..., and check if TCP is enabled. Then look into the TCP properties of that entry, tab IP Addresses. You should have either Dynamic TCP Ports set with the port number, or TCP Port. The latter is a static setting.

SQL Browser will work as long as you make sure the service named the same is running.

Commented:
seen this a lot of times, just check on the configuration manager as i told.

Author

Commented:
Hey guys just reinstalling SQL fixed the issue, the problem was we had installed the sql on some other network setup than what was actually needed, wher it was blocked.

In our new network we removed the old sql and put the new sql with new network settings and finally the issyue was resolved.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial