no mails on android mobiles from exchange 2007 (SBS2008) anymore

Hi,

we have a SBS2008 fully patched. Out mobile phones worked fine until last reboot of server. After that OWA showed only a blank page after telling that SSL-Certificate has a problem (we don´t have root-certified one. it´s ok for us). I found on the web the solution

powershell.exe -noexit UpdateOwa.ps1

. Now OWA works like always. But my Android mobile cant establish any connection to the server. So i deleted the account on the mobile and try to recreate one. When i enter all the settings it says, that there is a problem with SSL (was always so) and i say "continue". After that normally it was ready. Now it says after no time that the connection to the server could not established. Another mobile with android have the same problem.

So in short: OWA works, Outlook works and mobile (android) isn´t wokring anymore.

Any ideas ?
loosainAsked:
Who is Participating?
 
loosainConnect With a Mentor Author Commented:
I found the problem:
In IIS there was the "MSExchangeSyncAppPool"-Applicationpool disabled. I enabled it and yeppeeh it works again like charm.
The IIS-Logfile in c:\windows\system32\logfiles\httperr helped me to figure out.
0
 
TazDevil1674Connect With a Mentor Commented:
Can you try using the Browswer on the Android to access OWA?  It may help determine the problem.

you could also try browsing to the OMA site - /oma instead of /owa - i have used this to troubleshoot in the past

Any time I have seen errrors on iPhone/Andriod to do with OMA, its been SSL cert related...
0
 
loosainAuthor Commented:
It´s the same SSL cert like always. When i try to open OWA from mobile-browser, i can connect, but it always say that my loginname and/or password ist wrong. When i try to browse from browser on pc, it works...
When i try to open /oma it says after login error 404 File or folder not found.
0
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

 
loosainAuthor Commented:
Now OWA from mobile-browser works !
I have a symbol in my password. after an update on the mobile it makes a space after those symbols when typing the password. I can login via browser on the mobile.

But creating an account (exchange) is still NOT working.

In short: Outlook works, owa on pc works, owa on mobile works, creation of exchange-account on mbile not working.
0
 
cpmcomputersCommented:
Have you tried testing from this link

https://www.testexchangeconnectivity.com/

The detailed information will possibly point you in the right direction

Incidentally if you are using the internally generated cert They do expire and require renewal?
0
 
loosainAuthor Commented:
The cert is still valid (expiration 2014). Only the domain doesnt match with the domain i use because it is a dyndns. I cant make certs for dyndns. But the cert-error wasn´t a problem before. Thee mobile phone just said that there is a problem with the cert, i say continue and normally everything was fine.
The link above i tested. It only points out, that the cert is wrong (i knew this before...) everything else is fine.
0
 
loosainAuthor Commented:
Yes, i have the settings right:

serveradress: remote.domain.com
user: myinternaldomain\username
password: correct one
ssl: checked

OWA is working with these data. Only mobile isn´t.
0
 
loosainAuthor Commented:
As i wrote the needed app-pool was disabled
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.