Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1392
  • Last Modified:

Clean-MailboxDatabase command not working - Exchange 2007

I have disabled a mailbox today and I would like to reconnect it.  However, this mailbox is not showing up in disconnected mailboxes.  There is only one mailbox showing up in disconnected mailboxes no matter how many are disabled.  I read that this clean-mailboxdatabase command will resolve that.  When trying to run it I am getting the error in the picture below.

Command results
I am wondering what the issue could be here..  if anyone has an idea please let me know.
0
lpadmin1
Asked:
lpadmin1
  • 2
1 Solution
 
Manpreet SIngh KhatraSolutions Architect, Project LeadCommented:
Clean-MailboxDatabase "Db name" (please have teh DB name in quotes)

- Rancy
0
 
lpadmin1Author Commented:
Rancy you are the man, sir..  Thank you very much, cant believe I missed that.
0
 
lpadmin1Author Commented:
Thanks for the quick response!
0
 
Alan HardistyCommented:
If you also just type:

Get-mailboxdatabase | clean-mailboxdatabase

You don't have to specify a database name and you would not have had to worry about the quote marks!!
0

Featured Post

Important Lessons on Recovering from Petya

In their most recent webinar, Skyport Systems explores ways to isolate and protect critical databases to keep the core of your company safe from harm.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now