• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 971
  • Last Modified:

SBS 2003 to 2011 Migration DNS error

Hello Experts,

We're busy migrating a SBS 2003 box to SBS 2011 using Microsoft's migration wizard. We're stuck on a DNS error. I've included a screenshot of the error.

I've read through the section in the KB (http://support.microsoft.com/kb/2578426) but it did not resolve my problem. For the record this is the section of text I followed:

Sub-rule 8
The following sub-rule checks whether the local server is in the name server records on the migration source server:

Rule: Error is found in DNS Zone [DNS zone name]
Severity: Error
Description: In DNS zone [DNS zone name], your local server is not in the name server records. Migration will fail without this record. Go to http://support.microsoft.com/kb/2578426 for more details.

Actions to take if this sub-rule is violated

To resolve this sub-rule violation, integrate the DNS zone with Active Directory. To do this, follow these steps:
1.Open DNS Management Console.
2.Expand Forward Lookup Zones.
3.Right-click the zone that corresponds to your Active Directory domain name, and then click Properties.
4.On the General tab, make sure that the Type setting is set to Active Directory-Integrated and the Dynamic updates setting is set to Secure only, as shown in the following screen shot.
5.On the Name Servers tab, make sure that the source server IP address is listed and that the list contains only the IP addresses of valid working internal DNS servers. Remove any IP addresses that are not valid.

My settings look identical to the screenshot in the article. I've attached a screenshot of my DNS server settings and also the name servers tab under the properties.

Can't move forward in the migration wizard until this is resolved. Help!
  • 4
  • 4
1 Solution
I believe you need an NS record in your DNS Zone for your domain.  For instance, my domain is called tidder.local and inside my DNS Zone "tidder.local" I have an NS record set to sbs.tidder.local.

Hope that's all it is.

Looks like it's the zone wwr.jajo.com, you need to add an NS record to that zone with your local server name as the value.

EDIT: Ooops.  I doubt this applies in server 2003.  Sorry, skimming questions.  I'll come back once I take a look at one of my 2003 servers.

EDIT2: Yes, it does apply.  I see no difference in 2003 vs 2008 configuration.  But my way is the round about way of the instructions you already followed so.... that doesn't help.
So inside of the problematic DNS zone, you do have a record that looks similar to:

(same as parent folder)     Name Server (NS)     name.of.your.dns.server ?

I would think that's all that is required.  Does your server answer to other names?  Perhaps it's looking for something else.

Also, assign name servers to the _msdcs and _msdcs.domainname folders as well, see if that is possibly what it's complaining about.

Both my SBS 03 and SBS 08 servers have name servers set to the local machine for all these folders.
AnteksxmAuthor Commented:
Hey guys, thanks for the replies. It's there. Here's a screenshot of the NS record.

ns record
Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

How about the _msdcs folder under wwr.jajo.com ?  All my servers have NS records there also.
AnteksxmAuthor Commented:
Purple_Tidder, I don't see the option to create a new NS record under the _msdcs folder. I checked under other new records too.

I just noticed something else while looking at another SBS 2003 setup. The _msdcs folder looks different and has no subfolders like the one i'm wokring on. I do see that it contains an NS record but it doesn't have the DC and DOMAINS subfolders or CNAME entry. See screenshot below.

Yikes! Little more involved than just a DNS record.  Glad you found it.
AnteksxmAuthor Commented:
Found the article which resolved the problem.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

  • 4
  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now