Solved

Upgrading to wordpress 3.5 erased all posts and custom posts

Posted on 2012-12-28
15
679 Views
Last Modified: 2013-01-04
I have read the 3.5 troubleshooting master list and also searched but couldn't find anyone else who had this happen so far.

I have updated to 3.5 and this wiped all posts, custom post types, sliders etc. Basically cleaned the database I guess

Luckily I have a backupbuddy and restored it back to before the update but I have not clue how to proceed now in trying the upgrade again.

Has anyone had this happen? or know what caused this? How would I go about upgrading now without erasing all content?

Any advice would be great.

Thanks in advance
0
Comment
Question by:James-Wise
  • 8
  • 6
15 Comments
 
LVL 108

Expert Comment

by:Ray Paseur
ID: 38728392
No points for this, please, but in case you do not get an answer here, find Aaron Brazell on Facebook.  Tell him I sent you.  You'll have to pay for his support, but he wrote the book, literally, on WordPress.  Right now he is moving from Austin to Baltimore so he may be a little distracted, but if there is a quick fix, he will know about it.
0
 

Author Comment

by:James-Wise
ID: 38728411
Thanks for the suggestion ray, I will try him tough I am not sure I can afford a specialist.
0
 
LVL 70

Expert Comment

by:Jason C. Levine
ID: 38728617
Has anyone had this happen? or know what caused this? How would I go about upgrading now without erasing all content?

This shouldn't happen but it's almost impossible to know why it happened.  Things like custom post types and sliders are theme dependent.  Posts are pure database and shouldn't have been touched.

What I would do is a manual upgrade: download 3.5 and use FTP to copy the new files into place.
0
 

Author Comment

by:James-Wise
ID: 38729563
Ok i reverted back to my backup and started over. this time I did a manual update and followed the step by stem instructions from wordpress.org and this time everything goes ok until i try to go to the admin area after the update. it forces me to do a database upgrade which I cannot skip and when it is done it shows the following error:

WordPress database error: [Table 'db446353270.wp_categories' doesn't exist]
SELECT * FROM wp_categories ORDER BY cat_ID

WordPress database error: [Table 'db446353270.wp_post2cat' doesn't exist]
SELECT post_id, category_id FROM wp_post2cat GROUP BY post_id, category_id

WordPress database error: [Table 'db446353270.wp_linkcategories' doesn't exist]
SELECT cat_id, cat_name FROM wp_linkcategories

WordPress database error: [Unknown column 'link_category' in 'field list']
SELECT link_id, link_category FROM wp_links

Update Complete

Your WordPress database has been successfully updated!

After that, all of my custom posts, woocommerce products, subscriptions, users, EVERYTHING, turns into regular posts. meaning i had about 72 regular posts (blog articles) and after the database update I have 342 posts (and by their name I can see that they are what all the other things used to be), and now all my products and custom posts are empty.

any ideas??

Thanks
0
 
LVL 70

Expert Comment

by:Jason C. Levine
ID: 38729589
Which plugins are you running?
0
 

Author Comment

by:James-Wise
ID: 38729669
The list is long but this happens even when I turn them off and then update.

The main ones are:

Custom Content Type Manager
Advanced Custom Fields
Woocommerce (with added extensions)
Event Espresso (with added extensions)
0
 
LVL 70

Assisted Solution

by:Jason C. Levine
Jason C. Levine earned 500 total points
ID: 38729682
Ok, I think you are seeing an issue with CCTM.  I know ACF works with 3.5 because I use it on nearly every site and I also use Woo on a few sites and upgraded with no problems.  I don't use Event Espresso but what I do know of it, it shouldn't cause this type of issue.  

The change log for CCTM doesn't indicate an update for 3.5.  It may be the culprit but I don't have anything that would definitive verify this aside from testing on a separate site.  I certainly don't know how to fix this or even a workaround...if WP is choking on the db, it will do so regardless of the plugin being active or not. . You may want to check in with the plugin developer to see if an update is planned or to verify that 3.5 has introduced a bug.
0
What Security Threats Are You Missing?

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

 

Accepted Solution

by:
James-Wise earned 0 total points
ID: 38729930
Well that may or may not be the problem, but i cheated and worked around it.

On the wordpress 3.5 page it says:

For Version 3.5, the database version (db_version in wp_options) changed to 22441

So i just went into the database, changed it to db_version to 22441 and now it didn't ask to update my db. everything else works so it seems to be ok. I'm sure i might have problems with the next update but for now I have had enough of trying to figure this out...

Thanks again for the help!
0
 

Author Comment

by:James-Wise
ID: 38730074
I've requested that this question be closed as follows:

Accepted answer: 0 points for James-Wise's comment #a38729930
Assisted answer: 500 points for jason1178's comment #a38729682

for the following reason:

found a workaround myself. seemed to have worked.
0
 

Author Comment

by:James-Wise
ID: 38729989
I spoke too soon.

Widgets don't work. I can't open them or move them at all...
0
 
LVL 70

Expert Comment

by:Jason C. Levine
ID: 38730075
Stopping auto-close as problem is still present.
0
 
LVL 70

Expert Comment

by:Jason C. Levine
ID: 38730091
Can you run Firebug and see where the JavaScript errors are?

Edit: Just noticed you opened a new Q. What do you want to do about this one?
0
 

Author Comment

by:James-Wise
ID: 38731638
Sorry. I thought since i accepted solution you will not get the last added notice. You can close this one. I will reply on the other one. (still new here)

Thanks!
0
 
LVL 70

Expert Comment

by:Jason C. Levine
ID: 38731759
You need to close it.  I can't.
0
 

Author Closing Comment

by:James-Wise
ID: 38743254
Solution ended up being the following:<br /><br />So i just went into the database, changed it to db_version to 22441 and now it didn't ask to update my db. everything else works so it seems to be ok. I'm sure i might have problems with the next update but for now I have had enough of trying to figure this out...
0

Featured Post

Find Ransomware Secrets With All-Source Analysis

Ransomware has become a major concern for organizations; its prevalence has grown due to past successes achieved by threat actors. While each ransomware variant is different, we’ve seen some common tactics and trends used among the authors of the malware.

Join & Write a Comment

In order to have all security and back ups taken care of, WordPress users can sign up for services with WP Engine.
Password hashing is better than message digests or encryption, and you should be using it instead of message digests or encryption.  Find out why and how in this article, which supplements the original article on PHP Client Registration, Login, Logo…
The purpose of this video is to demonstrate how to set up basic WordPress SEO. This will be demonstrated using a Windows 8 PC. The plugin used will be WordPress SEO by Yoast. Go to your WordPress login page. This will look like the following: myw…
This tutorial will teach you the core code needed to finalize the addition of a watermark to your image. The viewer will use a small PHP class to learn and create a watermark.

746 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

11 Experts available now in Live!

Get 1:1 Help Now