Solved

directory not visible in DOS command window

Posted on 2012-12-29
13
301 Views
Last Modified: 2012-12-31
I have a directory c:\Users\Owner\Documents\My DVDs.  I can see this directory using Windows Explorer.  I am running Windows 7 Professional 64-bit.  If I open a DOS command window and cd to c:\Users\Owner\Documents\ and enter "dir" then I do not see the "My DVDs" directory listed in the results.  If I enter "dir /AD" then I see the "My DVDs" directory listed in the results.  Why is the "My DVDs" directory not listed when I enter "dir?"

Note that I looked at the permissions for the My DVDs folder.  The permissions are the same as all the other directories as far as I can tell.  Also, this is not a link to another folder.  This is a normal directory.  I have spoken with others who have experienced the same issue with other directories.
0
Comment
Question by:david_m_jacobson
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 5
  • 2
  • +1
13 Comments
 
LVL 95

Expert Comment

by:John Hurst
ID: 38730037
I see all the directories on my machine.

Go to Control Panel, Folder Options, View Tab

Select Show Hidden Files.
Uncheck Hide Empty Drives
Uncheck Hide Extensions

Close folder options, go back to Explorer and check that all is well.

Now open a DOS prompt (CMD), navigate to Documents with the CD command and try again.

.... Thinkpads_User
0
 

Author Comment

by:david_m_jacobson
ID: 38730040
I already had all those settings.  Again, my problem is not seeing the directory in the DOS command prompt.  I can see the directory in Windows Explorer.
0
 
LVL 75

Expert Comment

by:käµfm³d 👽
ID: 38730050
Does the directory have the hidden attribute set?
0
SharePoint Admin?

Enable Your Employees To Focus On The Core With Intuitive Onscreen Guidance That is With You At The Moment of Need.

 

Author Comment

by:david_m_jacobson
ID: 38730055
No
0
 
LVL 95

Expert Comment

by:John Hurst
ID: 38730068
I assume you are "Owner". Also, did you create the Directory called My DVDs while logged in as Owner?  Then are you running cmd.exe while logged in as Owner?

Try this.  Start, cmd.exe and then right click on cmd.exe. Select Run as Administrator. Allow cmd.exe to open and check again. Any change?

... Thinkpads_User
0
 

Author Comment

by:david_m_jacobson
ID: 38730082
I am the "Owner."  The owner of the directory "My DVDs" is "Owner."  Starting cmd.exe with "Run as Administrator" makes no difference.  I still do not see the directory in the DOS command window using "dir" but I do see the directory when I use the command "dir /AD."
0
 
LVL 95

Expert Comment

by:John Hurst
ID: 38730088
Try taking ownership of the folder again as yourself (Owner) to see if that makes a difference.

Also try running System File Checker. Run SFC /SCANNOW and allow to complete. Then restart the computer. SFC will not likely help because it fixes corrupt files, not permissions.

Also check for viruses.
... Thinkpads_User
0
 
LVL 8

Expert Comment

by:Scott Thompson
ID: 38730097
Try moving the'My DVDs' folder straight to the C:\ directory and see if it shows up there. If it does, move it back and check again. Post results.
0
 

Author Comment

by:david_m_jacobson
ID: 38731113
Thinkpads_User, I ran sfc /scannow.  It did not find any integrity violations.  No change in results.  There must be some setting on the directory making it a hidden directory because I see the directory when I use the dir /A option but I do not see the directory when I use dir without /A.  But I don't see where the directory is getting set as a hidden directory.  Can you point me to where this is set?  When I right-click on the folder in Windows Explorer and choose Properties I see the hidden checkbox unchecked.  The checkbox is disabled.

pc_solutions50501, I want to see if I can figure why I am having this problem before moving the directory.
0
 
LVL 95

Expert Comment

by:John Hurst
ID: 38731139
I don't know why the checkbox is disabled.  I checked my own system and it is not.

Windows7-Document-Properties
Are sure sure you are the owner of the file and that you as Owner set it up (Not as another user)?  

Did you try taking ownership of the folder (or folder above)?

.... Thinkpads_User
0
 
LVL 95

Expert Comment

by:John Hurst
ID: 38731213
@david_m_jacobson:

Another thing to try, and really easy, is as follows:

1. Make a new folder at the same level as My DVDs called My DVD Folder. So in Windows Explorer, they will appear beside each other.

2. Do a DIR command. You should see My DVD Folder. Please verify and post.

3. Move the files from My DVDs to My DVD Folder and delete My DVDs.  

Your problem should now be solved, but please do let us know.

.... Thinkpads_User
0
 
LVL 8

Accepted Solution

by:
Scott Thompson earned 500 total points
ID: 38731429
Try typing the following command

attrib -s -h "My DVDs"

This will take off any system and hidden attributes.

I know it works on files, don't remember if it does on directories.
0
 

Author Comment

by:david_m_jacobson
ID: 38732618
HOLY SMOKES!  YOU DID IT!  AWESOME HELP!  The following command fixed it:

attrib -s -h "My DVDs"
0

Featured Post

On Demand Webinar: Networking for the Cloud Era

Did you know SD-WANs can improve network connectivity? Check out this webinar to learn how an SD-WAN simplified, one-click tool can help you migrate and manage data in the cloud.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

OfficeMate Freezes on login or does not load after login credentials are input.
By default the complete memory dump option is disabled in windows . If we want to enable the complete memory dump for a diagnostic purpose, we have a solution for it. here we are using the registry method to enable this.
Windows 8 comes with a dramatically different user interface known as Metro. Notably missing from the new interface is a Start button and Start Menu. Many users do not like it, much preferring the interface of earlier versions — Windows 7, Windows X…
This Micro Tutorial will give you a introduction in two parts how to utilize Windows Live Movie Maker to its maximum editing capability. This will be demonstrated using Windows Live Movie Maker on Windows 7 operating system.

718 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question