Solved

Any one can answer the BGP Synchronization question ?

Posted on 2012-12-29
4
383 Views
Last Modified: 2012-12-31
Any one can answer the BGP Synchronization question ?

The topology is very simple. Router2---Router1--interface e1/1(ip address 111.1.1.1/24)

R1
router bgp 12
network 111.1.1.0 mask 255.255.255.0
 neighbor 2.2.2.2 remote-as 12
 neighbor 2.2.2.2 update-source Loopback0
router ospf 1
network 0.0.0.0 255.255.255.255 area 0

R2
router bgp 12
 synchronization
neighbor 1.1.1.1 remote-as 12
neighbor 1.1.1.1 update-source Loopback0
router ospf 1
network 0.0.0.0 255.255.255.255 area 0

R2#show ip bgp
   Network          Next Hop            Metric LocPrf Weight Path
* i111.1.1.0/24     1.1.1.1                  0    100      0 i

After R2 enabled synchronization, the network 111.1.1.0/24 in bgp table lost marker “>” in the bgp table.

Question:
In the case, synchronization rule means network 111.1.1.0/24 is inactive (meaning losing marker “>” ) in R2’ BGP table until this network goes into R2 via IGP. Now the network 111.1.1.0/24 already has gone into R2 via IGP. Why does the network 111.1.1.0/24 is still inactive in R2 BGP table after enabling synchronization in R2 ?
0
Comment
Question by:davidy2001
  • 2
4 Comments
 
LVL 3

Expert Comment

by:Teeshirt
ID: 38730694
Your topology isn't desirable to enable synchronization.

You can disable synchronization if one of the following conditions is true:

- Your AS does not pass traffic from one AS to another AS.
- All the transit routers in your AS run BGP.
0
 

Author Comment

by:davidy2001
ID: 38730966
Thanks. No matter whether I connect other additional iBGP or EBGP router to Router2, or not, the effect should be the same. The network 111.1.1.0/24 must be active ( with marker ">") , and then it can travel to next EBGP. what i am concerned is why the network 111.1.1.0/24 is not active after enabling synchronization
0
 
LVL 7

Accepted Solution

by:
Phyo HTET AUNG earned 500 total points
ID: 38732162
You are speaking ibgp and ospf between R1 and R2.
What is result of "R2#show ip bgp x.x.x.x". It's "not synchronized"?


I got troubleshooting guide from iphelp



Refer Cisco Case Studies

Hope this help.
Regards
0
 

Author Comment

by:davidy2001
ID: 38733598
Great, thanks, phyohtetaung
If eBGP connect with R2, there two ways to let 111.1.1.0/24 reach the eBGP: 1, turn off synchronization at R2, 2, redistribute the route or publish it by igp though the route is marked with "r" in bgp table.
0

Featured Post

Windows Server 2016: All you need to know

Learn about Hyper-V features that increase functionality and usability of Microsoft Windows Server 2016. Also, throughout this eBook, you’ll find some basic PowerShell examples that will help you leverage the scripts in your environments!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
WatchGuard T50 - Internet Priority Based on VLAN or User 1 51
VMware ESXi vswitch - performance question 2 80
Deny permission ACL 16 26
Ping in Fortigate 2 11
Meet the world's only “Transparent Cloud™” from Superb Internet Corporation. Now, you can experience firsthand a cloud platform that consistently outperforms Amazon Web Services (AWS), IBM’s Softlayer, and Microsoft’s Azure when it comes to CPU and …
When it comes to security, there are always trade-offs between security and convenience/ease of administration. This article examines some of the main pros and cons of using key authentication vs password authentication for hosting an SFTP server.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Internet Business Fax to Email Made Easy - With  eFax Corporate (http://www.enterprise.efax.com), you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, f…

820 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question