Solved

Cisco CME Inbound FXO calls used to work, now they disconnect immediately / Outbound still OK

Posted on 2012-12-29
23
3,065 Views
Last Modified: 2013-02-12
Experts,

In a configuration that used to work just fine, for some reason I am no longer able to receive any inbound calls in my FXO port on a 2801.

Outbound calling still works great.

I`ll get right to the configs:

voice-port 0/0/0
 supervisory disconnect dualtone mid-call
 pre-dial-delay 0
 cptone JP
 timeouts call-disconnect 1
 timeouts ringing 45
 timeouts wait-release 2
 connection plar 1999

!
voice-port 0/0/1
 supervisory disconnect dualtone mid-call
 pre-dial-delay 0
 timeouts call-disconnect 1
 timeouts ringing 45
 timeouts wait-release 2
 connection plar 1999
!




dial-peer voice 5000 voip
 destination-pattern ....
 session protocol sipv2
 session target ipv4:10.0.2.242
 incoming called-number .T
 dtmf-relay rtp-nte h245-alphanumeric
 codec g711ulaw
 fax rate disable
 fax protocol pass-through g711ulaw
!
dial-peer voice 99 pots
 translation-profile outgoing BroadVoice
 destination-pattern 99.T
 port 0/0/1
!
dial-peer voice 100 pots
 destination-pattern 0.T
 port 0/0/0
 forward-digits all
!

Open in new window



This config worked just fine for as long as I can remember.  But now when any inbound call happens, it just immediately disconnects.

Would anybody happen to have any ideas?
0
Comment
Question by:usslindstrom
  • 15
  • 8
23 Comments
 
LVL 5

Author Comment

by:usslindstrom
ID: 38730475
*Oh - and for the record, the inbound FXO problems happen when I PLAR over to a local registered phone extension and trying to send it to a back-end sip server.
0
 
LVL 15

Expert Comment

by:deepdraw
ID: 38731569
Hello! and straight to it...

connection plar 1999
there is no config for this number.
please provide more config.
with  passwords and public ip's removed...
0
 
LVL 5

Author Comment

by:usslindstrom
ID: 38731735
Thanks for chiming in here DeepDraw.  I really appreciate it when you've collaborated with me here in the past.

Please go slow with me, as I always try to understand what's happening - and not just copy/paste answers.


I have a dial-peer configured currently (Dial-Peer 5000) that comes into play:

dial-peer voice 5000 voip
 destination-pattern ....
 session protocol sipv2
 session target ipv4:10.0.2.242
 incoming called-number .T
 dtmf-relay rtp-nte h245-alphanumeric
 codec g711ulaw
 fax rate disable
 fax protocol pass-through g711ulaw
!

Open in new window


Currently, that dial-peer is pointing to a CUCM box.  I basically grab any 4 digits that get spit out (the PLAR 1999 in my case) and forward it back to the internal call manager.

What's strange, is that even when I PLAR over to an extension that's on a locally registered 7960 on the CME, the exact same thing happens.  Phones can call each other just fine, but inbound through the FXO ports get disconnected immedietly when I PLAR them to the internal extension.

*Seriously though, thanks for the collaboration on helping.
0
 
LVL 15

Expert Comment

by:deepdraw
ID: 38732340
without any more config i would try following
https://learningnetwork.cisco.com/thread/29575 advises to check the call hitting the router using.

debug voip ccappi
0
 
LVL 5

Author Comment

by:usslindstrom
ID: 38733821
Sorry for the delay in getting config up here.  Had to scrub it a bit.

Here's the CME router config.  Currently, I have removed all registered phones from it, and they're all on the internal CUCM box.

Below the config, I went ahead and pasted a dial-peer debug from the CME when an inbound FXO calls and then immediately disconnects.  The thing that's standing out to me, is the last entry "Result=NO_MATCH(-1) After All Match Rules Attempt", even though it does match the outbound dial-peer "Result=SUCCESS(0)     List of Matched Outgoing Dial-peer(s):     1: Dial-peer Tag=5000"

I attempted to grab a quick read of the link you provided, but it looks like there's some sort of monthly server maintenance currently on Cisco's servers.

Current configuration : 14194 bytes
!
! Last configuration change at 09:25:46 JST Tue Jan 1 2013 by ####
! NVRAM config last updated at 10:12:47 JST Tue Jan 1 2013 by ####
!
version 12.4
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
service internal
service compress-config
service sequence-numbers
!
hostname ####
!
boot-start-marker
boot system flash c2801-adventerprisek9-mz.124-24.T7.bin
boot-end-marker
!
logging message-counter syslog
logging buffered 4096
logging console informational
enable secret 5 $1$3SeF$BvZ./34dTtuwerL4VRd591
!
aaa new-model
!
!
aaa group server radius ####
 server #### auth-port 1645 acct-port 1646
!
aaa authentication login ####_Access group #### local
aaa authentication login ####_Access group #### local
!
!
aaa session-id common
memory-size iomem 15
clock timezone JST 9
dot11 syslog
ip source-route
!
!
!
!
ip cef
ip domain name ####.com
ip host mailrelay.####.com ####
ip name-server ####
ip name-server ####
ip multicast-routing
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
vpdn enable
!
!
!
voice rtp send-recv
!
voice service voip
 allow-connections h323 to h323
 allow-connections h323 to sip
 allow-connections sip to h323
 allow-connections sip to sip
 redirect ip2ip
 fax protocol cisco
 h323
  call start slow
 sip
  bind control source-interface FastEthernet0/0
  header-passing
  registrar server expires max 3600 min 3600
!
!
!
voice class codec 10
 codec preference 1 g711ulaw
!
!
!
!
!
!
!
!
!
!
!
!
voice register global
 mode cme
 source-address 10.0.0.1 port 5060
 max-dn 48
 max-pool 12
 authenticate register
 authenticate realm ####.com
 tftp-path flash:
 create profile sync 0052343002281559
!
!
voice translation-rule 1
 rule 1 /^.*/ /####/
!
voice translation-rule 2
 rule 1 /^99\(.......\)$/ /1208\1/
 rule 2 /^99\(..........\)$/ /1\1/
 rule 3 /^99\(.*\)/ /\1/
 rule 4 /####/ /0000/
!
voice translation-rule 3
 rule 1 /####/ /0000/
!
!
voice translation-profile ####
 translate calling 1
 translate called 2
!
voice translation-profile ####_800
 translate calling 3
!
!
voice-card 0
!
crypto pki token default removal timeout 0
!
!
!
!
memory reserve critical 512
memory free low-watermark processor 1024
username #### privilege 15 secret 5 ####
username #### privilege 15 secret 5 ####
archive
 log config
  logging enable
  logging size 500
  hidekeys
 path flash:/archive/####_cfg
 maximum 5
 write-memory
!
!
crypto isakmp policy 1
 encr aes
 hash md5
 authentication pre-share
 group 2
!
crypto isakmp policy 2
 encr 3des
 hash md5
 authentication pre-share
 group 2
crypto isakmp key #### address #### no-xauth
crypto isakmp keepalive 10
!
!
crypto ipsec transform-set ESP-AES_ESP-SHA-HMAC esp-aes esp-sha-hmac
 mode transport
crypto ipsec transform-set ESP-3DES_ESP-MD5-HMAC esp-3des esp-md5-hmac
 mode transport
crypto ipsec transform-set ESP-3DES_ESP-SHA-HMAC esp-3des esp-sha-hmac
 mode transport
!
crypto map #### 208 ipsec-isakmp
 set peer ####
 set security-association idle-time 60
 set transform-set ESP-3DES_ESP-SHA-HMAC
 match address NET_10_0_208_0
!
!
!
ip tcp window-size 1048576
!
class-map match-any P2P
 match protocol edonkey
 match protocol gnutella
 match protocol kazaa2
 match protocol winmx
class-map match-all VoiceOverIPSignaling
 match ip dscp af31
class-map match-all VoiceOverIP
 match ip dscp ef
 match protocol sip
 match protocol skinny
class-map match-any AdobeURLs
 match protocol http url "*adobe.com*"
!
!
policy-map Drop_AdobeURLs
 class AdobeURLs
   drop
policy-map VoiceOverIPPolicy
 class VoiceOverIP
    priority percent 15
  set precedence 1
 class VoiceOverIPSignaling
    bandwidth percent 5
  set precedence 1
 class class-default
    fair-queue
policy-map Drop_P2P
 class P2P
   drop
!
buffers tune automatic
!
!
!
!
interface Loopback0
 ip address 172.16.0.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 ip ospf 1 area 0
!
interface FastEthernet0/0
 description #### Fa0/0 --> #### (10.0.0.0/23)
 ip address 10.0.0.1 255.255.254.0
 ip access-group OutboundSMTP_#### in
 ip nbar protocol-discovery
 ip flow ingress
 ip pim sparse-mode
 ip nat inside
 no ip virtual-reassembly
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 7 ####
 ip ospf priority 255
 ip ospf 1 area 0
 speed 100
 full-duplex
 service-policy input Drop_AdobeURLs
 hold-queue 4096 in
 hold-queue 4096 out
!
interface FastEthernet0/1
 description #### Fa0/1 --> #### (NTT ISP / Vlan 100)
 no ip address
 speed 100
 full-duplex
 pppoe enable group global
 pppoe-client dial-pool-number 1
!
interface FastEthernet0/3/0
!
interface FastEthernet0/3/1
!
interface FastEthernet0/3/2
!
interface FastEthernet0/3/3
!
interface Vlan1
 no ip address
!
interface Dialer0
 no ip address
!
interface Dialer1
 description #### Dialer --> #### (ISP)
 mtu 1454
 bandwidth 12000
 ip address negotiated
 ip mtu 1426
 ip nbar protocol-discovery
 ip nat outside
 no ip virtual-reassembly
 encapsulation ppp
 ip tcp adjust-mss 1398
 dialer pool 1
 dialer-group 1
 no cdp enable
 ppp authentication chap pap callin
 ppp chap hostname ####
 ppp chap password 7 ####
 ppp pap sent-username #### password 7 ####
 ppp ipcp dns request accept
 ppp ipcp route default
 ppp ipcp address accept
 crypto map ####
 service-policy output Drop_P2P
!
router ospf 1
 router-id 10.0.0.1
 log-adjacency-changes
 area 0 authentication message-digest
 summary-address 10.0.0.0 255.255.240.0
 summary-address 10.0.224.0 255.255.240.0
 redistribute static subnets
 passive-interface default
 no passive-interface FastEthernet0/0
 default-information originate
!
ip forward-protocol nd
ip route 10.0.0.0 255.255.240.0 10.0.0.21 200
ip http server
no ip http secure-server
ip http path flash:/gui
!
ip flow-cache timeout active 1
ip flow-export source FastEthernet0/0
ip flow-export version 5
!
ip dns server
ip nat inside source list ####_NAT interface Dialer1 overload
ip nat inside source static udp #### 5061 interface Dialer1 5061
ip nat inside source static udp #### 5062 interface Dialer1 5062
ip nat inside source static udp #### 5063 interface Dialer1 5063
ip nat inside source static udp #### 69 interface Dialer1 69
ip nat inside source static udp #### 5060 interface Dialer1 5060
ip nat inside source static tcp #### 110 interface Dialer1 110
ip nat inside source static tcp #### 3389 interface Dialer1 3389
ip nat inside source static tcp #### 143 interface Dialer1 143
ip nat inside source static tcp #### 21 interface Dialer1 21
ip nat inside source static tcp #### 20 interface Dialer1 20
ip nat inside source static tcp #### 25 interface Dialer1 25
ip nat inside source static tcp #### 80 interface Dialer1 80
ip nat inside source static tcp #### 443 interface Dialer1 443
ip nat inside source static tcp #### 80 interface Dialer1 8080
!
ip access-list standard ####_Internal
 permit 10.0.0.0 0.0.255.255
 permit 172.16.0.0 0.0.255.255
 deny   any log
!
ip access-list extended NET_10_0_192_0
 permit ip 10.0.0.0 0.0.15.255 10.0.192.0 0.0.0.255
ip access-list extended NET_10_0_208_0
 permit ip 10.0.0.0 0.0.15.255 10.0.208.0 0.0.0.255
ip access-list extended ####_NAT
 deny   ip 10.0.0.0 0.0.255.255 10.0.0.0 0.0.255.255
 deny   ip 10.0.0.0 0.0.255.255 172.16.0.0 0.0.255.255
 deny   ip 172.16.0.0 0.0.255.255 10.0.0.0 0.0.255.255
 deny   ip 172.16.0.0 0.0.255.255 172.16.0.0 0.0.255.255
 permit ip 10.0.0.0 0.0.255.255 any
 permit ip 172.16.0.0 0.0.255.255 any
ip access-list extended ####_VPNTraffic
 permit ip 10.0.0.0 0.0.255.255 10.0.0.0 0.0.255.255
 permit icmp 10.0.0.0 0.0.255.255 10.0.0.0 0.0.255.255
 permit gre any host ####
 permit gre any host ####
ip access-list extended OutboundSMTP_####
 permit tcp any any eq smtp log
 permit tcp host #### any eq smtp log
 deny   tcp any any eq smtp log
 permit ip any any
!
logging history size 128
logging history debugging
dialer-list 1 protocol ip permit
dialer-list 10 protocol ip permit
!
!
!
!
!
snmp-server community public RO ####_Internal
snmp-server ifindex persist
snmp-server location ####
snmp-server contact ####.com
snmp-server enable traps cpu threshold
radius-server host #### auth-port 1645 acct-port 1646 key 7 ####
!
control-plane
!
!
!
voice-port 0/0/0
 supervisory disconnect dualtone mid-call
 pre-dial-delay 0
 cptone JP
 timeouts call-disconnect 1
 timeouts ringing 45
 timeouts wait-release 2
 connection plar 1999
!
voice-port 0/0/1
 supervisory disconnect dualtone mid-call
 pre-dial-delay 0
 timeouts call-disconnect 1
 timeouts ringing 45
 timeouts wait-release 2
 connection plar 1999
!
!
!
!
!
dial-peer voice 99 pots
 translation-profile outgoing BroadVoice
 destination-pattern 99.T
 port 0/0/1
!
dial-peer voice 100 pots
 destination-pattern 0.T
 port 0/0/0
 forward-digits all
!
dial-peer voice 5000 voip
 description #### --> #### (CUCM)
 destination-pattern [1-5]...
 session protocol sipv2
 session target ipv4:10.0.2.242
 incoming called-number .T
!
!
sip-ua
 no remote-party-id
 mwi-server ipv4:10.0.2.242 expires 3600 port 5060 transport udp unsolicited
 registrar ipv4:10.0.2.242 expires 3600
 sip-server ipv4:10.0.2.242
!
!
!
telephony-service
 fxo hook-flash
 max-ephones 30
 max-dn 48
 ip source-address 10.0.0.1 port 2000
 timeouts interdigit 4
 system message ####.com
 url services http://phone-xml.berbee.com/menu.xml
 load 7960-7940 P00307020200
 load 7970 SCCP70.9-2-3S
 time-zone 44
 time-format 24
 voicemail 5000
 mwi relay
 max-conferences 4 gain -6
 call-forward pattern ....
 moh music-on-hold.au
 web admin system name #### secret 5 ####
 dn-webedit
 transfer-system full-consult
 transfer-pattern ....
 secondary-dialtone 99
 after-hours block pattern 1 001 7-24
 after-hours block pattern 2 0033 7-24
 after-hours block pattern 3 0036 7-24
 after-hours block pattern 4 0037 7-24
 after-hours block pattern 5 0039 7-24
 after-hours block pattern 6 0041 7-24
 after-hours block pattern 7 0056 7-24
 after-hours block pattern 8 0061 7-24
 after-hours block pattern 9 0071 7-24
 after-hours block pattern 10 0077 7-24
 after-hours block pattern 11 0080 7-24
 after-hours block pattern 12 0081 7-24
 after-hours block pattern 13 0088 7-24
 after-hours block pattern 14 0089 7-24
 after-hours block pattern 15 0130 7-24
 after-hours block pattern 16 0140 7-24
 after-hours block pattern 17 0160 7-24
 after-hours block pattern 18 0170 7-24
 after-hours block pattern 19 0180 7-24
 after-hours block pattern 20 0190 7-24
 after-hours block pattern 21 020 7-24
 after-hours block pattern 22 050 7-24
 after-hours block pattern 23 0570 7-24
 after-hours block pattern 24 060 7-24
 after-hours block pattern 25 0910 7-24
 after-hours block pattern 26 0990 7-24
 after-hours block pattern 27 990 7-24
 after-hours block pattern 28 9919 7-24
 create cnf-files version-stamp 7960 Jan 01 2013 09:07:06
!
banner motd ^C
*************************************************************
************  Unauthorized Access is Prohibited  ************
*************************************************************

  Access to this system is for the use of authorized
  personel only.

  You are hereby advised that all actions performed are
  subject to monitoring and are being recorded.  In the
  event of any possible criminal activity, evidence will
  be turned over to proper Law Enforcement personnel,
  and offenders will be prosecuted!

  You have accessed:  $(hostname).$(domain)

*************************************************************
************  Unauthorized Access is Prohibited  ************
*************************************************************
^C
!
line con 0
 privilege level 15
 logging synchronous
 login authentication ####_Access
 transport preferred none
line aux 0
 logging synchronous
 login authentication ####_Access
line vty 0 4
 access-class ####_Internal in
 logging synchronous
 login authentication ####_Access
 transport preferred none
 transport input ssh
line vty 5 807
 access-class ####_Internal in
 logging synchronous
 login authentication ####_Access
 transport preferred none
 transport input ssh
!
scheduler allocate 20000 1000
process cpu threshold type total rising 80 interval 60
ntp master
ntp server ####
event manager environment SMTPAddress ####.com
event manager environment SMTPServer ####.com
event manager environment SMTPFooter "####.com Automated Network Health."
event manager environment LogConsole "E-mail notification of event submitted."
event manager applet SMTP_ReloadNotification
 event timer countdown name InitialDelay time 60
 action 1.0 info type routername
 action 2.0 mail server "$SMTPServer" to "$SMTPAddress" from "$SMTPAddress" subject "*** $_info_routername Reload Notification ***" body "$SMTPFooter"
 action 3.0 syslog priority notifications msg "$LogConsole"
event manager applet SMTP_ConfigChangeNotification
 event syslog pattern ".*%SYS-5-CONFIG_I.*"
 action 1.0 info type routername
 action 1.1 cli command "enable"
 action 1.2 cli command "show archive log config all"
 action 2.0 mail server "$SMTPServer" to "$SMTPAddress" from "$SMTPAddress" subject "*** $_info_routername Configuration Update ***" body "$_cli_result  $SMTPFooter"
 action 3.0 syslog priority critical msg "$LogConsole"
event manager applet SMTP_ConfigCommitNotification
 event cli pattern "(do wr.*)|(.*wr.* mem.*)|(.*copy run.* start.*)" sync no skip no occurs 1 period 5
 action 1.1 info type routername
 action 1.5 mail server "$SMTPServer" to "$SMTPAddress" from "$SMTPAddress" subject "*** $_info_routername Configuration Commited ***" body "$SMTPFooter"
 action 3.0 syslog priority critical msg "$LogConsole"
!
end

Open in new window





003665: Jan  1 01:25:27.114: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:
   Calling Number=, Called Number=, Voice-Interface=0x68242DB0,
   Timeout=TRUE, Peer Encap Type=ENCAP_VOICE, Peer Search Type=PEER_TYPE_VOICE,
   Peer Info Type=DIALPEER_INFO_SPEECH
003666: Jan  1 01:25:27.114: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:
   Match Rule=DP_MATCH_PORT;
003667: Jan  1 01:25:27.114: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:
   Result=Success(0) after DP_MATCH_PORT; Incoming Dial-peer=100
003668: Jan  1 01:25:27.114: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerSPI:exit@6170
003669: Jan  1 01:25:27.126: //-1/F5049A2C80DA/DPM/dpMatchPeersCore:
   Calling Number=, Called Number=1999, Peer Info Type=DIALPEER_INFO_SPEECH
003670: Jan  1 01:25:27.126: //-1/F5049A2C80DA/DPM/dpMatchPeersCore:
   Match Rule=DP_MATCH_DEST; Called Number=1999
003671: Jan  1 01:25:27.126: //-1/F5049A2C80DA/DPM/dpMatchCore:
   Dial String=1999, Expanded String=1999, Calling Number=
   Timeout=TRUE, Is Incoming=FALSE, Peer Info Type=DIALPEER_INFO_SPEECH
003672: Jan  1 01:25:27.130: //-1/F5049A2C80DA/DPM/MatchNextPeer:
   Result=Success(0); Outgoing Dial-peer=5000 Is Matched
003673: Jan  1 01:25:27.130: //-1/F5049A2C80DA/DPM/dpMatchPeersCore:
   Result=Success(0) after DP_MATCH_DEST
003674: Jan  1 01:25:27.130: //-1/F5049A2C80DA/DPM/dpMatchPeersMoreArg:
   Result=SUCCESS(0)
   List of Matched Outgoing Dial-peer(s):
     1: Dial-peer Tag=5000
003675: Jan  1 01:25:27.130: //-1/F5049A2C80DA/DPM/dpMatchPeersCore:
   Calling Number=, Called Number=1999, Peer Info Type=DIALPEER_INFO_SPEECH
003676: Jan  1 01:25:27.130: //-1/F5049A2C80DA/DPM/dpMatchPeersCore:
   Match Rule=DP_MATCH_DEST; Called Number=1999
003677: Jan  1 01:25:27.130: //-1/F5049A2C80DA/DPM/dpMatchCore:
   Dial String=1999, Expanded String=1999, Calling Number=
   Timeout=TRUE, Is Incoming=FALSE, Peer Info Type=DIALPEER_INFO_SPEECH
003678: Jan  1 01:25:27.130: //-1/F5049A2C80DA/DPM/MatchNextPeer:
   Result=Success(0); Outgoing Dial-peer=5000 Is Matched
003679: Jan  1 01:25:27.130: //-1/F5049A2C80DA/DPM/dpMatchPeersCore:
   Result=Success(0) after DP_MATCH_DEST
003680: Jan  1 01:25:27.130: //-1/F5049A2C80DA/DPM/dpMatchPeersMoreArg:
   Result=SUCCESS(0)
   List of Matched Outgoing Dial-peer(s):
     1: Dial-peer Tag=5000
003681: Jan  1 01:25:27.130: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
   Calling Number=1999, Called Number=1999, Peer Info Type=DIALPEER_INFO_SPEECH
003682: Jan  1 01:25:27.130: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
   Match Rule=DP_MATCH_DEST; Called Number=1999
003683: Jan  1 01:25:27.130: //-1/xxxxxxxxxxxx/DPM/dpMatchCore:
   Dial String=1999, Expanded String=1999, Calling Number=1999T
   Timeout=TRUE, Is Incoming=FALSE, Peer Info Type=DIALPEER_INFO_SPEECH
003684: Jan  1 01:25:27.130: //-1/xxxxxxxxxxxx/DPM/MatchNextPeer:
   Result=Success(0); Outgoing Dial-peer=5000 Is Matched
003685: Jan  1 01:25:27.130: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
   Result=Success(0) after DP_MATCH_DEST
003686: Jan  1 01:25:27.130: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersMoreArg:
   Result=SUCCESS(0)
   List of Matched Outgoing Dial-peer(s):
     1: Dial-peer Tag=5000
003687: Jan  1 01:25:27.130: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:
   Calling Number=1999, Called Number=, Voice-Interface=0x0,
   Timeout=TRUE, Peer Encap Type=ENCAP_VOIP, Peer Search Type=PEER_TYPE_VOICE,
   Peer Info Type=DIALPEER_INFO_SPEECH
003688: Jan  1 01:25:27.130: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:
   Match Rule=DP_MATCH_ANSWER; Calling Number=1999
003689: Jan  1 01:25:27.130: //-1/xxxxxxxxxxxx/DPM/dpMatchPeertype:
   Is Incoming=TRUE, Number Expansion=FALSE
003690: Jan  1 01:25:27.130: //-1/xxxxxxxxxxxx/DPM/dpMatchCore:
   Dial String=, Expanded String=, Calling Number=1999T
   Timeout=TRUE, Is Incoming=TRUE, Peer Info Type=DIALPEER_INFO_SPEECH
003691: Jan  1 01:25:27.130: //-1/xxxxxxxxxxxx/DPM/dpMatchCore:
   Result=-1
003692: Jan  1 01:25:27.130: //-1/xxxxxxxxxxxx/DPM/dpMatchPeertype:exit@5616
003693: Jan  1 01:25:27.130: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:
   Match Rule=DP_MATCH_ORIGINATE; Calling Number=1999
003694: Jan  1 01:25:27.130: //-1/xxxxxxxxxxxx/DPM/dpMatchPeertype:
   Is Incoming=TRUE, Number Expansion=FALSE
003695: Jan  1 01:25:27.130: //-1/xxxxxxxxxxxx/DPM/dpMatchCore:
   Dial String=, Expanded String=, Calling Number=1999T
   Timeout=TRUE, Is Incoming=TRUE, Peer Info Type=DIALPEER_INFO_SPEECH
003696: Jan  1 01:25:27.134: //-1/xxxxxxxxxxxx/DPM/MatchNextPeer:
   Result=Success(0); Incoming Dial-peer=5000 Is Matched
003697: Jan  1 01:25:27.134: //-1/xxxxxxxxxxxx/DPM/dpMatchPeertype:exit@5616
003698: Jan  1 01:25:27.134: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:
   Result=Success(0) after DP_MATCH_ORIGINATE; Incoming Dial-peer=5000
003699: Jan  1 01:25:27.134: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeer:exit@6216
003700: Jan  1 01:25:27.134: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:
   Calling Number=1999, Called Number=, Voice-Interface=0x0,
   Timeout=TRUE, Peer Encap Type=ENCAP_VOIP, Peer Search Type=PEER_TYPE_VOICE,
   Peer Info Type=DIALPEER_INFO_SPEECH
003701: Jan  1 01:25:27.134: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:
   Match Rule=DP_MATCH_ANSWER; Calling Number=1999
003702: Jan  1 01:25:27.134: //-1/xxxxxxxxxxxx/DPM/dpMatchPeertype:
   Is Incoming=TRUE, Number Expansion=FALSE
003703: Jan  1 01:25:27.134: //-1/xxxxxxxxxxxx/DPM/dpMatchCore:
   Dial String=, Expanded String=, Calling Number=1999T
   Timeout=TRUE, Is Incoming=TRUE, Peer Info Type=DIALPEER_INFO_SPEECH
003704: Jan  1 01:25:27.134: //-1/xxxxxxxxxxxx/DPM/dpMatchCore:
   Result=-1
003705: Jan  1 01:25:27.134: //-1/xxxxxxxxxxxx/DPM/dpMatchPeertype:exit@5616
003706: Jan  1 01:25:27.134: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:
   Match Rule=DP_MATCH_ORIGINATE; Calling Number=1999
003707: Jan  1 01:25:27.134: //-1/xxxxxxxxxxxx/DPM/dpMatchPeertype:
   Is Incoming=TRUE, Number Expansion=FALSE
003708: Jan  1 01:25:27.134: //-1/xxxxxxxxxxxx/DPM/dpMatchCore:
   Dial String=, Expanded String=, Calling Number=1999T
   Timeout=TRUE, Is Incoming=TRUE, Peer Info Type=DIALPEER_INFO_SPEECH
003709: Jan  1 01:25:27.134: //-1/xxxxxxxxxxxx/DPM/MatchNextPeer:
   Result=Success(0); Incoming Dial-peer=5000 Is Matched
003710: Jan  1 01:25:27.134: //-1/xxxxxxxxxxxx/DPM/dpMatchPeertype:exit@5616
003711: Jan  1 01:25:27.134: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:
   Result=Success(0) after DP_MATCH_ORIGINATE; Incoming Dial-peer=5000
003712: Jan  1 01:25:27.134: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeer:exit@6216
003713: Jan  1 01:25:27.134: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
   Calling Number=, Called Number=1999, Peer Info Type=DIALPEER_INFO_SPEECH
003714: Jan  1 01:25:27.134: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
   Match Rule=DP_MATCH_DEST; Called Number=1999
003715: Jan  1 01:25:27.134: //-1/xxxxxxxxxxxx/DPM/dpMatchCore:
   Dial String=1999, Expanded String=1999, Calling Number=
   Timeout=TRUE, Is Incoming=FALSE, Peer Info Type=DIALPEER_INFO_SPEECH
003716: Jan  1 01:25:27.134: //-1/xxxxxxxxxxxx/DPM/MatchNextPeer:
   Result=Success(0); Outgoing Dial-peer=5000 Is Matched
003717: Jan  1 01:25:27.134: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
   Result=Success(0) after DP_MATCH_DEST
003718: Jan  1 01:25:27.138: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersMoreArg:
   Result=SUCCESS(0)
   List of Matched Outgoing Dial-peer(s):
     1: Dial-peer Tag=5000
003719: Jan  1 01:25:27.138: //-1/F5049A2C80DA/DPM/dpMatchPeersCore:
   Calling Number=, Called Number=1999, Peer Info Type=DIALPEER_INFO_SPEECH
003720: Jan  1 01:25:27.138: //-1/F5049A2C80DA/DPM/dpMatchPeersCore:
   Match Rule=DP_MATCH_DEST; Called Number=1999
003721: Jan  1 01:25:27.138: //-1/F5049A2C80DA/DPM/dpMatchCore:
   Dial String=1999, Expanded String=1999, Calling Number=
   Timeout=TRUE, Is Incoming=FALSE, Peer Info Type=DIALPEER_INFO_SPEECH
003722: Jan  1 01:25:27.138: //-1/F5049A2C80DA/DPM/MatchNextPeer:
   Result=Success(0); Outgoing Dial-peer=5000 Is Matched
003723: Jan  1 01:25:27.138: //-1/F5049A2C80DA/DPM/dpMatchPeersCore:
   Result=Success(0) after DP_MATCH_DEST
003724: Jan  1 01:25:27.138: //-1/F5049A2C80DA/DPM/dpMatchPeersMoreArg:
   Result=SUCCESS(0)
   List of Matched Outgoing Dial-peer(s):
     1: Dial-peer Tag=5000
003725: Jan  1 01:25:27.158: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:
   Calling Number=[1-5]..., Called Number=, Voice-Interface=0x0,
   Timeout=TRUE, Peer Encap Type=ENCAP_VOIP, Peer Search Type=PEER_TYPE_VOICE,
   Peer Info Type=DIALPEER_INFO_SPEECH
003726: Jan  1 01:25:27.158: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:
   Match Rule=DP_MATCH_ANSWER; Calling Number=[1-5]...
003727: Jan  1 01:25:27.162: //-1/xxxxxxxxxxxx/DPM/dpMatchPeertype:
   Is Incoming=TRUE, Number Expansion=FALSE
003728: Jan  1 01:25:27.162: //-1/xxxxxxxxxxxx/DPM/dpMatchCore:
   Dial String=, Expanded String=, Calling Number=[1-5]...T
   Timeout=TRUE, Is Incoming=TRUE, Peer Info Type=DIALPEER_INFO_SPEECH
003729: Jan  1 01:25:27.162: //-1/xxxxxxxxxxxx/DPM/dpMatchCore:
   Result=-1
003730: Jan  1 01:25:27.162: //-1/xxxxxxxxxxxx/DPM/dpMatchPeertype:exit@5616
003731: Jan  1 01:25:27.162: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:
   Match Rule=DP_MATCH_ORIGINATE; Calling Number=[1-5]...
003732: Jan  1 01:25:27.162: //-1/xxxxxxxxxxxx/DPM/dpMatchPeertype:
   Is Incoming=TRUE, Number Expansion=FALSE
003733: Jan  1 01:25:27.162: //-1/xxxxxxxxxxxx/DPM/dpMatchCore:
   Dial String=, Expanded String=, Calling Number=[1-5]...T
   Timeout=TRUE, Is Incoming=TRUE, Peer Info Type=DIALPEER_INFO_SPEECH
003734: Jan  1 01:25:27.162: //-1/xxxxxxxxxxxx/DPM/dpMatchCore:
   Result=-1
USS2801A(config)#
003735: Jan  1 01:25:27.162: //-1/xxxxxxxxxxxx/DPM/dpMatchPeertype:exit@5616
003736: Jan  1 01:25:27.162: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:
   Result=NO_MATCH(-1) After All Match Rules Attempt
003737: Jan  1 01:25:27.162: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeer:exit@6216
003738: Jan  1 01:25:27.490: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:
   Calling Number=0.T, Called Number=, Voice-Interface=0x0,
   Timeout=TRUE, Peer Encap Type=ENCAP_VOIP, Peer Search Type=PEER_TYPE_VOICE,
   Peer Info Type=DIALPEER_INFO_SPEECH
003739: Jan  1 01:25:27.490: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:
   Match Rule=DP_MATCH_ANSWER; Calling Number=0.T
003740: Jan  1 01:25:27.490: //-1/xxxxxxxxxxxx/DPM/dpMatchPeertype:
   Is Incoming=TRUE, Number Expansion=FALSE
003741: Jan  1 01:25:27.490: //-1/xxxxxxxxxxxx/DPM/dpMatchCore:
   Dial String=, Expanded String=, Calling Number=0.TT
   Timeout=TRUE, Is Incoming=TRUE, Peer Info Type=DIALPEER_INFO_SPEECH
003742: Jan  1 01:25:27.490: //-1/xxxxxxxxxxxx/DPM/dpMatchCore:
   Result=-1
003743: Jan  1 01:25:27.490: //-1/xxxxxxxxxxxx/DPM/dpMatchPeertype:exit@5616
003744: Jan  1 01:25:27.490: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:
   Match Rule=DP_MATCH_ORIGINATE; Calling Number=0.T
USS2801A(config)#
003745: Jan  1 01:25:27.490: //-1/xxxxxxxxxxxx/DPM/dpMatchPeertype:
   Is Incoming=TRUE, Number Expansion=FALSE
003746: Jan  1 01:25:27.490: //-1/xxxxxxxxxxxx/DPM/dpMatchCore:
   Dial String=, Expanded String=, Calling Number=0.TT
   Timeout=TRUE, Is Incoming=TRUE, Peer Info Type=DIALPEER_INFO_SPEECH
003747: Jan  1 01:25:27.490: //-1/xxxxxxxxxxxx/DPM/dpMatchCore:
   Result=-1
003748: Jan  1 01:25:27.494: //-1/xxxxxxxxxxxx/DPM/dpMatchPeertype:exit@5616
003749: Jan  1 01:25:27.494: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:
   Result=NO_MATCH(-1) After All Match Rules Attempt
003750: Jan  1 01:25:27.494: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeer:exit@6216

Open in new window

0
 
LVL 15

Expert Comment

by:deepdraw
ID: 38734331
yeah the link was for a ccm-manager mgcp config.
You have a sip link to the cucm
im not sure how the cucm is set up but i cant see a number which is trying to call.
not sure if you need to just to give it something to play with.
voice translation-rule 1
 rule 1 /.*/ /1234567890/
voice translation-profile cucm
 translate calling 1

or try to call from cmd line
csim start 1999

why do you need
incoming called-number .T       < please try with that removed first.
0
 
LVL 5

Author Comment

by:usslindstrom
ID: 38735530
Please bare with me here...  Trying to understand what you're showing me.

When I enter these commands:
voice translation-rule 1
 rule 1 /.*/ /1234567890/
voice translation-profile cucm
 translate calling 1

Open in new window


Does that mean that any call that dials CUCM Box --> CME router would then appear as coming from "1234567890" (of course I would change this to make more sense), but in the context of the example you gave.


For the "incoming called-number .T" - it's most likely not needed, I just added it to force the dial-peer for CUCM to accept any #.  (The CME router is in Japan and has a POTS port there, where Japan's dialing usually starts with 0.T)
0
 
LVL 5

Author Comment

by:usslindstrom
ID: 38735787
BTW - thanks for the CLI command idea on testing dialing 1999.

It failed...

csim: called number = 1999, loop count = 1 ping count = 0

csim err:csim_do_test invalid major major(16) minor(0)
csim err csimDisconnected recvd DISC cid(14446)
csim: loop = 1, failed = 1
csim: call attempted = 1, setup failed = 1, tone failed = 0

Open in new window

0
 
LVL 15

Expert Comment

by:deepdraw
ID: 38737493
Does that mean that any call that dials CUCM Box --> CME router would then appear as coming from "1234567890" correct
csim
please read
http://www.markholloway.com/blog/?p=645
http://itzvoip.blogspot.co.uk/2011/01/command-1-csim-start-dial-string.html
I managed to recreate the same problem you have connecting to an asterisk sip server and after rebooting the router it had resolved, not a good answer but might resolve it!
I have also seen call manager requires a number to be called from.
Just out of interest why is this set up using sip instead of using cucm and srst
0
 
LVL 5

Author Comment

by:usslindstrom
ID: 38739302
Unfortunately a reboot didn't land me anywhere different here.

On configuring the thing as SIP instead of MGCP, it's entirely due to the fact I'm not truly a voice guy, and I'm slowly trying to piece together a system while trying to understand the inner workings.

I originally had the gateway configured as a MGCP, and the dial rules set on the CUCM box to use their respective FXO ports, but the phones kept giving me a fast-busy signal when I tried to call any external #.  Using SIP for the gateway at least got me through that portion.
0
 
LVL 15

Expert Comment

by:deepdraw
ID: 38742044
If you want to explore MGCP further then i would read up on calling search space
http://www.cisco.com/en/US/docs/voice_ip_comm/cucm/admin/3_2_1/ccmcfg/b03csspc.html

to understand sip with cucm using softphones
http://www.markholloway.com/blog/?p=1111

how is the trunk set up?
ill have a look for a good trunk page to post...

what is the output from show sip reg status on the cme?
0
What Should I Do With This Threat Intelligence?

Are you wondering if you actually need threat intelligence? The answer is yes. We explain the basics for creating useful threat intelligence.

 
LVL 5

Author Comment

by:usslindstrom
ID: 38743539
Hmm...  I think I'm going to have to work out the TFTP issues, as it looks like they've never really gone away.

But first, I'd like to personally thank you for assisting me.  I apologize that I haven't been as speedy in coming to a resolution, but I'm actively trying to understand this stuff as I go.  Thanks for giving me a helping hand on the way.

- I've zero'd out the CME configuration in regards to any telephony service, and started going through the MGCP guide you linked. - And as of right this second, I only have the following configuration (for telephony):

mgcp
mgcp bind control source-interface FastEthernet0/0
mgcp bind media source-interface FastEthernet0/0

ccm-manager mgcp
ccm-manager config server 10.0.2.242
ccm-manager config

Open in new window


I've set debugging on the ccm-manager and it looks like it's having trouble grabbing this file:     tftp://10.0.2.242/HOSTNAME.domain.com.cnf.xml     When I shoot over to the CUCM tftp file manager, I'm not seeing that file either in the list of things available.

Could it be my overall setup?  Meaning, in this particular lab, I only have a single CUCM box acting as a publisher.  Do I need to stand up a subscriber box as well?

Sorry for the basic questions.
0
 
LVL 5

Author Comment

by:usslindstrom
ID: 38743547
*Oh - the CUCM configuration is as follows:

Gateway = 2801 MGCP
Domain Name = HOSTNAME.domain.com
Module in Slot 0 = NM-4VWIC-MBRD
    Subunit 0 = VIC2-2FXO     0/0/0 LS     0/0/1 LS

Both FXO ports are unregistered.


For the CME, here is the output of "sh ccm-manager"

MGCP Domain Name: HOSTNAME.domain.com
Priority        Status                   Host
============================================================
Primary         None
First Backup    None
Second Backup   None

Current active Call Manager:    None
Backhaul/Redundant link port:   2428
Failover Interval:              30 seconds
Keepalive Interval:             15 seconds
Last keepalive sent:            18:54:10 JST Jan 4 2013 (elapsed time: 02:51:36)
Last MGCP traffic time:         20:05:44 JST Jan 4 2013 (elapsed time: 01:40:01)
Last failover time:             None
Last switchback time:           None
Switchback mode:                Graceful
MGCP Fallback mode:             Not Selected
Last MGCP Fallback start time:  None
Last MGCP Fallback end time:    None
MGCP Download Tones:            Disabled
TFTP retry count to shut Ports: 2

Backhaul/Redundant link is down
Configuration Auto-Download Information
=======================================
 No configurations downloaded
Current state: Downloading XML file
Configuration Download statistics:
        Download Attempted             : 1
          Download Successful          : 0
          Download Failed              : 0
          TFTP Download Failed         : 45
        Configuration Attempted        : 0
          Configuration Successful     : 0
          Configuration Failed(Parsing): 0
          Configuration Failed(config) : 0
Last config download command:
FAX mode: cisco
Configuration Error History:
0
 
LVL 5

Author Comment

by:usslindstrom
ID: 38746018
***** Please disregard the TFTP "fun" this box appears to be having. *****

That is a completely unrelated EE Question I will post at a later time.

I've went ahead and set everything back to a SIP/H.323 config between the CUCM and CME box.  Outbound calls work fine, but it's still stuck with the inbound calls getting dropped immediately.
0
 
LVL 15

Expert Comment

by:deepdraw
ID: 38748216
tftp://10.0.2.242/HOSTNAME.domain.com.cnf.xml

you did not set up the dns name of the cucm during the initial config.
I did have a config guide for this but i cant find it.

136: Result=SUCCESS(0)
137: List of Matched Outgoing Dial-peer(s):
138: 1: Dial-peer Tag=5000 <it finds the cucm but cant connect
165: Result=NO_MATCH(-1) After All Match Rules Attempt < looks to have given up.

Did you add the translation rule and a number for cucm to expect.
If so please re-post the debug log.
Did csim work not using ssh?
0
 
LVL 5

Author Comment

by:usslindstrom
ID: 38748330
Sec, trying to wrap my head around what you're showing me...

For these questions:

Number for CUCM to expect?
    If you don't mind me asking - what do you mean by this?  (Configure an incoming dialed number on the CME box, or a route rule on the CUCM?)  I do have the SIP trunk in the CUCM configured in the same Search Space as all of my internal phones, if that's what you're meaning.


CSIM without using ssh?
    I am at a loss here as well.  I use SSH to connect to the CME unit.  Would you like me to try the CISM command some other way?
0
 
LVL 5

Author Comment

by:usslindstrom
ID: 38748336
Here is the Gateway SIP trunk config.

I just noticed that the port may be off...  It was default, and I haven't changed it, but if I'm not mistaken, shouldn't that read "5060" for the "Signaling Port" (The first posted pic).?
CUCM-Gateway.png
CUCM-Gateway2.png
CUCM-Gateway3.png
0
 
LVL 15

Expert Comment

by:deepdraw
ID: 38748773
I do have the SIP trunk in the CUCM configured in the same Search Space as all of my internal phones, if that's what you're meaning. Yes, this is good.
 I am at a loss here as well.  I use SSH to connect to the CME unit.  Would you like me to try the CISM command some other way? Yes, CISM does not work over SSH so need another way in to test.
Pic 1 is h323 not sip.
example of h323 trunk on cme router
dial-peer voice 51 voip
 destination-pattern 11..
 session target ipv4:10.1.1.1
 codec g711ulaw
0
 
LVL 5

Author Comment

by:usslindstrom
ID: 38776626
Thank you very much for your continued patience here.  Emergencies at work have kept me from concentrating on this.

I have adapted my Dial-Peer to use "codec g711ulaw" as per your example.  I was always under the impression that H.323 & SIP were one and the same, but I obviously was wrong.  Thank you for showing me that.

Unfortunately, it's still in the same boat, where inbound calls are disconnected immediately.  I do, however, think that the problem is not in the Dial-Peer connection back to the CUCM server in this case, since when I have a phone connected directly to the CME and PLAR to its extension - I get the exact same results.

The problem would look like it's in my voice-port configurations I'm guessing then.  Does anything look out of place here?

voice-port 0/0/0
 supervisory disconnect dualtone mid-call
 pre-dial-delay 0
 cptone JP
 timeouts call-disconnect 1
 timeouts ringing 45
 timeouts wait-release 2
 connection plar 1999
!
voice-port 0/0/1
 supervisory disconnect dualtone mid-call
 pre-dial-delay 0
 timeouts call-disconnect 1
 timeouts ringing 45
 timeouts wait-release 2
 connection plar 1999
!

Open in new window

0
 
LVL 15

Accepted Solution

by:
deepdraw earned 500 total points
ID: 38777190
voice-port 2/0
 supervisory disconnect dualtone pre-connect
 supervisory answer dualtone sensitivity high
 no battery-reversal
 cptone GB
 timeouts call-disconnect 1
 timing sup-disconnect 85
 connection plar 1310
 impedance complex2
 station-id name Greg
 caller-id alerting dsp-pre-allocate

the above are my settings
caller-id alerting dsp-pre-allocate is for uk caller id

I would try setting up an h323 dial plan and remove the sip for testing.
0
 
LVL 5

Author Comment

by:usslindstrom
ID: 38874289
Many apologies on delay here.  I'm going to accept the solution, to not as keep you waiting.

Work emergencies have kept me from concentrating on this.  After reading your configuration (thank you very much) - I'm at a loss why my setup would allow this to happen.
0
 
LVL 5

Author Comment

by:usslindstrom
ID: 38874332
*Oh - and I did previously convert to H.323 as your suggestion from above.
0
 
LVL 5

Author Closing Comment

by:usslindstrom
ID: 38882783
As to not keep this EE post open even longer, I'm closing it and awarding points to DeepDraw.

His explinations provided and insite into VOIP is by and far OUTSTANDING! - I really do appreciate his assistance in gaining a better understanding on everything.

The problems described orignially are still present, but I'm going to attribute it to my "learning curve" with VOIP.
0

Featured Post

How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

Join & Write a Comment

The Zaptel people (www.zaptel.com) got kind of annoyed with the fact that they were getting bombarded with searches for the zaptel driver system for Asterisk (not to mention they own the trademark on zaptel). So, they kindly requested that Digium ch…
So you think no one can listen in on your VOIP conversations, eh? Well... if you haven't setup Secure Real Time Transport (SRTP), your voice communications can be hacked into by just about anyone! First, let's talk about the intended audience for…
This video gives you a great overview about bandwidth monitoring with SNMP and WMI with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're looking for how to monitor bandwidth using netflow or packet s…
This video demonstrates how to create an example email signature rule for a department in a company using CodeTwo Exchange Rules. The signature will be inserted beneath users' latest emails in conversations and will be displayed in users' Sent Items…

758 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

14 Experts available now in Live!

Get 1:1 Help Now